[libhandy] (78 commits) Non-fast-forward update to branch wip/exalm/paginator-animate



The branch 'wip/exalm/paginator-animate' was changed in a way that was not a fast-forward update.
NOTE: This may cause problems for people pulling from the branch. For more information,
please see:

 https://wiki.gnome.org/Git/Help/NonFastForward

Commits removed from the branch:

  8ea06b5... swipeable: Add gesture state getters
  564315e... swipe-tracker: Lazily access swipeable state
  42b4180... swipe-tracker: Remove hdy_swipe_tracker_confirm_swipe()
  072d1ef... swipe-tracker: Add hdy_swipe_tracker_shift_position()
  aa3f815... carousel-box: Rename child to widget in insert() and reorde
  61a76ea... carousel-box: Implement add() through insert()
  932946a... carousel-box: Add swipe state accessors
  3c88ae6... carousel-box: Add hdy_carousel_box_get_page_at_position()
  3fac939... carousel-box: Add hdy_carousel_box_get_current_page_index()
  749c440... carousel-box: Shift position after page changes
  be3b8a1... carousel-box: Remove hdy_carousel_box_animate()
  84e2cd3... carousel-box: Allow children to have different sizes
  a2d2c96... carousel-box: Decouple tick callback id from the animation
  05b2b4c... carousel-box: Extract animation struct
  411e60b... carousel-box: Use for loop in forall()
  e89c6d5... carousel-box: Add reveal-duration property
  c0446ca... carousel-box: Animate child addition and deletion
  e3c9f04... carousel: Add reveal-duration property
  b668401... carousel-box: Track child additions and removals
  860c0dc... carousel: Support add/remove animations for indicators

Commits added to the branch:

  e95edf4... Fix acknowledge typo in build doc (*)
  da0c5f6... expander-row: Simplify boolean parameter sanitization (*)
  460a78f... expander-row: Prevent gtk_widget_show_all() (*)
  5b4845c... view-switcher: Extend bin instead of box (*)
  8cba7e9... column: Queue resize after changing maximum width (*)
  181d521... stackable-box: Disconnect the signal handler after removing (*)
  d8dc353... stackable-box: Unset last_visible_child after removing or h (*)
  8c1a489... stackable-box: Only hide last visible child when folded (*)
  009bd8c... preferences-window: Implement remove() and forall() (*)
  91e01cc... preferences-page: Subclass GtkBin instead of GtkScrolledWin (*)
  f89df4f... preferences-page: Implement remove() and forall() (*)
  361e10b... preferences-group: Subclass GtkBin (*)
  9193341... preferences-group: Implement remove() (*)
  35a0d35... action-row: Implement remove() (*)
  b9b2c26... action-row: Don't allow adding null prefixes (*)
  2ced6f4... expander-row: Implement remove() (*)
  91ef53d... expander-row: Fix forall() (*)
  144646d... glade: Update dtd (*)
  b514935... glade: Add GladeHdyUtils (*)
  cb437a9... glade: Use utils in HdyCarousel adaptor (*)
  02655df... glade: Add a synthetic position child property for HdyCarou (*)
  88397a9... glade: Properly support HdyHeaderBar (*)
  45ba373... glade: Have proper names for HdyViewSwitcherTitle policy (*)
  e1b9691... glade: Properly support HdySearchBar (*)
  323f09c... glade: Set better default values for HdyColumn (*)
  8b21646... glade: Support HdyLeaflet and HdyDeck (*)
  ea57c78... glade: Support HdyPreferencesWindow (*)
  123603e... glade: Support HdyPreferencesPage (*)
  0d82b88... glade: Mark HdyPreferencessGroup properties as translatable (*)
  b04befb... glade: Support HdyExpanderRow (*)
  6f9cf34... debian: Drop handy-1-examples's dep on libhandy-0.0-0 (*)
  ff617e8... example: Replace deprecated Dialer with Keypad in example.p (*)
  9264653... example: Add some spacing between widgets (*)
  8157ecc... Separate public and private enums (*)
  48e6c47... Adding new example apps using libhandy. (*)
  d2b5e3d... Update .gitlab-ci.yml (*)
  438bd79... Update .gitlab-ci.yml (*)
  797957d... Update .gitlab-ci.yml (*)
  f3fe15a... glade: Make the Flatpak manifest use Glade 3.36 (*)
  887beed... glade: Adapt to Glade 3.36 API changes (*)
  d08c587... glade: Support both 3.24 and 3.36 (*)
  a8008fe... navigation-direction: Add HdyDeck in doc (*)
  2217595... Bump the version to 0.80.0 (*)
  a551b8b... debian: Bump the 0.9.90 symbols to 0.80.0 (*)
  b61eefd... Release libhandy 0.80.0 (*)
  0e19baf... adwaita: Fix nested list bottom rounding (*)
  54d36f0... theme: Move window corners to Adwaita (*)
  59b51e9... theme: Split shared style into shared and fallback (*)
  f763716... theme: Introduce HighContrast style (*)
  87c0b2d... theme: Adjust leaflet/deck shadow for dark and HC (*)
  8592f86... doap: Update the maintainers' email (*)
  a8a2a8c... Switch CI to GNOME (*)
  f10626c... gitlab-ci: Use eatmydata to speed up package installation (*)
  8c5f5d4... gitlab-ci: Don't bother updating manual page catalogs (*)
  885e0dd... examples: Enable tests, introspection and VAPI (*)
  2ae9365... glade: use 3.36.0 instead of gnome-3-36 HEAD (*)
  59249ee... ci: Speed up api-visibility job (*)
  295a705... ci: Migrate to GNOME CI template for Flatpak (*)
  bf9f228... swipeable: Add gesture state getters
  33e6592... swipe-tracker: Lazily access swipeable state
  a07f389... swipe-tracker: Remove hdy_swipe_tracker_confirm_swipe()
  db577c1... swipe-tracker: Add hdy_swipe_tracker_shift_position()
  65f0694... carousel-box: Rename child to widget in insert() and reorde
  63bcfbe... carousel-box: Implement add() through insert()
  b0627a6... carousel-box: Add swipe state accessors
  0ee893e... carousel-box: Add hdy_carousel_box_get_page_at_position()
  d68cc8c... carousel-box: Add hdy_carousel_box_get_current_page_index()
  944b729... carousel-box: Shift position after page changes
  1160ab5... carousel-box: Remove hdy_carousel_box_animate()
  fb10ee7... carousel-box: Allow children to have different sizes
  1fd88f5... carousel-box: Decouple tick callback id from the animation
  92ae139... carousel-box: Extract animation struct
  46d8f3d... carousel-box: Use for loop in forall()
  c1a9074... carousel-box: Add reveal-duration property
  9f71d6e... carousel-box: Animate child addition and deletion
  3738a1a... carousel: Add reveal-duration property
  cef3a29... carousel-box: Track child additions and removals
  25d7e0d... carousel: Support add/remove animations for indicators

(*) This commit already existed in another branch; no separate mail sent


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]