[gtk] (171 commits) Non-fast-forward update to branch wip/jimmac/adwaitadark-lighten-switches



The branch 'wip/jimmac/adwaitadark-lighten-switches' was changed in a way that was not a fast-forward update.
NOTE: This may cause problems for people pulling from the branch. For more information,
please see:

 https://wiki.gnome.org/Git/Help/NonFastForward

Commits removed from the branch:

  d3150f1... Adwaita: dark switches/check/radios

Commits added to the branch:

  823714c... filechooser: Fix crash when file has no content-type (*)
  8cb45cd... filechooser: Fallback if content-type unavailable (*)
  46ba019... builder-tool: rename show-close-button to show-title-button (*)
  d7fb33c... filechooserwidget: Avoid criticals when in recent mode (*)
  0e8850b... examples: Add common_cflags to build (*)
  d1cd6aa... tests: Add common_cflags to build (*)
  83982a2... testuite/gsk: Add common_cflags to build (*)
  b3c332a... testsuite/performance: Add common_cflags to build (*)
  79c60bb... testsuite/gdk: Add common_cflags to build (*)
  01bd791... testsuite/css: Add common_cflags to build (*)
  e759358... testsuite/a11y: Add common_cflags to build (*)
  6fcd5d5... testsuite/reftests: Add common_cflags to build (*)
  5d1e006... demos/constraint-editor: Add common_cflags to build (*)
  e444d73... demos/icon-browser: Add common_cflags to build (*)
  6f6ed1e... demos/node-editor: Add common_cflags to build (*)
  3c28f6d... demos/widget-factory: Add common_cflags to build (*)
  948ab27... Merge branch 'master' into 'master' (*)
  049f841... padcontroller: Copy action entries (*)
  dc36c21... demos/gtk-demo: Add common_cflags to build (*)
  7789d0e... builder: Make object names a const array (*)
  7553649... testsuite/gtk: Add common_cflags to build (*)
  5858b56... Update Japanese translation (*)
  2da445f... Update Japanese translation (*)
  4232cbe... Really fix annotation for GtkDropTarget.get_gtypes() (*)
  4af0531... Fix annotation for GdkContentFormats.get_gtypes() (*)
  8742d42... Merge branch 'wip/ricotz/annotations' into 'master' (*)
  7de6211... Fix message for VFL parser errors (*)
  ff0909f... Merge branch 'vfl-error' into 'master' (*)
  d70c945... disable popover test (*)
  6f36d98... Drop gtk_window_begin_move/resize_drag (*)
  ad322c1... testsuite: Stop using GtkSpinner::active (*)
  c488e86... testsuite: Update a11y test output (*)
  78d71eb... Simplify surface move/drag api (*)
  c2f25c0... wayland: Stop calling frontend surface api (*)
  fe35831... Move GdkSurface autocleanup declaration (*)
  0791363... popuplayout: Add docs (*)
  aee8a02... Introduce GdkPopup (*)
  530dd5a... surface: Implement GdkPopup (*)
  b670bf5... popover: Use GdkPopup (*)
  4e8dfdf... tooltip: Use GdkPopup (*)
  dc4f751... surface: Drop popup api (*)
  5acbfce... wayland: Stop abusing type hints (*)
  b1fb049... x11: Stop abusing type hints for dnd (*)
  3276021... broadway: Stop using gdk_surface_raise (*)
  2a6c085... x11: Stop using gdk_surface_raise (*)
  513eb11... inspector: Stop raising and lowering windows (*)
  29606af... wayland: Stop using gdk_surface_set_geometry_hints (*)
  78ed520... x11: Stop using gdk_surface_set_geometry_hints (*)
  72fdf54... x11: Stop using gdk_surface_maximize (*)
  b2ae6ce... surface: Rename gdk_surface_input_shape_combine_region (*)
  6c44f7b... wayland: Stop tracking orphan dialogs (*)
  ec0fb44... a11y: Stop using type hints (*)
  aec3705... testsuite: Stop using type-hint (*)
  66669e0... headerbar: Stop looking at type hints (*)
  ef9d761... shortcutswindow: Stop setting type hints (*)
  2ae3b46... Stop setting type hints for dialogs (*)
  eefedcc... x11: Set type hints based on surface type (*)
  11c9106... window: Drop type hints (*)
  e7ef4a5... testsuite: Stop using type-hints (*)
  822d672... Replace a few more fallthrough comments (*)
  73d8f6a... build: Add -Wno-typedef-redefinition to build (*)
  3830e76... Docs: Refer to GtkWidget::can_target in migration guide (*)
  c0c3870... Introduce GdkToplevelLayout (*)
  dfbde3d... Introduce GdkToplevel (*)
  9266881... window: Use GdkToplevel (*)
  6edff8c... gtk: use toplevel state getter (*)
  f78f865... x11: Stop using gdk_surface_get_state (*)
  f90c0cc... a11y: Stop using gdk_surface_get_state (*)
  703d696... demo: stop using gdk_surface_get_state (*)
  8e0ad72... testgtk: Stop using gdk_surface_get_state (*)
  f7aec64... wayland: Stop using gdk_surface_set_title (*)
  8ea8080... testgtk: Stop using gdk_surface_set_icon_name (*)
  496bd57... tests: Stop using gdk_surface_fullscreen (*)
  a79b6fb... testgtk: Stop setting decorations and functions (*)
  c67d426... docs: Stop using gdk_surface_get_decorations (*)
  3a4e647... surface: Drop redundant toplevel api (*)
  b25be8a... Add a GdkDragSurface interface (*)
  ceefe34... gtkdragicon: Use drag surface api (*)
  d6be419... Drop gdk_surface_show and gdk_surface_resize (*)
  412a593... widget: Stop using gdk_surface_set_opacity (*)
  fafddde... x11: Stop using gdk_surface_set_opacity (*)
  b3cabe6... Drop gdk_surface_set_opacity (*)
  cd773e7... wayland: Implement GdkPopup, GdkToplevel and GdkDragSurface (*)
  bf08bf6... x11: Implement GdkPopup, GdkToplevel and GdkDragSurface (*)
  34ff8f3... Merge branch 'migration-can-target-docs' into 'master' (*)
  4c06c3b... broadway: Implement GdkPopup, GdkToplevel and GdkDragSurfac (*)
  84095fe... x11: Only use state of toplevels (*)
  c00ec40... surface: Don't implement subtypes in the frontend (*)
  70e45aa... surface: Stop using surface types (*)
  5a516f2... wayland: Stop using surface types (*)
  0616fe0... x11: Stop using gdk_surface_get_surface_type (*)
  df223ae... broadway: Stop using surface type (*)
  763321e... x11: Stop using surface-type (*)
  a2dbc72... wayland: Stop using surface-type (*)
  90dfca2... gdk: Drop surface-type (*)
  b2c5d77... x11: Stop using gdk_surface_show (*)
  7e15a13... wayland: Drop dead code (*)
  90ff8ca... broadway: Stop using gdk_surface_show (*)
  4dc27ee... win32: Stop using gdk_surface_show (*)
  8b57092... surface: Drop gdk_surface_show (*)
  b6c8cf7... broadway: Drop some unused vuncs (*)
  3654c05... x11: Drop some unused vfuncs (*)
  651b746... wayland: Drop some unused vfuncs (*)
  fe19ad7... win32: Drop some unused vfuncs (*)
  b05408f... quartz: Drop unused vfuncs (*)
  b7f51a3... surface: Drop unused vfuncs (*)
  81be6ff... Move edge-constraints to GdkToplevel (*)
  f020d77... Move fullscreen-mode to GdkToplevel (*)
  641c8f3... Drop mwm hints from api (*)
  3e06a9b... Drop root coordinates from _gdk_device_query_state (*)
  31d2b68... popup: require GdkSurface (*)
  f005dfa... toplevel: require GdkSurface (*)
  25b9090... surface: document gdk_surface_translate_coordinates (*)
  7fd60ab... Fix up gdk docs (*)
  2b2d6bf... win32: implement subtypes (*)
  1963ff2... gtk: Tweak GTK_ALIGN_BASELINE docs (*)
  2fe2340... Merge branch 'align-docs-fixes' into 'master' (*)
  19e2ab7... win32: Build fixes (*)
  179b39e... Merge branch 'wip/hadess/fix-remote-filechooser-main' into  (*)
  9d98707... Merge branch 'present-toplevel-2' into 'master' (*)
  c507667... a11y: Drop the private from GtkPopoverAccessible (*)
  086a577... broadway: Handle browser hidpi scale factor (*)
  a4b718d... broadway: Fix image updates for firefox (*)
  43598fc... broadway: Ensure images are decoded, not only loaded (*)
  1a763c4... broadway: Correctly track surface visibility in client (*)
  03d6d27... broadway: Track surface position correctly (*)
  b74a26b... broadway: Keep popups above their parent (*)
  9e28297... broadway: Inherit frame clock from parent surface (*)
  97d189d... Merge branch 'popover-accessible-private' into 'master' (*)
  9aa270f... Merge branch 'update-broadway' into 'master' (*)
  331069f... wayland: Stop capping cursor scales (*)
  eaf9f7e... Merge branch 'wayland-max-cursor-scale' into 'master' (*)
  265d9c8... Update POTFILES.in (*)
  66a0a8d... Merge branch 'wip/baedert/test-cflags' into 'master' (*)
  8fd51d7... testsuite: Actually run tools tests (*)
  4b71ed3... testsuite: Update tools tests (*)
  bc6953a... testsuite: Update the settings test output (*)
  8b1301c... Update the ui file conversion output (*)
  7db490e... testsuite: Specify the test protocol (*)
  33db28c... Merge branch 'fix-tools-tests' into 'master' (*)
  8010bc4... x11: Update surface size for popups too (*)
  60a9e9d... Merge branch 'x11-resize' into 'master' (*)
  c2e5aed... NEWS: Updates (*)
  0c25b4c... Update gtk docs (*)
  4be675b... Small documentation fixes (*)
  0d3df4f... Document gdk_toplevel_set_modal (*)
  50c2b80... gdk: Documentation fixes (*)
  dfda880... window: Drop gtk_window_set_attached_to (*)
  951f821... Merge branch 'window-attach' into 'master' (*)
  d4f49a8... tests: Stop sticking windows (*)
  fb7ef8f... window: Drop sticky (*)
  60ea971... Drop GdkToplevel:sticky (*)
  103ef3c... tests: Stop using keep above/below (*)
  6f156da... window: Drop keep above/below (*)
  32b9dd6... Drop GdkToplevel:keep-above/below (*)
  c9ec1c6... Drop focus-related properties (*)
  1576cce... Drop GdkToplevel:accept-focus/:focus-on-map (*)
  c6cc026... Merge branch 'x11-props' into 'master' (*)
  5343ec3... imcontextwayland: Honour len argument in gtk_im_context_way (*)
  5bf51ad... Merge branch 'respect-text-len-gtk4' into 'master' (*)
  4d7f0f3... emojichooser: Make the variation picker work again (*)
  292cea7... Adwaita: Fix focus in emoji chooser (*)
  5d4b46b... Merge branch 'emoji-chooser-fixes' into 'master' (*)
  4359926... Adwaita: dark switches/check/radios (*)
  826f237... Merge branch 'wip/jimmac/adwaitadark-lighten-switches' (*)
  8fab4ce... Assorted migration guide updates (*)
  6eb848f... popover: Add keynav keybindings (*)
  01568dc... Revert "Adwaita: dark switches/check/radios" (*)
  7a46157... window: Set min size properly (*)
  3408ff1... emojichooser: Fix keynav (*)
  c91dd2c... Adwaita: dark switches/check/radios

(*) This commit already existed in another branch; no separate mail sent


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]