[gnome-games] (129 commits) Non-fast-forward update to branch wip/exalm/n64



The branch 'wip/exalm/n64' was changed in a way that was not a fast-forward update.
NOTE: This may cause problems for people pulling from the branch. For more information,
please see:

 https://wiki.gnome.org/Git/Help/NonFastForward

Commits removed from the branch:

  10341b3... flatpak: Use opengl branch of retro-gtk
  e632b01... flatpak: Add ParaLLel N64 core
  97feaff... Introduce Nintendo 64 plugin
  b0fef64... nintendo-64: Handle controller paks

Commits added to the branch:

  f0af2d7... build: Use libhandy master (*)
  465d9a1... ui: Stop manually adding/removing folded style class (*)
  ecc7792... preferences-window: Enable swipe gesture for leaflet (*)
  1802b2b... preferences-window: Use extra boxes for subpage (*)
  8ea25fa... preferences-window: Don't call leaflets boxes (*)
  b0a2f41... preferences-window: Implement back swipe for subpages (*)
  ba4d267... ui: Implement back swipe for collection subviews (*)
  e0bb705... Updated Spanish translation (*)
  21ff0d9... nintendo-ds: Added database file for overriding gaps (*)
  b6b8937... media-set: Make get_media() public (*)
  6f2a37c... nintendo-ds: Set screen gap for top/bottom screen layout (*)
  3948400... Update Italian translation (*)
  f9883b9... preferences-subpage-gamepad: Fix info message (*)
  49b7a97... preferences-subpage-keyboard: Unify info message handling w (*)
  98ef61f... generic-input-capabilities: Add get_allow_gamepad_mode() (*)
  7bf80bd... input-capabilities: Add interface for get_allow_gamepad_mod (*)
  3fbe37b... retro-runner: Ensure correct input mode when starting (*)
  7473656... ms-dos: Disable gamepad input (*)
  0e69219... gamepad-view-configuration: Define namespace explicitly (*)
  6d46214... gamepad-view-configuration: Unify configuration for gamepad (*)
  8bc2ee5... gamepad-view: Use a hashtable for storing input data (*)
  c59ea58... gamepad-view: Draw each button only once (*)
  794362d... gamepad-view: Support drawing background elements (*)
  80b601b... gamepad-view-configuration: Rename inputs to buttons (*)
  c10ebdf... gamepad-view: Support analog sticks (*)
  e43979a... gamepad: Update gamepad svg and configuration (*)
  5ccf2a7... gamepad-tester: Show analog stick position precisely (*)
  c52e353... gamepad-mapper: Animate analog sticks when mapping them (*)
  3d7b158... Update Swedish translation (*)
  bf66c84... Update Brazilian Portuguese translation (*)
  b71c2a2... dummy: Remove DummyGame (*)
  e2ef49d... database: Remove DatabaseGame (*)
  cf93cea... Remove GenericGame and make Game a class (*)
  b300d15... desktop: Remove DesktopUid (*)
  8f0d38c... dreamcast: Remove DreamcastUid (*)
  7817be3... game-cube: Remove GameCubeUid (*)
  150d74c... libretro: Remove LibretroUid (*)
  79fdf24... playstation: Remove PlayStationUid (*)
  60afe5e... sega-saturn: Remove SegaSaturnUid (*)
  de3982d... steam: Remove SteamUid (*)
  62d319e... wii: Remove WiiUid (*)
  85732c4... fingerprint: Drop FingerprintUid (*)
  0965063... dummy: Remove DummyUid (*)
  14ca082... Make Uid a class and remove GenericUid (*)
  5409e32... game-thumbnail: Remove uid (*)
  59139de... uid: Don't throw errors for get_uid() (*)
  c1c98bc... retro-runner: Simplify construction (*)
  66106a0... retro-runner: Store game (*)
  fe37996... game: Make uid a property (*)
  d8d5f25... game: Make uri a property (*)
  df31dae... game: Make platform a property (*)
  2627779... game: Make media set a property (*)
  6cdb52d... uid: Rename get_uid() to to_string() (*)
  d183652... uid: Add Uid.hash() (*)
  0e733da... uid: Add Uid.equal() (*)
  f60c9e0... game-model: Move compare func to Game (*)
  62e6ad2... game: Use Platform.compare() instead of reinventing it (*)
  5d96b42... platform-model: Use Platform.compare() instead of reinventi (*)
  d8c4df9... uid: Add Uid.compare() (*)
  41f739b... Update Indonesian translation (*)
  2175b31... display-view: Grab focus for CoreView immediately after foc (*)
  ba77a33... Update Dutch translation (*)
  c8eec60... data: Remove application/x-desktop from desktop file MimeTy (*)
  dc8205f... retro-runner: Remove capture_current_state_pixbuf() (*)
  60ae965... savestate: Make prepare_empty_savestate_in_tmp() private (*)
  8e560ce... display-view: Rename try_run_with_cancellable() to start_or (*)
  5d516b6... display-view: Remove a redundant can_resume check (*)
  4d834d8... display-view: Simplify starting the game (*)
  14434d1... retro-runner: Create display in construct block (*)
  a56b8c4... core: Add RunnerError (*)
  b7b2bbd... runner: Throw errors from try_init_phase_one() (*)
  d9c9f6f... retro-runner: Move get_unsupported_system_message() next to (*)
  0d55a0f... runner: Rename try_init_phase_one() to prepare() (*)
  451b46e... retro-runner: Merge init_phase_one() into prepare() (*)
  309ed24... retro-runner: Load savestate metadata in prepare() (*)
  ead2969... savestate: Pass Game to get_game_savestates() (*)
  69d5fd8... savestate: Add compare() (*)
  c4a568b... savestate: Make load() public (*)
  752e976... core: Introduce SnapshotManager (*)
  5a550d2... retro-runner: Use SnapshotManager.get_savestates() (*)
  21f41ce... savestate: Remove get_game_savestates() (*)
  2a99885... retro-runner: Move retro-specific snapshot creation to save (*)
  f59a928... retro-runner: Rename save_savestate_metadata() to save_to_s (*)
  c5a8526... retro-runner: Generalize save_screenshot_in_tmp() (*)
  fe4713d... retro-runner: Move save_screenshot() to where it's used (*)
  9882142... retro-runner: Merge store_save_ram_in_tmp() into save_to_sn (*)
  f8e76c1... retro-runner: Remove an extra blank line (*)
  4e0ef66... retro-runner: Make create_savestate() not depend on tmp_liv (*)
  975f6eb... snapshot-manager: Move snapshot creation from RetroRunner (*)
  84a9d76... retro-runner: Get rid of tmp_live_savestate (*)
  ceaed83... savestate: Remove unused functions (*)
  fa477bd... retro-runner: Move snapshot deletion to SnapshotManager (*)
  c336452... retro-runner: Stop storing the list of snapshots (*)
  b79f33f... retro-runner: Stop passing save dir around (*)
  afad4ea... retro-runner: Don't duplicate core.get_can_access_state() (*)
  2b2c801... savestate: Add missing license header (*)
  74213fc... retro-runner: Reset metadata when restarting (*)
  4bdcf2e... retro-runner: Only reset metadata on start() when not ready (*)
  832e6f2... display-view: Start the game even if resuming (*)
  e43490f... retro-runner: Call through to resume() in start() (*)
  184ad44... retro-runner: Don't instantiate in start() (*)
  f3a8e19... retro-core: Move instantiate_core() and prepare_core() to w (*)
  5736725... retro-runner: Have clearer names for is_initialized and rea (*)
  8b98b79... retro-runner: Don't set booleans to false in construct (*)
  f0575d0... retro-runner: Reset metadata when preparing, load save ram  (*)
  eed013e... retro-runner: Remove save_ram_and_dir_set (*)
  2a1a880... retro-runner: Do actual loading in load_savestate_metadata( (*)
  4df111a... runner: Throw an error in restart() (*)
  851b788... retro-runner: Move on_video_filter_changed() to where it's  (*)
  659b172... retro-runner: Merge instantiate_core() into prepare_core() (*)
  503b27e... retro-runner: Reorder functions to match Runner better (*)
  f083eb6... retro-runner: Use newly created snapshot when restarting (*)
  1bd8943... retro-runner: Make latest_savestate local (*)
  5fc5c2f... retro-runner: Don't set running to false in prepare_core() (*)
  994f59f... retro-runner: Include pause() into deinit() (*)
  097a3af... retro-runner: Move deinit() to where it's used (*)
  e184474... retro-runner: Explicitly pause/resume when restarting (*)
  c494630... retro-runner: Rename reset_metadata() to reset_with_snapsho (*)
  f58758c... retro-runner: Rename load_savestate_metadata() to load_from (*)
  84b87f8... ui: Rename SavestateListBoxRow to SnapshotRow (*)
  674314b... ui: Rename SavestatesList to SnapshotsList (*)
  a704d3b... runner: Rename supports_savestates to supports_snapshots (*)
  14d8378... runner: Rename new_savestate_created() to snapshot_created( (*)
  5e655bc... nintendo-ds: Rename NintendoDsSavestate to NintendoDsSnapsh (*)
  9206101... core: Rename Savestate to Snapshot (*)
  425e062... flatpak: Use opengl branch of retro-gtk
  32434ce... flatpak: Add ParaLLel N64 core
  349c56e... Introduce Nintendo 64 plugin
  4af6ada... nintendo-64: Handle controller paks

(*) This commit already existed in another branch; no separate mail sent


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]