[gtk] (126 commits) Non-fast-forward update to branch wip/otte/dnd



The branch 'wip/otte/dnd' was changed in a way that was not a fast-forward update.
NOTE: This may cause problems for people pulling from the branch. For more information,
please see:

 https://wiki.gnome.org/Git/Help/NonFastForward

Commits removed from the branch:

  096aafc... testsuite: Use g_assert() in tests
  5be975b... treeview, iconview: Don't return the drop target
  875cec6... textview: Move drop scrolling to drop motion controller
  fb3cccb... notebook: Make dnd page switching a drop controller
  b5b65e8... placessidebar: Don't use the GdkDrag
  ba42cb2... droptarget: Redo
  267823e... gtk-demo: Add a simple peg solitaire DND demo

Commits added to the branch:

  5f070ff... Remove filename/URI API from GtkFileChooser (*)
  d505573... Drop GtkFileChooser:extra-widget (*)
  063ad28... Remove overwrite confirmation machinery from GtkFileChooser (*)
  516eab5... Remove GtkFileChooser:show-hidden (*)
  b09e7df... Remove GtkFileChooser:local-only (*)
  4a37429... Remove GTK_FILE_CHOOSER_ACTION_CREATE_FOLDER (*)
  6e699e3... Remove GtkPlacesView:local-only (*)
  ebd2373... Remove GtkPlacesSidebar:local-only (*)
  e5ef26e... Remove GtkFileChooserEntry:local-only (*)
  ff6772f... Remove preview widget from GtkFileChooser (*)
  9bf03cf... docs: Add migration notes for GtkFileChooser (*)
  9036d49... Merge branch 'wip/otte/dnd' into 'master' (*)
  9d2d4a6... Update POTFILES.in (*)
  e123853... build: Install Valgrind suppressions files (*)
  247a68d... broadway: Remove SURFACE_IS_TOPLEVEL (*)
  5af865f... Merge branch 'matthiasc/for-master' into 'master' (*)
  78d63a4... Merge branch '138-gtk4-install-valgrind-suppressions' into  (*)
  7f46b25... Merge branch 'wip/ebassi/filechooser-new' into 'master' (*)
  3735c9d... Fix the build with docs (*)
  4ca0a93... Add a getter for GdkAppLaunchContext::display (*)
  9ce6e98... device: Add missing getters (*)
  6be9e44... gdk: Drop GdkDevice::input-mode and rename ::input-source (*)
  ec76f65... surface: Add a getter for autohide (*)
  3c95798... Add missing GdkDrag getters (*)
  90fb0ca... Merge branch 'getters-and-setters' into 'master' (*)
  96b7c5f... Add gdk_surface_get_mapped (*)
  7a39f2d... Replace gdk_surface_is_visible by _get_mapped (*)
  6fb50cc... Drop gdk_surface_is_visible (*)
  259f465... Merge branch 'surface-get-mapped' into 'master' (*)
  a43d13a... popover: Drop ::relative-to (*)
  8628c57... Drop rtl variants of media-playback-start (*)
  52c948e... Merge branch 'kill-popover-relative-to' into 'master' (*)
  00f6d1c... Merge branch 'kill-rtl-media-icons' into 'master' (*)
  e73a407... Rename GtkSpinner::active to ::spinning (*)
  9d80db2... Merge branch 'spinning-spinner' into 'master' (*)
  648a670... testsuite: Remove outdated exclusions (*)
  1b278b0... colorchooserwidget: Get rid of a gtk_widget_destroy() call (*)
  73faa9c... popovermenu: Avoid a gtk_widget_destroy() call (*)
  ceabe70... emojichooser: Avoid using gtk_widget_destroy() (*)
  103b6a9... popovermenubar: Avoid calling gtk_widget_destroy() (*)
  f4202c5... headerbar: Avoid calling gtk_widget_destroy() (*)
  e1ca83d... pathbar: Avoid calling gtk_widget_destroy() (*)
  995277f... placessidebar: Avoid calling gtk_widget_destroy() (*)
  60d2813... placessidebar: Convert popover menu to proper GtkPopoverMen (*)
  df3b884... modelbutton: Fix wrong function name in doc comment (*)
  dbd1180... stackswitcher: Avoid calling gtk_widget_destroy() (*)
  68b4c06... shortcutlabel: Remove unnecessary includes (*)
  ff4a33b... headerbar: Remove size request on icon button (*)
  549a3a8... headerbar: Replace gtk_widget_destroy() call (*)
  dae06d8... inspector: Remove double borders in recorder (*)
  1baae1f... colorchooser: Fix typo in checkerboard color (*)
  b1d4d24... pathbar: Inherit from GtkWidget (*)
  596be28... menusectionbox: Avoid a gtk_widget_destroy() call (*)
  838fc4f... range: Clean up compute_slider_position() (*)
  b81cd8c... range: Inline function into only caller (*)
  a1fc94f... range: Remove an outdated comment (*)
  e552adf... widget: Remove surface member (*)
  6b970c6... widget: Remove set_csd_input_shape (*)
  73c212d... popover: Stop using gtk_widget_input_shape_combine_region() (*)
  6056ca9... window: Carry an extra input region (*)
  0bca4a2... inspect-button: Use new gtk_window_set_extra_input_region (*)
  d5327a6... widget: Remove gtk_widget_input_shape_combine_region() (*)
  54bf739... scrolledwindow: Remove useless local variables (*)
  6ff057f... scrolledwindow: Remove an unnecessary cast (*)
  02e295e... statusbar: Remove _get_message_area() from public API (*)
  64ff12d... Merge branch 'wip/baedert/for-master' into 'master' (*)
  97b5775... ci: Add a separate "docs" stage (*)
  8a6d5a7... ci: Fix style check script (*)
  a87966b... ci: Rename the "style-check" phase to "analysis" (*)
  382340c... ci: Add clang-analyzer to the fedora build image (*)
  92d86c4... ci: Update all fedora images to v14 (*)
  d9608a0... ci: Move style-check to .pre phase (*)
  7bc50b7... ci: Update the docker wrapper script (*)
  341b2a3... ci: Add a static analysis job (*)
  06ff60a... Merge branch 'ci-docs' into 'master' (*)
  77ce55b... builder-tool: replace some properties (*)
  2d4e1e2... update testsuite (*)
  a9c0519... Drop the expand property (*)
  b5bacb3... Drop the margin property (*)
  c8f4f90... Remove last instances of GtkFileChooser:show-hidden (*)
  a1bbd25... Fix introspection annotation syntax (*)
  d4dcb43... Add missing ownership transfer annotations (*)
  7eb7ee3... Add missing documentation to GdkDevice (*)
  3c2312a... Fix gtk-doc stanza for private symbol (*)
  303e202... Add missing ownership transfer annotations (*)
  c79acb4... Merge branch 'remove-show-hidden' into 'master' (*)
  815e18e... Merge branch 'docs-fixes' into 'master' (*)
  37a2cae... Small fixups (*)
  5430c80... Merge branch 'expand-margin-cleanup' into 'master' (*)
  fa75d7f... builder-tool: Fix a thinko (*)
  dcbecda... gesture: Actually track targets (*)
  17b7aab... Merge branch 'matthiasc/for-master' into 'master' (*)
  6a359c5... Update Persian translation (*)
  90376d6... Fix a leftover occurrence of ::expand (*)
  73d40c2... Merge branch 'matthiasc/for-master' into 'master' (*)
  8df0455... Fix a typo in gtkplacessidebar.c (*)
  d86832a... Merge branch 'patch-1' into 'master' (*)
  0c1f93c... Update Dutch translation (*)
  527a804... Avoid a crash in css font features values (*)
  cf873f3... Remove a stray g_object_unref (*)
  29d033a... Merge branch 'matthiasc/for-master' into 'master' (*)
  cf2bcef... Update POTFILES.in and POTFILES.skip (*)
  8f87555... inspector: Fix the "Software GL" switch (*)
  d60097f... Merge branch 'matthiasc/for-master' into 'master' (*)
  0ffb35c... Drop device grabs (*)
  57c8a64... Drop gtk_grab_get_current (*)
  3d11973... Drop gtk_grab_add/remove from public api (*)
  c9d3f87... Merge branch 'kill-grabs-2' into 'master' (*)
  810d567... placessidebar: Fix a couple of typos and thinkos in menu la (*)
  35f8f05... Merge branch 'piotrdrag/placessidebar-typos' into 'master' (*)
  d9fa839... testsuite: Use g_assert() in tests
  fdb39b0... treeview, iconview: Don't return the drop target
  b799bc5... textview: Move drop scrolling to drop motion controller
  b64a027... notebook: Make dnd page switching a drop controller
  f4ac747... placessidebar: Don't use the GdkDrag
  a411959... droptarget: Redo
  3f7b401... gtk-demo: Add a simple peg solitaire DND demo
  c3fb6ca... colorswatch: Switch to dragged color during dnd
  45db9cd... gdk: Make gdk_drop_status() take preferred action
  2cb4610... dragicon: Add GtkDragIcon::child
  c7f3c92... dragicon: Change how to acquire drag icons
  a3d46de... contentformats: Constify some functions
  cea90ae... dragicon: Add gtk_drag_icon_create_widget_for_value()
  03959a4... dnd: Don't create custom color drag icons
  f92c363... calendar: Use a drag source
  8df89f7... themes: Set proper foreground color for DND icons

(*) This commit already existed in another branch; no separate mail sent


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]