[librsvg] Created tag 2.47.2
- From: Federico Mena Quintero <federico src gnome org>
- To: commits-list gnome org
- Cc:
- Subject: [librsvg] Created tag 2.47.2
- Date: Wed, 15 Jan 2020 23:50:58 +0000 (UTC)
The signed tag '2.47.2' was created.
Tagger: Federico Mena Quintero <federico gnome org>
Date: 1579132255 -0600
Tag for version 2.47.2
Changes since the last tag '2.47.1':
Federico Mena Quintero (176):
(#504): Provide an usage example in the librsvg crate docs
Merge branch 'rect' into 'master'
Merge branch 'dasharray' into 'master'
Doc comments for the Parse trait
Generate slightly more meaningful ParseError messages
Remove ParseFromStreamError; use LoadingError directly everywhere
Change the error code for short files
Move all the GError machinery to c_api.rs
Log all errors in c_api to get diagnostics from apps which pass a NULL GError
parse_one_presentation_attribute() - renamed from parse_attribute_pair()
Don't log non-presentation attributes as unknown properties
Log parse errors on properties with less noise from QualName
Log errors for presentation attributes as such, not as style properties
Make fmt::Display for NodeError less verbose
Don't convert to NodeError in parse_one_presentation_attribute()
impl Parse for IRI - return ValueErrorKind, not ParseError
trait Parse - remove the Err associated type
NodeError::new() - renamed from ::attribute_error()
Convert directly from cssparser::BasicParseError to our ValueErrorKind
Images: make methods private
Images::lookup() - take an AllowedUrl, not a &str
Get rid of ParseError; only use ValueErrorKind
Merge branch 'refactor-errors'
Merge branch 'bbox' into 'master'
(#408): Don't clip feImage to integer bounds
Merge branch 'pborelli/librsvg-filters'
Merge branch 'pborelli/librsvg-rect'
Rect: extract a make_path_builder() function
Circle, Ellipse: extract a make_path_builder function
Polygon / Polyline: extract a make_path_builder function
Line: extract a make_path_builder function
Return Cow<PathBuilder> from all the make_path_builder functions
Path: extract a make_path_builder function
shapes.rs: Make all the draw() functions the same
shapes.rs: Move the common draw() code to a trait Shape
Use a struct Shape instead of a trait
Use a custom Markers enum instead of a bool
Shape: use an Rc<PathBuilder>, not a Cow
Merge branch 'refactor-shapes'
Document the `LoadOptions` struct
Docs for the Document struct
Start documenting RsvgNode and create_node
Document PropertyBag
Add one-line descriptions of each module
Use a utility function
Use ValueErrorKind::parse_error instead of creating the variant directly
lighting.rs: Don't use NodeError directly
turbulence.rs: Don't create a NodeError directly
filters/image.rs: Don't create a NodeError directly
morphology.rs: Don't create a NodeError directly
gaussian_blur.rs: Don't create a NodeError directly
component_transfer.rs: Don't create a NodeError directly
convolve_matrix.rs: Don't create a NodeError directly
image.rs: Don't create a NodeError directly
parsers.rs: Don't create a NodeError directly
node.rs: Don't create a NodeError directly
color_matrix.rs: Don't create NodeError directly
NodeError: remove unused method value_error()
displacement_map.rs: Don't create a NodeError directly
morphology.rs: Don't create a NodeError directly
component_transfer.rs: Don't create a NodeError directly
convolve_matrix.rs: Don't create a NodeError directly
blend.rs: Don't create a NodeError directly
filters/input.rs: Don't create a NodeError directly
turbulence.rs: Don't create a NodeError directly
Remove unused NodeError::parse_error
Inline NodeError::new() into its only caller
Remove unneeded type parameter E on AttributeResultExt
Introduce a ParseError type
parse_identifiers! - new macro for parsing symbol lists from attributes
aspect_ratio: use parse_identifiers!
property_macros: use parse_identifiers! for the identifiers: case
FontSizeSpec: simplify parsing
LetterSpacingSpec: simplify parsing
SpreadMethod: simplify parsing
MarkerUnits: simplify parsing
CoordUnits: simplify parsing
BaselineShift: simplify parsing
Operator: simplify parsing
component_transfer.rs: impl Parse for FunctionType instead of a custom method
displacement_map.rs: impl Parse for ColorChannel instead of using a custom method
morphology.rs: impl Parse for Operator instead of using a custom method
Remove a few unnecessary derives
convolve_matrix.rs: impl Parse for bool for the preserveAlpha attribute
convolve_matrix.rs: impl Parse for EdgeMode instead of using a custom method
color_matrix.rs: impl Parse for OperationType instead of using a custom method
color_matrix.rs: impl Default for OperationType
blend.rs: impl Parse for Mode instead of using a custom method
turbulence.rs: impl Parse for StitchTiles and NoiseType instead of using a custom method
filters/input.rs: Implement the CSS custom-ident type
Return a BasicParseError from parse_identifiers
Input::FilterOutput(x) make x a CustomIdent, not a String
FontSizeSpec: simplify parser
Remove the CssParserExt trait
Merge branch 'refactor-parsers'
Update NEWS
Bump version to 2.47.2
Cargo update
properties.rs: Add a helper parse_input_to_parse_error to convert each parser
Temporarily rename ParseError to CssParseError
Introduce a ParseError enum, temporarily with variants for CssParseError and ValueErrorKind
Return a ParseError from the basic parse_property()
TextDecoration: return a CssParseError
Convert all the "identifiers" properties to CssParseError
Convert Color, FontSizeSpec, LetterSpacingSpec to CssParseError
Convert SingleFontFamily / FontFamily to CssParseError
Convert FontWeightSpec / FontWeight to CssParseError
Convert UnitInterval / all the *Opacity properties to CssParseError
Convert IRI, ClipPath, Filter, Marker*, Mask to CssParseError
Temporary trait ParseValueToParseError
Convert PaintServer, Fill, Stroke to CssParseError
Convert Dasharray, StrokeDasharray to CssParseError
Convert StrokeMiterlimit to CssParseError
Convert Length and all properties/attributes of that type to CssParseError
Remove unused parse_input()
Remove unused parse_and_validate()
Convert NumberList and ViewBox to CssParseError
Remove the is_*_error() functions for tests
Convert Matrix to CssParseError
Convert Input and CustomIdent to CssParseError
impl ParseToParseError for i32 instead of using an integer() function
Replace number_optional_number() with a NumberOptionalNumber type
Convert Angle, MarkerOrient to CssParseError
Convert StitchTiles, NoiseType to CssParseError
Convert blend::Mode to CssParseError
Convert OperationType to CssParseError
Convert EdgeMode to CssParseError
Convert FunctionType to CssParseError
Convert composite::Operator to CssParseError
Convert morphology::Operator to CssParseError
Convert ColorChannel to CssParseError
Convert CoordUnits to CssParseError
Convert XmlLang, XmlSpace to CssParseError
Convert AspectRatio, MarkerUnits to CssParseError
Convert Points to CssParseError
Convert all the remaining uses of f64::parse to the CssParseError version
Convert SpreadMethod to CssParseError
Convert StyleType to CssParseError
Remove the Parse and ParseValue traits
The Great Renaming is done!
Merge branch 'css-parse-error'
Merge branch 'selectors' into 'master'
Merge branch 'cleanup' into 'master'
Merge branch 'filters' into 'master'
Merge branch 'clipmask' into 'master'
Merge branch 'marker' into 'master'
(#542): Fix infinite loop when processing sibling combinators
Link to libxml2 from rsvg_internals, not librsvg_crate
Add tests for impl selectors::Element
Ahem, forgot to babysit Makefile.am
Write test output from the Rust tests to the same output/ dir from the C tests
Merge branch 'pborelli/librsvg-image'
Use the xml namespace for the xml:lang and xml:space attributes
Unprefixed attributes don't have a namespace at all
Log invalid rules and declarations
Merge branch 'unprefixed-attributes' into 'master'
Remove the last traces of the ParseError enum with variants
Finally rename CssParseError to ParseError.
Merge branch 'parse-error' into 'master'
error.rs: Move an impl so all its related code is contiguous
repr(C) the enums created by the make_property macro
Don't parse "inherit" for rsvg_css_parse_color()
Add missing newlines to a couple of rsvg-convert error messages
rgba_to_argb(): Make private
Remove RSVG_CSS_COLOR_SPEC_CURRENT_COLOR
Move rsvg_css_parse_color() and its machinery to librsvg_c_api
Inline ColorSpec::from() into its only caller
Merge branch 'parse-color-to-c-api' into 'master'
Don't erase error information in DeclParser::parse_value()
Log invalid declarations when parsing the style attribute
Use ? in favor of map_err
FontWeightSpec: simplify parser
IRI: preserve the Href error information
FeImage: preserve the Href error information
Merge branch 'filters' into 'master'
Update NEWS
Jordan Petridis (1):
Merge branch 'remove-clzsi2-workaround' into 'master'
Kleis Auke Wolthuizen (1):
Remove __clzsi2 workaround
Paolo Borelli (97):
viewbox: small cleanup
image: small cleanup
benches: remove unused cairo_sys
filters: shorten code leveraging Rect's From trait
surface_utils: use IRect::contains
rect: add from_size to RectangleExt
rect: add (x|y)_range methods to IRect
rect: add constructrors for IRect
rect: rename method to intersection
rect: add translate and intersection for IRect
rect: add translate method
Move RsvgRectangle in the legacy C api
dasharray: split to its own module
Add IRect::width() and height()
bbox: rework API and internals
rect: drop outer() method
filters: avoid rect conversion roundtrip
pattern: small cleanup
rect: replace IRect with a generic rect
Add a Rect type alias for rect::Rect<f64>
rect: conversion trait
Move all the internals from cairo:Rect to Rect
viewbox: make viewbox a newtype on Rect
rect: remove cairo extension trait
lighting: get w,h just once
filters: shorten context code
filters: factor out shared conversion code
Switch to the released version of the selectors crate
drawing_ctx: make CompositingAffines private to the module
bbox: tweak construction API
filters: shorten code
Move test in the correct place.
Move composition code in surface_utils.
filters: use compose method also for FeMerge
filters: use compose method also for FeBlend
image: reduce scope of cairo context
drawing_ctx: shorten code
image: shorten code
drawing_ctx: use iterator instead of recursive function
drawing_ctx: move the num_elements_acquired check in AcquiredNodes
mask: consolidate rect computation in a block
gaussian_blur: shorten code
Improve feOffset reftest
filters: remove unused pub method
clip_path: shorten code
clip_path: move cairo clipping in drawing_ctx
mask: move generate_cairo_mask in drawing_ctx
drawing_ctx: add with_link_tag method
structure: move clip_path, link, and mask in structure.rs
drawing_ctx: make with_saved_matrix take an optional transform
marker: make code slightly more idiomatic
marker: shorten parse function
pattern: factor out get_rect
pattern: manually check cairo surface creation
drawing_ctx: make push/pop_cairo_context private
drawing_ctx: add draw_from_use_node method
Tidy up cairo imports
bounds: remove unneeded into()
surface_utils: pass down opacity as a UnitInterval
flood: move cairo implementation to surface_utils
offset: move cairo implementation to surface_utils
flood: shorten code
cargo fmt
Move srgb.rs in surface_utils
shapes: move draw_path method on drawing_ctx
node: reorder includes
shapes: shorten code
drawing_ctx: turn a couple of method into plain helper functions
drawing_ctx: cleanup AcquiredNodes
image: factor out get_rect
filters: move cairo code out of the image filter
tile: move cairo code out of the tile filter
css: fmt
Morphology: shorten code
surface_utils: clarify iterator constructors
shared_surface: rework constructor methods
drawing_ctx: rework get_snapshot
drawing_ctx: pass SharedImageSurface as param to run_filter
shared_surface: always use the full cairo namespace
shared_surface: remove unused method
filters: shorten "merge" code
surface_utils: add ExclusiveImageSurface
filters: port color matrix to ExclusiveImageSurface
filters: port component transfer to ExclusiveImageSurface
filters: port convolution matrix to ExclusiveImageSurface
filters: port turbolence to ExclusiveImageSurface
filters: port morphology to ExclusiveImageSurface
filters: port displacement to ExclusiveImageSurface
filters: port lighting to ExclusiveImageSurface
filters: port drawing_ctx to ExclusiveImageSurface
filters: shorten code in context.rs
filters: port context to ExclusiveImageSurface
shared_surface: use ExclusiveImageSurface for composite_arithmetic
benches: port pixel iterator bench to ExclusiveImageSurface
surface_utils: shorten iterator test code
srgb: use ExclusiveImageSurface
surface_utils: go back on set_pixel directly on the data slice
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]