[retro-gtk] (44 commits) Non-fast-forward update to branch auto-goodness



The branch 'auto-goodness' was changed in a way that was not a fast-forward update.
NOTE: This may cause problems for people pulling from the branch. For more information,
please see:

 https://wiki.gnome.org/Git/Help/NonFastForward

Commits removed from the branch:

  9065ee6... Add error handling helpers
  e50b43a... core: Use auto cleanups and throws where possible
  2d4e425... core-descriptor: Use auto cleanups and throws where possibl

Commits added to the branch:

  c8534cc... meson: Actually use the 'm' dependency (*)
  959da69... Add RetroMainLoopSource (*)
  b004538... retro-core: Use RetroMainLoopSource for timing (*)
  86c2c85... retro-core: Add 'iterated' signal (*)
  fed306b... retro-core: Add retro_core_get_sample_rate() (*)
  47a2e57... retro-pa-player: Bufferize samples on each frame (*)
  9809681... retro-core: Stop bufferizing samples (*)
  daf663d... meson: Add libsamplerate dependency (*)
  e455ddb... retro-pa-player: Resample audio for non-1 speed rates (*)
  1c0a16c... retro-core: Rename run() to iteration() (*)
  6b3cc1d... retro-core: Rename start() to run() (*)
  dca3c07... retro-core: Remove an extra 'iterated' emission (*)
  a4bdf09... retro-pa-player: Fix resample loop condition (*)
  63d014f... retro-controller-iterator: Mark controller in next() as (tr (*)
  f625f2f... retro-controller-iterator: Don't error on null parameters i (*)
  8f0f419... retro-core: Use GUINT_TO_POINTER() for controller ports (*)
  a1553e5... retro-pa-player: Don't try to play audio if there are no sa (*)
  37135e1... retro-core: Make state size mismatch non-fatal (*)
  b1c3c3e... glsl-filters: Re-add bicubic and sharp filters (*)
  70bd269... retro-gl-display: Use shaders for all filters (*)
  e4f98ce... Create shared/ dir (*)
  3b2a773... retro-controller-type: Add functions for getting id and ind (*)
  24eea50... Add RetroMemfd (*)
  7e126a1... Add RetroControllerState (*)
  513ccbf... Add RetroFramebuffer (*)
  452b5e0... Move RetroCore to retro-runner/ (*)
  667f52a... Run libretro cores in subprocess (*)
  7757828... build: Allow to disable pulseaudio (*)
  41fe3b0... flatpak: Disable pulseaudio for unit tests (*)
  ff8e548... ci: Disable pulseaudio for tests (*)
  c38dc04... core: Make it a singleton (*)
  ffe2d9f... core: Document the iterated signal (*)
  d1a691b... core: Improve the runahead property documentation (*)
  388e1d7... core: Typo, quote and apostrophe fix (*)
  9d81cae... core: Fix a precondition in retro_core_override_option_defa (*)
  2a7abec... core: Make keyboard_widget_notify() static (*)
  349e254... core: Make controller_state_changed_cb() static (*)
  b935f18... core: Check controller in retro_core_set_default_controller (*)
  7bb2f2f... core: Check controller in retro_core_set_controller() (*)
  b923180... core: Auto emit 'iterated' on cleanup (*)
  5150775... Add error handling helpers
  0d854fb... core: Use auto cleanups and throws where possible
  94886d3... core-descriptor: Use auto cleanups and throws where possibl
  ceda38b... option: Use auto cleanups and throws where possible

(*) This commit already existed in another branch; no separate mail sent


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]