[gtk] (96 commits) Non-fast-forward update to branch css-lookup-caching
- From: Matthias Clasen <matthiasc src gnome org>
- To: commits-list gnome org
- Cc:
- Subject: [gtk] (96 commits) Non-fast-forward update to branch css-lookup-caching
- Date: Fri, 14 Feb 2020 02:19:36 +0000 (UTC)
The branch 'css-lookup-caching' was changed in a way that was not a fast-forward update.
NOTE: This may cause problems for people pulling from the branch. For more information,
please see:
https://wiki.gnome.org/Git/Help/NonFastForward
Commits removed from the branch:
7ec7f80... Move performance tests to the right testsuite
b414df1... testsuite: Warn if a necessary env var is missing
2a14c84... perf test: Discard invalid runs
edd28f6... Clean up some includes
f60a21a... lookup: Loose the underscores
787af5a... Make lookups refcounted
29f5767... lookup: Add a getter
a10f67e... lookup: Don't store flat arrays
14319dc... style: Cache the lookup
40684ca... Pass a lookup to gtk_css_static_style_new_compute
010bb1f... cssnode: Rearrange code a bit
c131520... cssnode: Reused cached lookups
a0c19d4... Revamp lookup memory handling
6fcf52b... css provider: Keep rulesets sorted
05e3ad9... lookup: Merge rulesets more efficiently
22c5ba4... css style: Use a linear sweep to compute values
f84951f... wip: Count duplicate lookups
a956c54... Revert "wip: Count duplicate lookups"
0d10b30... Keep an emtpy lookup singleton
7beae96... Make PropertyValue another name for GtkCssLookupValue
711b5f5... Rename gtk_css_lookup_merge to _fill
139f605... Rewrite the merge loop more concisely
d66a138... Make GtkCssLookupValue refcounted
93c9db6... Try to make the style computation clearer
Commits added to the branch:
36808e0... profiler: Always mark events with the kind (*)
6e0cf02... Merge branch 'mark-events-with-kind' into 'master' (*)
c2dcd1b... Update Esperanto translation (*)
6de85c0... Add gdk_profiler_add_markf() to do printf formating (*)
8a1c51d... Use the new gdk_profiler_add_markf() function (*)
685fd3c... fixup! Add gdk_profiler_add_markf() to do printf formating (*)
13eedf1... Use markf in one more place (*)
cc643df... Convert all profiler times from nsec to usec (*)
01d5ad2... profiler: Make profiler-is-running a macro (*)
2890cd8... profiler: Add _end_mark() version of _add_mark() (*)
e134eef... builder: Don't add profiler marks for short parses (*)
b4b00e2... icon theme: Don't add profiler marks for short async icon l (*)
e3a6738... profiler: Add profiler marks for when surfaces are mapped a (*)
324202a... profiler: Clean up profiler marks for frameclock (*)
d9c59a7... profiler: Add G_GNUC_PRINTF markers to silence warnings (*)
6e3dd6d... profile: Use separate names for frameclock marks instead of (*)
d702c15... Merge branch 'cleanup-profiler-marks' into 'master' (*)
b12a6be... rendernode: draw() only in node bounds (*)
52c46e5... rendernode: Don't clip when _draw()ing (*)
cc8506c... Move performance tests to the right testsuite (*)
e1d85ae... testsuite: Warn if a necessary env var is missing (*)
f51ceb1... ci: Fix linking of the CI assets in the report (*)
f2da5e5... ci: Deploy the API ref before flatpak (*)
4247bf0... ci: Update flatpak job (*)
88e2a06... Merge branch 'ci-pages' into 'master' (*)
1b95cd2... build: Install gtkemojichooser.h (*)
7404c39... Merge branch 'gbsneto/fix-emojichooser-header' into 'master (*)
11ab396... Fix the Emoji chooser finalize (*)
2ab9be5... Rename the SCSS files for our themes (*)
6c6b3d0... Merge branch 'ci-pages' into 'master' (*)
073e8dd... popovermenu: Avoid an uninitialized variable (*)
14ecc9e... Remove unused signal enum values (*)
9be8f8c... Merge branch 'wip/baedert/cairo-paint' into 'master' (*)
fb84fe7... Fix flickery hover (*)
c313a71... testsuite: Remove accidentally checked in file (*)
9d8ceb0... testsuite: Don't destroy surfaces that are still used (*)
16e3870... testsuite: Don't use gdk_cairo_get_clip_rectangle() (*)
b0369fc... roundedrect: Fix gsk_rounded_rect_intersects_rect() (*)
77d7c71... roundedrect: Fix inlining of graphene functions (*)
75b130e... testsuite: Add tests for rounded rect code (*)
f0993fc... rendernode: Avoid rounding errors (*)
67610b1... cairoblur: Move the check for early exit (*)
6f9f180... gsk: Add a utility function for rectangles (*)
6203cec... gsk: Clip shadow node before push_group() (*)
8f6cab6... cairoblur: Get rid of gdk_cairo_get_clip_rectangle() call (*)
052d0f6... gdk: Remove gdk_cairo_get_clip_rectangle() (*)
313c399... Merge branch 'wip/otte/no-clip-on-draw' into 'master' (*)
47f2a6c... Remove border-half-pixel reftest from xfail (*)
cdd7e4c... Add a notify function to GdkContentProvider (*)
0d354d1... docs: Match the argument name with its declaration (*)
35ac7de... Match argument name between declaration and definition (*)
32a2a62... Fix the function name in the gtk-doc stanza (*)
40852ea... gi: Skip gtk_custom_layout_new() (*)
2a0dfa9... Remove gtk_style_context_get_parent() (*)
3dc6a07... ci: Re-enable ccache (*)
f4a8edf... ci: Move HTML report meta from header to article (*)
adc7bf9... ci: Put the branch name in the HTML header (*)
1a4d1f8... ci: Unexpected passes are failures (*)
2b1e273... ci: Use result instead of exit code in the JUnit report (*)
affc7b5... ci: Fix the HTML anchor in the report (*)
5ed3f8d... ci: Rearrange the results in the HTML report (*)
de1543d... ci: Use per-suite anchors (*)
09abb43... Merge branch 'report-fixes' into 'master' (*)
a66ed7c... gsk: Fix the compiler warning differently (*)
cdee2ac... testsuite: Handle icontheme test better (*)
2e0af29... Make release builds mandatory for ci (*)
883980c... Merge branch 'gi-fixes' into 'master' (*)
9332abf... ci: Allow flatpak jobs to fail (*)
9a631f2... ci: Remove G_MESSAGES_DEBUG (*)
33c6032... Merge branch 'ci-flatpak' into 'master' (*)
c4111da... Fixed OpenGL extension detection for extensions promoted to (*)
0969d06... Fix detection of OpenGL 3.3 core GL_ARB_timer_query. (*)
eb2e013... Merge branch 'master' into 'master' (*)
97ec29d... Force-create style contexts in realize (*)
5b8be14... perf test: Discard invalid runs
3ebc627... Clean up some includes
da2c832... lookup: Loose the underscores
1a6c8a2... Make lookups refcounted
77e53d6... lookup: Add a getter
43076f3... lookup: Don't store flat arrays
72b09c0... style: Cache the lookup
2b71f4e... Pass a lookup to gtk_css_static_style_new_compute
107bf9e... cssnode: Rearrange code a bit
c0682f3... cssnode: Reused cached lookups
e12ef76... Revamp lookup memory handling
d342ca8... css provider: Keep rulesets sorted
6d6d986... lookup: Merge rulesets more efficiently
0726c34... css style: Use a linear sweep to compute values
37d2382... wip: Count duplicate lookups
0f32eb0... Revert "wip: Count duplicate lookups"
9f46d1c... Keep an emtpy lookup singleton
0dbe256... Make PropertyValue another name for GtkCssLookupValue
81ac3a8... Rename gtk_css_lookup_merge to _fill
e5a648b... Rewrite the merge loop more concisely
592eb39... Make GtkCssLookupValue refcounted
f32cbed... Try to make the style computation clearer
(*) This commit already existed in another branch; no separate mail sent
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]