[gnome-shell/gnome-3-34] allView: Rename variable



commit 59daa4192c8a6e76a089f805b1836d09e0cc3a90
Author: Georges Basile Stavracas Neto <georges stavracas gmail com>
Date:   Thu Nov 21 18:03:34 2019 -0300

    allView: Rename variable
    
    The variable that holds the list of application icons is
    called 'newApps', but that technically was never true,
    since we only create new app icons when necessary.
    
    Rename it to 'appIcons'.
    
    https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/841

 js/ui/appDisplay.js | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)
---
diff --git a/js/ui/appDisplay.js b/js/ui/appDisplay.js
index 917532b8c1..14f95aced9 100644
--- a/js/ui/appDisplay.js
+++ b/js/ui/appDisplay.js
@@ -425,7 +425,7 @@ var AllView = class AllView extends BaseAppView {
     }
 
     _loadApps() {
-        let newApps = [];
+        let appIcons = [];
         this._appInfoList = Shell.AppSystem.get_default().get_installed().filter(appInfo => {
             try {
                 (appInfo.get_id()); // catch invalid file encodings
@@ -450,7 +450,7 @@ var AllView = class AllView extends BaseAppView {
                 icon.connect('name-changed', this._itemNameChanged.bind(this));
                 icon.connect('apps-changed', this._redisplay.bind(this));
             }
-            newApps.push(icon);
+            appIcons.push(icon);
             this.folderIcons.push(icon);
         });
 
@@ -472,10 +472,10 @@ var AllView = class AllView extends BaseAppView {
                 });
             }
 
-            newApps.push(icon);
+            appIcons.push(icon);
         });
 
-        return newApps;
+        return appIcons;
     }
 
     // Overridden from BaseAppView


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]