[gnome-shell/gbsneto/dont-create-so-many-icons-pretty-please: 2/3] allView: Rename variable



commit fc6e56113a56df3b81c519eb39e71de412d5afce
Author: Georges Basile Stavracas Neto <georges stavracas gmail com>
Date:   Thu Nov 21 18:03:34 2019 -0300

    allView: Rename variable
    
    The variable that holds the list of application icons is
    called 'newApps', but that technically was never true,
    since we only create new app icons when necessary.
    
    Rename it to 'appIcons'.
    
    https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/841

 js/ui/appDisplay.js | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)
---
diff --git a/js/ui/appDisplay.js b/js/ui/appDisplay.js
index 838fef6077..a49ebe09a8 100644
--- a/js/ui/appDisplay.js
+++ b/js/ui/appDisplay.js
@@ -453,7 +453,7 @@ var AllView = GObject.registerClass({
     }
 
     _loadApps() {
-        let newApps = [];
+        let appIcons = [];
         this._appInfoList = Shell.AppSystem.get_default().get_installed().filter(appInfo => {
             try {
                 appInfo.get_id(); // catch invalid file encodings
@@ -478,7 +478,7 @@ var AllView = GObject.registerClass({
                 icon.connect('name-changed', this._itemNameChanged.bind(this));
                 icon.connect('apps-changed', this._redisplay.bind(this));
             }
-            newApps.push(icon);
+            appIcons.push(icon);
             this.folderIcons.push(icon);
         });
 
@@ -500,10 +500,10 @@ var AllView = GObject.registerClass({
                 });
             }
 
-            newApps.push(icon);
+            appIcons.push(icon);
         });
 
-        return newApps;
+        return appIcons;
     }
 
     // Overridden from BaseAppView


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]