[gtk] (243 commits) Non-fast-forward update to branch cairo-script-interpreter



The branch 'cairo-script-interpreter' was changed in a way that was not a fast-forward update.
NOTE: This may cause problems for people pulling from the branch. For more information,
please see:

 https://wiki.gnome.org/Git/Help/NonFastForward

Commits removed from the branch:

  145be6d... rendernodeparser: Parse cairo script

Commits added to the branch:

  096d28e... surface: Add marshallers for new events (*)
  ff1150d... Export gtk_widget_render privately (*)
  afcf3e6... widget: guard popover-specific code paths (*)
  618f1f0... main: guard window-specific code paths (*)
  12a16a2... Introduce GtkNative (*)
  d51c85c... native: Add to docs (*)
  5bf2b63... window: Implement GtkNative (*)
  d4257d2... root: Require GtkNative (*)
  7dcb163... Add gtk_widget_get_native (*)
  c1d5e82... Use GtkNative APIs instead of GtkRoot (*)
  9059eee... Review and replace uses of get_toplevel (*)
  5de06f4... widget: Use GtkNative (*)
  f2447e0... GtkRoot: Drop overlap with GtkNative (*)
  8713397... root: Make gtk_root_get_display public (*)
  54662f4... widget: Don't snapshot foreign children (*)
  2606ca0... Introduce event controller propagation limits (*)
  2764652... menushell: Keep outside clicks working (*)
  9e6d8be... surface: Start sketching a new surface type (*)
  6ab8ab8... Reimplement GtkPopover (*)
  4bf4f04... Adapt to new popover lifecycle (*)
  1cbc26d... menubutton: Allocate the popover (*)
  82d506a... Adwaita: Give popover menus a background (*)
  580aa82... widget: Remove some unneeded popover special-casing (*)
  66ccc82... main: Remove special-case hiding popopvers (*)
  0d25233... main: Use gtk_widget_get_native (*)
  c3c33ac... entry completion: Use a popover (*)
  68e5456... x11: Stop using child surface api (*)
  f7e1146... wayland: Stop using child surface apis (*)
  d6a8518... xim: Stop using child surface apis (*)
  43d4c90... a11y: Stop supporting ATK_XY_SCREEN (*)
  52c3507... widget: Stop using child surface apis (*)
  989792c... Drop child surfaces (*)
  90e86b3... surface: minor cleanup (*)
  60ec1ee... surface: Remove code dealing with child surfaces (*)
  bb1dd3f... wayland: Stop using surface->parent (*)
  6183d58... x11: Stop using surface->parent (*)
  edab501... broadway: Stop using surface->parent (*)
  0760958... gdk: Stop using surface->parent (*)
  e68c554... Remove surface->parent (*)
  7aae926... wayland: Stop using surface->children (*)
  2eebac8... gdk: Stop using surface->children (*)
  0699b17... Remove surface->children (*)
  77e99f7... surface: Simplify some code (*)
  0f5a6a3... surface: Small cleanup (*)
  3248bdc... surface: Remove abs_x/abs_y (*)
  9b54f12... surface: Simplify destroy implementation (*)
  a3e0329... surface: Small simplification (*)
  2ccd0dc... Remove gdk_surface_coords_to/from_parent (*)
  8ee1620... Remove gdk_surface_get_root_coords as public api (*)
  cb23d40... Drop gdk_surface_get_root_origin (*)
  bb399b5... Remove gdk_surface_get_geometry as public api (*)
  48b522c... x11: Drop a gratitious use of gdk_event_get_root_coords (*)
  73a6aae... surface: Make gdk_surface_get_device_position void (*)
  55c2866... menu: Stop using gtk_widget_register_surface (*)
  81a673c... window: Stop using gtk_widget_register_surface (*)
  fa25b06... popover: Stop using gtk_widget_register_surface (*)
  bab5836... Drop gtk_widget_register_surface (*)
  f692974... gdk: Remove remnants of client-side windows (*)
  8bb7fcd... docs: Remove references to gdk_device_grab (*)
  6029875... wayland: Remove a useless switch (*)
  4483125... broadway: Stop using gdk_surface_new_temp (*)
  7c1509f... x11: Stop using gdk_surface_new_temp (*)
  346bd3f... menu: Stop using gdk_surface_new_temp (*)
  82c8a05... Drop gdk_surface_new_temp (*)
  1a23ebf... gdk: Remove an unused field (*)
  2855729... gdk: Drop input-only surfaces (*)
  47fb092... gdk: Drop GdkWindowAttr (*)
  8536557... gdk: Drop pass-through surfaces (*)
  0571fc2... surface: Cosmetics (*)
  d2951d3... Rename surface constructors (*)
  93b8f25... gdk: Add a private header (*)
  712a5d4... Get rid of GdkSurfaceImpl (*)
  07b3a09... x11: Remove useless checks (*)
  33c6dff... gdk: Introduce a popup surface type (*)
  9af6d7f... surface: Store popup parent (*)
  1fa2a82... surface: Make move-to-rect work for popups (*)
  1661615... surface: Stop setting transient-for for popups (*)
  99783c7... wayland: Use popup parents (*)
  6f1c32b... x11: Implement popup surfaces (*)
  2dd1534... broadway: Track popups (*)
  b15ba64... surface: Add an autohide property (*)
  49268c2... popover: Use GdkSurface::autohide (*)
  1c7eb5c... surface: Remove old debug code (*)
  ebb89bc... surface: Remove gdk_surface_set/merge_child_input_shapes() (*)
  18e396e... Add gdk_surface_get_parent back (*)
  27596c3... widget: Improve warning messages (*)
  f3559fe... widget: Optimize resize propagation (*)
  1f2d3c0... window: Don't inherit cursors across surfaces (*)
  e6f71d8... text: Allocate popovers (*)
  507b2d3... scale button: Allocate popovers (*)
  4cab6ae... entry: Allocate popovers (*)
  07426da... color swatch: Allocate popovers (*)
  6c3ffa1... places sidebar: Allocate popovers (*)
  a33d4f0... text view: Allocate popovers (*)
  61247a8... widget: Remove a popover special case (*)
  07c8fd9... Add a testcase for size allocation (*)
  ef353f2... gdk: Inherit the frame clock for popups (*)
  fa9cbf6... x11: Fix handling of frame clock freezes (*)
  fd0a290... popover: Bring back the beak (*)
  db855e0... Add a GdkSurface::parent property (*)
  18788c2... Remove gtk_widget_get/set_has_surface (*)
  0047492... Work toward dropping widget->surface (*)
  43bed79... Drop GtkWidget::surface (*)
  b99962e... Drop gtk_widget_set_surface (*)
  0b3a971... window: Make unrealize work again (*)
  ebee21b... testsuite: Fix popover-related failures (*)
  6e885ab... testsuite: Fix some a11y output (*)
  09ec88d... win32: Build fixes (*)
  25aef96... popover: Rename modal to autohide (*)
  a65696f... builder tool: Handle modal->autohide rename (*)
  c3d7c94... Add a test for the property renaming (*)
  9765aab... Mention modal->autohide rename in migration guide (*)
  302d2a0... Stop using gtk_widget_get_surface (*)
  8fc6f07... Drop gtk_widget_get_surface (*)
  8af89b3... Mention gtk_widget_get_surface in the migration guide (*)
  948347a... Stop using gtk_widget_is_toplevel (*)
  6674f27... Drop gtk_widget_is_toplevel (*)
  7b9789d... Mention gtk_widget_is_toplevel in the migration guide (*)
  f728295... Cosmetics (*)
  7447abb... Stop using gtk_widget_get_toplevel (*)
  693b2aa... Drop gtk_widget_get_toplevel (*)
  26b4329... Mention gtk_widget_get_toplevel in the migration guide. (*)
  8f291be... tooltip: fix critical warnings (*)
  c2b9a12... surface: Don't dispose the frame clock prematurely (*)
  d5e26cd... GDK W32: be able to handle NULL cursor (*)
  138104d... GDK W32: Fix the code to compile (*)
  83f952d... IME IM: Be able to handle NULL widget correctly (*)
  2c43f87... win32: Set the surface type (*)
  a841ff0... popover: Set input shapes on wayland too (*)
  ec41335... popover: Make it possible to not have an arrow (*)
  db21cbd... inspector: Avoid a critical warning (*)
  c638a0a... Adwaita: Remove Emoji completion special case (*)
  44be642... surface: Make surface-type a property (*)
  3d283cc... gdk: Maintain popup tree in the frontend (*)
  895962d... surface: Make only toplevels control events (*)
  78c94f9... win32: Set surface type early enough (*)
  c7f9f8f... surface: Fix the fallback move-to-rect implementation (*)
  f154fd4... popover: Stop needles allocations (*)
  37f8df2... fishbowl: Don't pop up popovers too early (*)
  a3f127b... surface: Give backends a chance to disconnect (*)
  28addd3... broadway: Disconnect from the frame clock (*)
  2aa0cea... x11: Disconnect from the frame clock (*)
  07b0da6... win32: Disconnect the frame clock (*)
  2fa1a0a... wayland: Disconnect the frame clock (*)
  d08805d... popover: Don't constantly redraw the beak (*)
  11fdde0... surface: Cosmetics (*)
  6ab565b... GDK W32: Adjust to new popup surfaces (*)
  5ccb081... Avoid compiler warnings (*)
  5ff7c34... GDK W32: Don't handle WM_ACTIVATE for popup windows (*)
  82c80c0... Add missing include (*)
  90058ed... Don't assume that gdk_surface[_move]_resize() is asynchrono (*)
  493b30c... GDK W32: No more child windows (*)
  b12d521... GDK W32: Only use owner windows for popups (*)
  d14e987... GDK W32: Correctly log popups (*)
  84739dd... GDK W32: Fix indentation and placate GCC (*)
  9086321... inspector: Show surface and renderer (*)
  173a4b0... Merge branch 'wip/matthiasc/popup5' into 'master' (*)
  a4b1ff7... Forgotten file (*)
  461e8e0... places sidebar: Don't derive from scrolled window (*)
  211128f... inspector: Stop deriving from scrolled window (*)
  bc739e6... scrolled window: Make final (*)
  055a991... file chooser error stack: Don't derive from stack (*)
  700e9e0... stack: Make final (*)
  f0fd484... iconview: Make final (*)
  4b5fee9... tool button: Use standard padding (*)
  5db4530... toggle tool button: Use standard padding (*)
  ef3e20c... radio tool button: Make final (*)
  0a6813d... menu tool button: Make final (*)
  6ffc9f9... Forgotten file (*)
  8695e8c... menu: Make final (*)
  6836bfc... toolbar: make final (*)
  b523f2b... menubar: Make final (*)
  c34abb6... label: Make final (*)
  ee29b9b... notebook: Make final (*)
  217115d... listbox Make final (*)
  aec5e3d... flow box: Make final (*)
  79940b3... treeview: Make final (*)
  9abc726... treeview column: Make final (*)
  dd5839d... tree models: Use standard padding (*)
  0cc94ed... Some entry completion fixes (*)
  ead96b6... notebook: Drop position from ::create-window (*)
  6e15538... broadway: Handle Cairo nodes with NULL surfaces (*)
  d71c196... css: Don't print numbers with exponent (*)
  9ee2b23... rendernodeparser: Handle repeating linear gradients (*)
  89fb752... css: Use %f, not %.17f (*)
  a079fd2... widget: Fix transform refcounting in allocate() (*)
  e85f1e1... widget: Insist on proper vfunc calling (*)
  170c25a... widget: Move functions around (*)
  2380f96... widget: Do proper clean up in real_hide() (*)
  cabe398... widget: Add marshallers to signals (*)
  863f4d1... window: Chain up in show/hide (*)
  56db17e... Revert "window: Chain up in show/hide" (*)
  5675d58... testgtk: Fix a crash (*)
  745a7cf... HighContrast: Improve contrast of notebook tabs (*)
  7f65e5f... Rename GtkGestureMultiPress to GtkGestureClick (*)
  fdcbd75... Merge branch 'high-contrast-tabs' into 'master' (*)
  902a49a... surface: Add coordinate translation (*)
  fcc8a36... main: Use gdk_surface_translate_coordinates (*)
  83827d3... a11y: Stop using gdk_surface_get_origin (*)
  fd04800... Clarify gdk_surface_get_position (*)
  0103c13... x11: Set surface position correctly (*)
  f0ef533... a11y: Stop using gdk_surface_get_frame_extnts (*)
  987e787... Drop gdk_surface_get_frame_extents (*)
  4f9c1bf... gtk-demo: Stop using gtk_window_set_position (*)
  d2bc5b4... tests: Stop using gtk_window_set_position (*)
  a8899cc... window: Drop gtk_window_set_position (*)
  879f22f... Drop gdk_display_get_monitor_at_point (*)
  d515c43... Make gdk_surface_get_origin internal (*)
  b636e32... widget: Stop using gdk_device_get_position (*)
  12da0a6... Drop gdk_device_get_position (*)
  147adc0... window: Drop some unused fields (*)
  ece7fff... window: Drop more unused fields (*)
  d6d5d60... Drop an empty function (*)
  74db7cb... window: Never call gdk_surface_move (*)
  2081bf3... window: Remove move unused fields (*)
  956e94a... Remove a misleading comment (*)
  8ed27d6... Drop gdk_surface_move (*)
  b867cbe... Cosmetics (*)
  5139653... Fix the win32 build (*)
  9ecd906... Cosmetics (*)
  792d578... Cosmetics (*)
  d47434b... Mention global coordinates in the migration guide (*)
  200373f... Mention event controller API in the migration guide (*)
  2be7334... Merge branch 'global-coords' into 'master' (*)
  3874f37... node editor: Add a quick way to save a testcase (*)
  90f330e... Merge branch 'gesture-click' into 'master' (*)
  f507a79... marshallers: ensure g_cclosure_marshal_VOID__VOIDv is used (*)
  164e362... Merge branch 'wip/chergert/marshal-gtk4' into 'master' (*)
  82afe85... marshallers: add missing g_cclosure_marshal_VOID__VOID fixe (*)
  e0cc72e... Fix shortcuts window sizing (*)
  853e832... Merge branch 'shortcuts-sizing' into 'master' (*)
  3a0beea... profiler: port GdkProfiler to sysprof-3 (*)
  3f6b64f... Merge branch 'wip/chergert/sysprof-3' into 'master' (*)
  d691393... Merge branch 'wip/baedert/nodeeditor-fuckery' into 'master' (*)
  78ee4c0... gl renderer: Properly flip scaled fallback nodes (*)
  2d55fce... builder-tool: Rewrite GtkBuilder templates too (*)
  1e7225a... builder-tool: Set the parent of newly created GtkAssistantP (*)
  dad5da8... Merge branch 'lr/builder-tool-assistant-crash' into 'master (*)
  93a34eb... Merge branch 'lr/builder-tool-templates' into 'master' (*)
  d71bf4d... Add gtknative.h to public headers (*)
  2f37207... Remove leftover debug spew (*)
  1e0c0c0... rendernodeparser: Parse cairo script (*)
  53f23f8... rendernodeparser: Handle empty Cairo nodes (*)

(*) This commit already existed in another branch; no separate mail sent


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]