[gtk] (152 commits) Non-fast-forward update to branch wip/matthiasc/popup5



The branch 'wip/matthiasc/popup5' was changed in a way that was not a fast-forward update.
NOTE: This may cause problems for people pulling from the branch. For more information,
please see:

 https://wiki.gnome.org/Git/Help/NonFastForward

Commits removed from the branch:

  e6f7387... Export gtk_widget_render privately
  4cef7af... widget: guard popover-specific code paths
  433f9fd... main: guard window-specific code paths
  71a443b... Introduce GtkNative
  7ef9ddb... window: Implement GtkNative
  ed0b53f... root: Require GtkNative
  00821c5... root: Make gtk_root_get_display public
  96e3cc8... Review and replace uses of get_toplevel
  0fb21a2... widget: Don't snapshot foreign children
  787e4c2... widget: Use GtkNative
  0e2e7d4... Add gtk_widget_get_native
  4eb3252... Introduce event controller propagation limits
  6492b77... surface: Start sketching a new surface type
  5d305b0... Reimplement GtkPopover
  28cd145... Adapt to new popover lifecycle
  92c4d73... menubutton: Allocate the popover
  d97a0b9... Adwaita: Give popover menus a background
  b669af9... widget: Remove some unneeded popover special-casing
  627f3c7... main: Remove special-case hiding popopvers
  0412f6e... main: Use gtk_widget_get_native
  2728c38... entry completion: Use a popover
  8fa4a44... x11: Stop using child surface api
  1082c21... wayland: Stop using child surface apis
  d7f8fc4... xim: Stop using child surface apis
  5f47a65... a11y: Stop supporting ATK_XY_SCREEN
  0d7057f... widget: Stop using child surface apis
  66487aa... Drop child surfaces
  53ea395... surface: minor cleanup
  7a70ad1... surface: Remove code dealing with child surfaces
  8e9350a... wayland: Stop using surface->parent
  7d734a2... x11: Stop using surface->parent
  88fc6ad... broadway: Stop using surface->parent
  6a90c04... gdk: Stop using surface->parent
  92c274c... Remove surface->parent
  4ec7d18... wayland: Stop using surface->children
  14214f9... gdk: Stop using surface->children
  5e7882a... Remove surface->children
  90758ee... surface: Simplify some code
  fc0ea3c... surface: Small cleanup
  4493b4d... surface: Remove abs_x/abs_y
  3ef4bb4... surface: Simplify destroy implementation
  086296a... surface: Small simplification
  4735962... Remove gdk_surface_coords_to/from_parent
  debde82... Remove gdk_surface_get_root_coords as public api
  6929eae... Drop gdk_surface_get_root_origin
  af3c766... Remove gdk_surface_get_geometry as public api
  1800f26... x11: Drop a gratitious use of gdk_event_get_root_coords
  47b8b8d... surface: Make gdk_surface_get_device_position void
  1ff8f03... menu: Stop using gtk_widget_register_surface
  7d06b95... window: Stop using gtk_widget_register_surface
  550eb0b... popover: Stop using gtk_widget_register_surface
  8383c07... Drop gtk_widget_register_surface
  601af4e... gdk: Remove remnants of client-side windows
  59bd653... docs: Remove references to gdk_device_grab
  723f685... wayland: Remove a useless switch
  fe3eede... broadway: Stop using gdk_surface_new_temp
  ee26982... x11: Stop using gdk_surface_new_temp
  d4e6512... menu: Stop using gdk_surface_new_temp
  9065719... Drop gdk_surface_new_temp
  fde847f... gdk: Remove an unused field
  7ba9c5f... gdk: Drop input-only surfaces
  963724d... gdk: Drop GdkWindowAttr
  9a0dc5d... gdk: Drop pass-through surfaces
  9d7cf27... surface: Cosmetics
  dda937e... Rename surface constructors
  65b72a5... gdk: Add a private header
  6b02aca... Get rid of GdkSurfaceImpl
  2110a4d... x11: Remove useless checks
  13a4961... gdk: Introduce a popup surface type
  e382fae... surface: Store popup parent
  ccfb538... surface: Make move-to-rect work for popups
  6c3c233... surface: Stop setting transient-for for popups
  8e31a00... wayland: Use popup parents
  170fb74... x11: Implement popup surfaces
  1af0aec... broadway: Track popups
  3096acf... surface: Add an autohide property
  3cf5e9f... popover: Use GdkSurface::autohide
  9a34382... surface: Remove old debug code
  09eb17f... surface: Remove gdk_surface_set/merge_child_input_shapes()
  8e7db0d... Add gdk_surface_get_parent back
  004b1d1... widget: Improve warning messages
  f47eae3... widget: Optimize resize propagation
  65899e3... window: Don't inherit cursors across surfaces
  de2baf8... text: Allocate popovers
  65f759f... scale button: Allocate popovers
  114c6f5... entry: Allocate popovers
  87ab33e... color swatch: Allocate popovers
  1946913... places sidebar: Allocate popovers
  d8e03b9... text view: Allocate popovers
  745911f... widget: Remove a popover special case
  e6cb4d7... node editor: Adapt to GtkNative
  b873e0c... Add a testcase for size allocation
  4aa8cd8... gdk: Inherit the frame clock for popups
  61cd79a... x11: Fix handling of frame clock freezes
  f0786d9... popover: Bring back the beak
  88d6beb... Add a GdkSurface::parent property
  9b10592... Remove gtk_widget_get/set_has_surface
  c084dda... Work toward dropping widget->surface
  23bf744... Drop GtkWidget::surface
  4b7fadb... Drop gtk_widget_set_surface
  9d38497... window: Make unrealize work again
  b13dedf... testsuite: Fix popover-related failures
  3ed3a6f... testsuite: Fix some a11y output
  f91a015... win32: Build fixes
  fa4347d... popover: Rename modal to autohide
  6802963... builder tool: Handle modal->autohide rename
  5916b1b... Add a test for the property renaming
  0e874a7... Mention modal->autohide rename in migration guide
  170916f... Stop using gtk_widget_get_surface
  0834772... Drop gtk_widget_get_surface
  43ced3e... Mention gtk_widget_get_surface in the migration guide
  787d386... Stop using gtk_widget_is_toplevel
  000ac30... Drop gtk_widget_is_toplevel
  747d1b2... Mention gtk_widget_is_toplevel in the migration guide
  1178dac... Cosmetics
  afa3bd4... Stop using gtk_widget_get_toplevel
  d337bd0... Drop gtk_widget_get_toplevel
  ca87565... Mention gtk_widget_get_toplevel in the migration guide.
  c77135a... Cosmetics
  a1d8807... wayland: recreate serverside resources on show
  063b6de... tooltip: fix critical warnings
  440df62... color plane: Don't allocate 0-size textures
  25955dc... surface: Don't dispose the frame clock prematurely
  c58e149... GDK W32: be able to handle NULL cursor
  41e09dd... GDK W32: Fix the code to compile
  884cd60... IME IM: Be able to handle NULL widget correctly
  2f13881... win32: Set the surface type
  7258217... popover: Set input shapes on wayland too
  fddab8c... Remove debug spew
  00aa7bd... popover: Make it possible to not have an arrow
  16428ea... inspector: Avoid a critical warning
  440b632... popover: fixup
  5815a44... Adwaita: Remove Emoji completion special case
  d908949... surface: Make surface-type a property
  ba21b2f... surface: Make only toplevels control events
  a9bb715... gdk: Maintain popup tree in the frontend
  7a4c694... surface: Handle paint recursively
  7afd553... win32: Set surface type early enough
  6d2bdd2... surface: Fix the fallback move-to-rect implementation
  9e5f939... popover: Stop needles allocations
  8c0c047... fishbowl: Don't pop up popovers too early
  1ccac41... broadway: Disconnect from the frame clock
  4e2c2b4... x11: Disconnect from the frame clock
  6d1ff38... surface: Give backends a chance to disconnect

Commits added to the branch:

  beedec1... broadway: add frame times to the profiler (*)
  e95e39c... widget-factory: Add some animation in a popover (*)
  c50052e... Revert "wayland: Keep some resources until destroy" (*)
  0cd8dd4... inspector: Make updates overlay not crash (*)
  fda6439... rendernode: Remove unused function (*)
  928c85c... rendernodeparser: Parse Cairo nodes (*)
  8d1f05f... Cosmetics (*)
  4df64bc... color plane: Don't allocate 0-size textures (*)
  71cc68b... surface: fix up docs (*)
  848f658... Trivial (*)
  bec8973... Export gtk_widget_render privately
  0164d2c... widget: guard popover-specific code paths
  65410e7... main: guard window-specific code paths
  e3733d2... Introduce GtkNative
  f5cb0d3... window: Implement GtkNative
  b20e146... root: Require GtkNative
  02864aa... root: Make gtk_root_get_display public
  31edfbf... Review and replace uses of get_toplevel
  e5e02bc... widget: Don't snapshot foreign children
  4e12e7c... widget: Use GtkNative
  e668251... Add gtk_widget_get_native
  382a2a4... Introduce event controller propagation limits
  0dc8833... surface: Start sketching a new surface type
  bc82a8e... Reimplement GtkPopover
  fdc9764... Adapt to new popover lifecycle
  86925c2... menubutton: Allocate the popover
  29ae65e... Adwaita: Give popover menus a background
  54da0a6... widget: Remove some unneeded popover special-casing
  ed79463... main: Remove special-case hiding popopvers
  ea3e490... main: Use gtk_widget_get_native
  5ad2e5c... entry completion: Use a popover
  2568773... x11: Stop using child surface api
  a467079... wayland: Stop using child surface apis
  1024dd3... xim: Stop using child surface apis
  20287b9... a11y: Stop supporting ATK_XY_SCREEN
  86e3c45... widget: Stop using child surface apis
  f131dbd... Drop child surfaces
  f9a62ee... surface: minor cleanup
  1143577... surface: Remove code dealing with child surfaces
  c9cea76... wayland: Stop using surface->parent
  297a867... x11: Stop using surface->parent
  aecd85f... broadway: Stop using surface->parent
  3f65c09... gdk: Stop using surface->parent
  4c521e4... Remove surface->parent
  b625acd... wayland: Stop using surface->children
  2d37b66... gdk: Stop using surface->children
  4ff0124... Remove surface->children
  928c701... surface: Simplify some code
  283210e... surface: Small cleanup
  733b180... surface: Remove abs_x/abs_y
  8a130e9... surface: Simplify destroy implementation
  4cae073... surface: Small simplification
  7b95c34... Remove gdk_surface_coords_to/from_parent
  fbf1f1d... Remove gdk_surface_get_root_coords as public api
  8a6c943... Drop gdk_surface_get_root_origin
  cf21390... Remove gdk_surface_get_geometry as public api
  f6d94f9... x11: Drop a gratitious use of gdk_event_get_root_coords
  35069ef... surface: Make gdk_surface_get_device_position void
  06501f6... menu: Stop using gtk_widget_register_surface
  c60000a... window: Stop using gtk_widget_register_surface
  add7cbe... popover: Stop using gtk_widget_register_surface
  fe557ef... Drop gtk_widget_register_surface
  8812303... gdk: Remove remnants of client-side windows
  8068fd4... docs: Remove references to gdk_device_grab
  a81e5dd... wayland: Remove a useless switch
  fcbc6ee... broadway: Stop using gdk_surface_new_temp
  da80264... x11: Stop using gdk_surface_new_temp
  0fe35d3... menu: Stop using gdk_surface_new_temp
  999706d... Drop gdk_surface_new_temp
  89350e5... gdk: Remove an unused field
  2fe42c2... gdk: Drop input-only surfaces
  c5ab812... gdk: Drop GdkWindowAttr
  e2d8bf9... gdk: Drop pass-through surfaces
  4f5dee0... surface: Cosmetics
  8425e97... Rename surface constructors
  a476a29... gdk: Add a private header
  c397fa7... Get rid of GdkSurfaceImpl
  ce7e993... x11: Remove useless checks
  3ea6989... gdk: Introduce a popup surface type
  6108ee3... surface: Store popup parent
  bfefecf... surface: Make move-to-rect work for popups
  ea2c32a... surface: Stop setting transient-for for popups
  cc548c7... wayland: Use popup parents
  e138c73... x11: Implement popup surfaces
  e707487... broadway: Track popups
  d255d4c... surface: Add an autohide property
  3372af9... popover: Use GdkSurface::autohide
  7dd4bf6... surface: Remove old debug code
  1f83a1b... surface: Remove gdk_surface_set/merge_child_input_shapes()
  6a8ab84... Add gdk_surface_get_parent back
  fba28fa... widget: Improve warning messages
  d4a5513... widget: Optimize resize propagation
  ea43a50... window: Don't inherit cursors across surfaces
  422efff... text: Allocate popovers
  3a55065... scale button: Allocate popovers
  e6a23bc... entry: Allocate popovers
  e2ecdf7... color swatch: Allocate popovers
  d4ea751... places sidebar: Allocate popovers
  65e5c55... text view: Allocate popovers
  a4330df... widget: Remove a popover special case
  2563723... node editor: Adapt to GtkNative
  fa05e10... Add a testcase for size allocation
  cbdbfb5... gdk: Inherit the frame clock for popups
  9e42fdd... x11: Fix handling of frame clock freezes
  4eec4d6... popover: Bring back the beak
  a92adea... Add a GdkSurface::parent property
  6536481... Remove gtk_widget_get/set_has_surface
  08a605b... Work toward dropping widget->surface
  5f71e39... Drop GtkWidget::surface
  637dd6f... Drop gtk_widget_set_surface
  ed56102... window: Make unrealize work again
  0a52fa0... testsuite: Fix popover-related failures
  9de8f3c... testsuite: Fix some a11y output
  7da0cdc... win32: Build fixes
  bb896e5... popover: Rename modal to autohide
  6876335... builder tool: Handle modal->autohide rename
  44a590a... Add a test for the property renaming
  3f206ee... Mention modal->autohide rename in migration guide
  6b53314... Stop using gtk_widget_get_surface
  7cf1735... Drop gtk_widget_get_surface
  2cef002... Mention gtk_widget_get_surface in the migration guide
  e2fb4fc... Stop using gtk_widget_is_toplevel
  6120dfb... Drop gtk_widget_is_toplevel
  3ddd06d... Mention gtk_widget_is_toplevel in the migration guide
  51a9ec7... Cosmetics
  7486cff... Stop using gtk_widget_get_toplevel
  c14ffd2... Drop gtk_widget_get_toplevel
  dd938fa... Mention gtk_widget_get_toplevel in the migration guide.
  0102c4c... tooltip: fix critical warnings
  dc3aba2... surface: Don't dispose the frame clock prematurely
  3faa9b3... GDK W32: be able to handle NULL cursor
  584f4cb... GDK W32: Fix the code to compile
  65ee92e... IME IM: Be able to handle NULL widget correctly
  f4dddf6... win32: Set the surface type
  4b456e7... popover: Set input shapes on wayland too
  35205c4... popover: Make it possible to not have an arrow
  9fe781f... inspector: Avoid a critical warning
  ca9c2a2... Adwaita: Remove Emoji completion special case
  7b82175... surface: Make surface-type a property
  2f14d1a... gdk: Maintain popup tree in the frontend
  fcb4a8b... surface: Make only toplevels control events
  079271d... win32: Set surface type early enough
  3bfde25... surface: Fix the fallback move-to-rect implementation
  b92ca1e... popover: Stop needles allocations
  6900259... fishbowl: Don't pop up popovers too early
  56ee56d... surface: Give backends a chance to disconnect
  aaeb521... broadway: Disconnect from the frame clock
  3332d14... x11: Disconnect from the frame clock
  a0658f1... win32: Disconnect the frame clock
  d859931... wayland: Disconnect the frame clock
  c4c2ce9... popover: Don't constantly redraw the beak
  d9f3ae0... surface: Cosmetics

(*) This commit already existed in another branch; no separate mail sent


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]