[gtk] (109 commits) Non-fast-forward update to branch wip/matthiasc/popup5



The branch 'wip/matthiasc/popup5' was changed in a way that was not a fast-forward update.
NOTE: This may cause problems for people pulling from the branch. For more information,
please see:

 https://wiki.gnome.org/Git/Help/NonFastForward

Commits removed from the branch:

  c7aea6d... Export gtk_widget_render privately
  835671a... widget: guard popover-specific code paths
  c0bc056... main: guard window-specific code paths
  fcdc62d... Introduce GtkNative
  bd31bd2... window: Implement GtkNative
  7415d83... root: Require GtkNative
  2cf7c86... root: Make gtk_root_get_display public
  46fe7b1... Review and replace uses of get_toplevel
  d7d1b76... widget: Don't snapshot foreign children
  76a1bbd... widget: Use GtkNative
  eec26c2... Add gtk_widget_get_native
  ca77565... Introduce event controller propagation limits
  dc0fa81... surface: Start sketching a new surface type
  e3d6979... Reimplement GtkPopover
  599c78d... Adapt to new popover lifecycle
  d9ae198... menubutton: Allocate the popover
  ff3440c... Adwaita: Give popover menus a background
  06e6433... widget: Remove some unneeded popover special-casing
  974a99d... main: Remove special-case hiding popopvers
  29ebf64... main: Use gtk_widget_get_native
  9f61aea... entry completion: Use a popover
  be045a6... x11: Stop using child surface api
  90fe05f... wayland: Stop using child surface apis
  666ef97... xim: Stop using child surface apis
  616d950... a11y: Stop supporting ATK_XY_SCREEN
  ae7330f... widget: Stop using child surface apis
  53fa8c8... Drop child surfaces
  859138a... surface: minor cleanup
  931522c... surface: Remove code dealing with child surfaces
  00a509c... wayland: Stop using surface->parent
  8a18112... x11: Stop using surface->parent
  b0b0b5f... broadway: Stop using surface->parent
  210f9f7... gdk: Stop using surface->parent
  5b72d73... Remove surface->parent
  5c4197a... wayland: Stop using surface->children
  59948a1... gdk: Stop using surface->children
  02bc446... Remove surface->children
  92b7862... surface: Simplify some code
  469317f... surface: Small cleanup
  39f4567... surface: Remove abs_x/abs_y
  a6fd74a... surface: Simplify destroy implementation
  e07081f... surface: Small simplification
  5ac10cf... Remove gdk_surface_coords_to/from_parent
  1076000... Remove gdk_surface_get_root_coords as public api
  2e2a4ec... Drop gdk_surface_get_root_origin
  822dc32... Remove gdk_surface_get_geometry as public api
  d61f5ba... x11: Drop a gratitious use of gdk_event_get_root_coords
  95cb9b9... surface: Make gdk_surface_get_device_position void
  1531cd8... menu: Stop using gtk_widget_register_surface
  1af9ace... window: Stop using gtk_widget_register_surface
  4e49eba... popover: Stop using gtk_widget_register_surface
  4eecebc... Drop gtk_widget_register_surface
  cc65fd7... gdk: Remove remnants of client-side windows
  84a5d6b... docs: Remove references to gdk_device_grab
  dba048f... wayland: Remove a useless switch
  5ce9652... broadway: Stop using gdk_surface_new_temp
  842a3a8... x11: Stop using gdk_surface_new_temp
  519448e... menu: Stop using gdk_surface_new_temp
  581709b... Drop gdk_surface_new_temp
  305cdd2... gdk: Remove an unused field
  9c4c15f... gdk: Drop input-only surfaces
  b9e8487... gdk: Drop GdkWindowAttr
  8805054... gdk: Drop pass-through surfaces
  d8e0291... surface: Cosmetics
  06e8616... Rename surface constructors
  c5dc0b5... gdk: Add a private header
  7e1cac5... Get rid of GdkSurfaceImpl
  0132cdb... x11: Remove useless checks
  3ccb442... gdk: Introduce a popup surface type
  057ec70... surface: Store popup parent
  b591957... surface: Make move-to-rect work for popups
  0b48d3a... surface: Stop setting transient-for for popups
  af33a40... wayland: Use popup parents
  97270a0... x11: Implement popup surfaces
  7090ba6... broadway: Track popups
  a44f10b... surface: Add gdk_surface_show_with_auto_dismissal
  bffea2c... popover: Use gdk_surface_show_with_auto_dismissal
  80a1ddc... surface: Remove old debug code
  79fc713... surface: Remove gdk_surface_set/merge_child_input_shapes()
  6160597... Add gdk_surface_get_parent back
  b41b70c... widget: Improve warning messages
  6b9b6b1... widget: Optimize resize propagation
  e935040... window: Don't inherit cursors across surfaces
  4cfd996... text: Allocate popovers
  8e47320... scale button: Allocate popovers
  d7f3247... entry: Allocate popovers
  4918706... color swatch: Allocate popovers
  3385112... places sidebar: Allocate popovers
  4764654... text view: Allocate popovers
  60ce5b2... widget: Remove a popover special case
  17f7342... node editor: Adapt to GtkNative
  373f1a8... Add a testcase for size allocation
  45fd973... gdk: Inherit the frame clock for popups
  ebeb695... x11: Fix handling of frame clock freezes
  18afaee... popover: Bring back the beak
  de80eaf... Add a GdkSurface::parent property
  05c27c5... Remove gtk_widget_get/set_has_surface
  998519c... Work toward dropping widget->surface
  b31fd0f... Drop GtkWidget::surface
  9beb569... Drop gtk_widget_set_surface
  9e70e1c... window: Make unrealize work again
  c425d59... testsuite: Fix popover-related failures
  f336d9b... testsuite: Fix some a11y output
  f4ca247... win32: Build fixes
  474c9c5... Redo autohide as surface property
  61c428a... popover: Adapt to surface api change

Commits added to the branch:

  322507f... builder-tool: Remove debug spew (*)
  5b293b8... Export gtk_widget_render privately
  bc73b0f... widget: guard popover-specific code paths
  415312f... main: guard window-specific code paths
  3665621... Introduce GtkNative
  6261c1c... window: Implement GtkNative
  d34f1e6... root: Require GtkNative
  65b91aa... root: Make gtk_root_get_display public
  decbd1d... Review and replace uses of get_toplevel
  df0bfae... widget: Don't snapshot foreign children
  2b85080... widget: Use GtkNative
  39c2b72... Add gtk_widget_get_native
  647e3eb... Introduce event controller propagation limits
  411393e... surface: Start sketching a new surface type
  611fa3b... Reimplement GtkPopover
  0ec6f47... Adapt to new popover lifecycle
  6c44970... menubutton: Allocate the popover
  cd84789... Adwaita: Give popover menus a background
  62b9d7b... widget: Remove some unneeded popover special-casing
  3630c88... main: Remove special-case hiding popopvers
  e3a069b... main: Use gtk_widget_get_native
  30bfda5... entry completion: Use a popover
  0fe2b81... x11: Stop using child surface api
  68c96e4... wayland: Stop using child surface apis
  2741459... xim: Stop using child surface apis
  93a2765... a11y: Stop supporting ATK_XY_SCREEN
  50bc7a9... widget: Stop using child surface apis
  5168508... Drop child surfaces
  2bc6ed4... surface: minor cleanup
  33571fd... surface: Remove code dealing with child surfaces
  d46a5d0... wayland: Stop using surface->parent
  eb0297a... x11: Stop using surface->parent
  03bb67e... broadway: Stop using surface->parent
  2e3af08... gdk: Stop using surface->parent
  7eb5951... Remove surface->parent
  3155ccf... wayland: Stop using surface->children
  f367390... gdk: Stop using surface->children
  ab375f0... Remove surface->children
  fdbed65... surface: Simplify some code
  2a776e8... surface: Small cleanup
  5d17f77... surface: Remove abs_x/abs_y
  1afcc9f... surface: Simplify destroy implementation
  672412e... surface: Small simplification
  8c2d611... Remove gdk_surface_coords_to/from_parent
  0d8e1db... Remove gdk_surface_get_root_coords as public api
  c8769fe... Drop gdk_surface_get_root_origin
  08314e0... Remove gdk_surface_get_geometry as public api
  472d8ff... x11: Drop a gratitious use of gdk_event_get_root_coords
  bcfd8a7... surface: Make gdk_surface_get_device_position void
  0218910... menu: Stop using gtk_widget_register_surface
  f52fd4d... window: Stop using gtk_widget_register_surface
  53cfdb3... popover: Stop using gtk_widget_register_surface
  829165e... Drop gtk_widget_register_surface
  22578a6... gdk: Remove remnants of client-side windows
  691ea3e... docs: Remove references to gdk_device_grab
  a929030... wayland: Remove a useless switch
  ac05640... broadway: Stop using gdk_surface_new_temp
  ac125da... x11: Stop using gdk_surface_new_temp
  9666dbd... menu: Stop using gdk_surface_new_temp
  c70f24c... Drop gdk_surface_new_temp
  73212b0... gdk: Remove an unused field
  5e5ec47... gdk: Drop input-only surfaces
  98b9af6... gdk: Drop GdkWindowAttr
  5babe18... gdk: Drop pass-through surfaces
  945b6ec... surface: Cosmetics
  4876828... Rename surface constructors
  f878aad... gdk: Add a private header
  519fc55... Get rid of GdkSurfaceImpl
  731eadd... x11: Remove useless checks
  e34876f... gdk: Introduce a popup surface type
  5736639... surface: Store popup parent
  b067914... surface: Make move-to-rect work for popups
  77808f1... surface: Stop setting transient-for for popups
  a14e07c... wayland: Use popup parents
  9e6be2d... x11: Implement popup surfaces
  dfaf492... broadway: Track popups
  b97a348... surface: Add an autohide property
  c69c34e... popover: Use GdkSurface::autohide
  5d01786... surface: Remove old debug code
  7b828c2... surface: Remove gdk_surface_set/merge_child_input_shapes()
  a2000e7... Add gdk_surface_get_parent back
  8c690c4... widget: Improve warning messages
  383a215... widget: Optimize resize propagation
  6726be2... window: Don't inherit cursors across surfaces
  31a5dc6... text: Allocate popovers
  32c65c9... scale button: Allocate popovers
  1eed3cd... entry: Allocate popovers
  90dc531... color swatch: Allocate popovers
  dc73094... places sidebar: Allocate popovers
  385001d... text view: Allocate popovers
  5fb0505... widget: Remove a popover special case
  2a24b74... node editor: Adapt to GtkNative
  52e5fde... Add a testcase for size allocation
  bfab2b0... gdk: Inherit the frame clock for popups
  e1fac2e... x11: Fix handling of frame clock freezes
  1f705ba... popover: Bring back the beak
  c92ad8b... Add a GdkSurface::parent property
  346734f... Remove gtk_widget_get/set_has_surface
  b61477f... Work toward dropping widget->surface
  e36cea5... Drop GtkWidget::surface
  4d0524b... Drop gtk_widget_set_surface
  64e612e... window: Make unrealize work again
  4023b30... testsuite: Fix popover-related failures
  7322d7c... testsuite: Fix some a11y output
  65a2a68... win32: Build fixes
  47520f6... popover: Rename modal to autohide
  1a40ffc... builder tool: Handle modal->autohide rename
  5d3f6f1... Add a test for the property renaming
  b9eb4af... Mention modal->autohide rename in migration guide

(*) This commit already existed in another branch; no separate mail sent


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]