[librsvg] (90 commits) ...Merge branch 'viewport-with-offsets'
- From: Federico Mena Quintero <federico src gnome org>
- To: commits-list gnome org
- Cc:
- Subject: [librsvg] (90 commits) ...Merge branch 'viewport-with-offsets'
- Date: Tue, 26 Mar 2019 19:12:03 +0000 (UTC)
Summary of changes:
812b445... Add test for render_element_to_viewport() with a viewport n
2f119bb... DrawingCtx: don't use the base offsets at all
2bf5d08... NodeSvg: Use the initial viewport when rendering the toplev
618f8de... rsvg-test: Try a 0 offset for the frame; this makes all tes
52397dc... DrawingCtx.with_discrete_layer(): Add a few missing map_err
28b5c86... DrawingCtx.get_offset() - removed, since it always returned
16e81cb... DrawingCtx::new() - No need to calculate a specific affine
243e7d2... DrawingCtx::set_affine_on_cr() - Removed, since it wasn't c
6c44feb... wip: test render_to_viewport_with_transform()
5951d00... DrawingCtx: Centralize the place where a viewport-sized sur
96c525e... DrawingCtx: extract function to get the clipping node
3916d6f... DrawingCtx: extract function to do the actual clipping to t
21810bd... DrawingCtx: clarify the mask vs. no-mask case a bit
e640a60... DrawingCtx: Remove the original_cr confusion; it's always t
c317759... Don't mutate the DrawingCtx's bbox in the clipping code
425a521... Pass the current bbox as immutable to the masking code
cf6dd43... Convince myself that the bbox in the FilterContext is alway
d87504e... Pass the bbox of the node being filtered to the filters; do
f6a536a... Pass the current node_bbox to the filters from the toplevel
ef82e13... Replace the explicit bbox_stack by an implicit one
02a8dac... Split with_discrete_layer() into two cases
9d14cd1... Don't get the temporary surface in a roundabout way
305d2d8... DrawingCtx::is_cairo_context_nested(): Removed; now the off
da3fb67... DrawingCtx.initial_cr: removed field, it is no longer used
821e801... DrawingCtx.initial_affine - store the initial affine of the
8dce1ac... with_discrete_layer(): Restore the state completely if a fi
d49e82e... clip_path.rs: Remove superfluous rebinding of the cr
bdcd78d... NodeClipPath.to_cairo_context() - reorder code a bit
08f9bb3... NodeClipPath.to_cairo_context() - Simplify the way in which
2bef6ae... DrawingCtx.with_saved_matrix() - new function
5ae6773... clip_path.rs: use DrawingCtx.with_saved_matrix()
e870e9f... node.rs: use DrawingCtx.with_saved_matrix()
1bddf63... DrawingCtx.with_saved_cr() - new function
5234199... image.rs: use DrawingCtx.with_saved_cr()
18c9a91... text.rs: use DrawingCtx.with_saved_cr()
eadebf4... marker.rs: use DrawingCtx.with_saved_cr()
188761f... with_discrete_layer(): use DrawingCtx.with_saved_cr()
b38b9eb... with_discrete_layer(): avoid a temporary result
3ae3bb1... PathBuilder::to_cairo() - Check the cr.status after complet
325b736... (#438): Only create a temporary ImageSurface if we'll need
677eed4... Oops, we just need the cairo::prelude for SurfaceExt
c469441... NodeClipPath.to_cairo_context(): Don't take an affine; use
19fb7e8... DrawingCtx::mask_surface(): inline into its only caller
e164765... NodeClipPath::to_cairo_context(): Move the short-circuit if
14b8d03... Rename variable
2f67f2d... NodeMask::generate_cairo_mask(): Move the short-circuit if
a061a7d... Clarify just when we are measuring the toplevel SVG
444a435... Use a single conditional to figure out the SVG's viewport/v
9191af6... Rename variable
65484a7... compute_luminance_to_alpha(): Take a SharedImageSurface, no
a6d6f38... (#445): Initialize libxml2 so multithreaded tests don't dea
6bbfe94... Reset back to the initial_affine before clipping
229f320... Reset back to the initial_affine before masking
0d2785b... start breakage: restore the offset in rsvg-test
168ab90... When using a temporary surface, un-transform by the initial
f133df9... clip_to_node() - don't consume the node reference
ff217e7... New test for clipping to a viewport offsetted by a transfor
8dc1cd1... New test for masking to a viewport offsetted by a transform
dff605d... Only use an untransformed affine if the cr_stack is empty
3aee493... tests/render_to_viewport.rs: Extract function to do the ren
896ce3f... tests/render_to_viewport.rs: Extract function to compare th
1bc5d34... Make a librsvg_crate/tests/utils module
fec1130... Rename test_file to compare_to_file
54fc926... librsvg_crate/tests/primitives.rs - New tests for drawing p
21062b3... Offset the initial_affine by the original viewport
0f8a7f7... opacity_inside_transformed_group(): New test for what cause
7b07dd5... Nested temporary surfaces should not be offset with respect
78d4865... Print where the test suite is outputting test artifacts
be32065... Extract function to copy a surface to a SharedImageSurface
be7a9ea... Initialize the DrawingCtx's bbox with the initial affine, f
d2e4faf... Don't rebind "affine", since we need the original value
a44837e... Compute all of the affines in the same place
464da35... Rename variable
f8d93ef... Compute the initial_inverse only once
20815c7... Extract computation of affines to a separate function
7e7dfb0... Rename CompositingAffines.temporary to .for_temporary_surfa
39b5cba... Pass the whole CompositingAffines to the masking code
1ac98bf... Pass the intial offsetted affine as part of CompositingAffi
5a250ae... Oops, use the compositing affine when setting the mask
e8f9791... Move the decision about the topmost temporary surface to Co
736a22a... Rename "node" to "mask_node" when appropriate
2d8eb09... CompositingAffines.outside_temporary_surface - renamed from
ac644f9... Obviate the need for reusing a previous result
465c207... Push/pop the cairo_t while drawing a mask's contents
c509eb4... Fix the affines used in get_snapshot()
9d9a17c... Extract function to compute the size of the temporary surfa
324687a... (#295): Ensure the initial viewport fits into temporary sur
b8937c3... Handle.render_cairo_sub() - implement in terms of render_el
906d495... librsvg_crate/tests: Broken try at explicitly loading fixtu
69873e0... Merge branch 'viewport-with-offsets'
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]