[gnome-shell-extensions/wip/jimmac/duller-classic-mode: 3/19] window-list: Use a more specific GTypeName for workspace indicator
- From: Jakub Steiner <jimmac src gnome org>
- To: commits-list gnome org
- Cc:
- Subject: [gnome-shell-extensions/wip/jimmac/duller-classic-mode: 3/19] window-list: Use a more specific GTypeName for workspace indicator
- Date: Wed, 3 Jul 2019 13:01:52 +0000 (UTC)
commit 967e8ce8747ee04cf872f7e50367b30741804845
Author: Florian Müllner <fmuellner gnome org>
Date: Wed Jun 5 17:39:53 2019 +0000
window-list: Use a more specific GTypeName for workspace indicator
Now that the class inherits from GObject, the generic name easily
conflicts with other classes otherwise, for example with the one
from the workspace-indicator extension.
https://gitlab.gnome.org/GNOME/gnome-shell-extensions/merge_requests/70
extensions/window-list/workspaceIndicator.js | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
---
diff --git a/extensions/window-list/workspaceIndicator.js b/extensions/window-list/workspaceIndicator.js
index fb3ffe7..8ac43eb 100644
--- a/extensions/window-list/workspaceIndicator.js
+++ b/extensions/window-list/workspaceIndicator.js
@@ -7,8 +7,9 @@ const PopupMenu = imports.ui.popupMenu;
const Gettext = imports.gettext.domain('gnome-shell-extensions');
const _ = Gettext.gettext;
-var WorkspaceIndicator = GObject.registerClass(
-class WorkspaceIndicator extends PanelMenu.Button {
+var WorkspaceIndicator = GObject.registerClass({
+ GTypeName: 'WindowListWorkspaceIndicator'
+}, class WorkspaceIndicator extends PanelMenu.Button {
_init() {
super._init(0.0, _('Workspace Indicator'), true);
this.setMenu(new PopupMenu.PopupMenu(this, 0.0, St.Side.BOTTOM));
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]