[librsvg] Created tag 2.45.3



The signed tag '2.45.3' was created.

Tagger: Federico Mena Quintero <federico gnome org>
Date: 1546995899 -0600

    Tag for version 2.45.3

Changes since the last tag '2.45.2':

Carlos Martín Nieto (1):
      Port default DPI tracking to Rust

Federico Mena Quintero (47):
      Post-release version bump
      (#395): Morphology needs positive radii even after the transformation
      rustfmt
      rustfmt
      Log the element name when a pattern has a circular reference
      (#398): Detect circular references in gradients
      Merge branch 'cmartin/librsvg-default-dpi'
      Merge branch 'pborelli/librsvg-draw-ctx'
      Remove unused typedefs
      Clarify that there are no replacements for get_metadata/desc/title.
      Store the node ids in Svg, not in Defs
      Svg::load_from_stream(): Move code from Handle::read_stream_internal()
      handle::acquire_data() - Removed; inline this one-liner into all callers
      handle::acquire_stream() - Removed; inline this one-liner into all callers
      handle::load_css(): Return some errors, at least
      css::parse_into_css_styles() - Take a base_url, not a handle
      handle::get_dpi() - Inline into the single caller
      get_rust_handle(): Make private
      handle::load_extern(): No need to cascade the extern SVG
      handle::load_extern(): Take a LoadOptions, not a whole handle
      Defs::get_extern_handle(): Don't take a handle
      LoadFlags: renamed from LoadOptions
      LoadOptions: also store the base_url
      load_image_to_surface(): Take a LoadOptions, not a handle
      filters/image.rs: Don't store the handle; store the LoadOptions instead
      set_atts(): Don't take a *mut RsvgHandle, take a &LoadingOptions instead
      Defs::lookup() - take a LoadOptions, not a handle
      rsvg_return_*(): Removed.  Use g_return_*_if_fail() instead
      Clean up includes in rsvg-css.h
      Clean up math.h includes
      Removed the styles tests; they have been unused for a long while
      Clean up includes in rsvg-view.c
      Clean up includes in rsvg-base.c
      Clean up includes in rsvg-pixbuf.c
      Merge branch 'split-defs' into 'split-defs'
      Merge branch 'split-defs'
      Clean up includes in rsvg-tools-main.c
      Clean up includes in rsvg-handle.c
      rsvg-private.h: Removed.
      Add a test for rsvg_handle_set_size_callback()
      Test that the size_callback's destroy_notify is called if set twice
      Port all handling of the size_func to Rust
      Handle.set_base_url() - Move the load_state check to here
      rsvg_handle_set_base_gfile(): Port the implementation to Rust
      rsvg_handle_set_base_uri(): Assume that the string is really a URI
      Remove unused type
      Update NEWS

Jordan Petridis (2):
      text: Add explicit lifetime to an impl block
      Merge branch 'alatiera/add-lifetime' into 'master'

Paolo Borelli (38):
      pixbuf: shorten C code
      unit_interval: rename file to follow rust conventions
      handle: move is_loaded to rust
      handle: move is_at_start_for_setting_base_file to rust
      shapes: use a Points struct and impl Parse for it
      parsers: make optional_comma a method of the extension trait
      parsers: introduce a ParseValue trait
      shapes: use the ParseValue trait
      unit_interval: add constructor that clamps a f64
      gradient: store offset as a UnitInterval
      text: impl From trait for XmlLang
      drawing_ctx: clip() does not need a mutable reference
      text: remove last use of text_gravity_is_vertical
      image: do not compute bbox if we are returning early
      mask: move bit manipulation to the Pixel object
      drawing_ctx: move set_source_paint_server method
      text: move text drawing into text.rs
      paint_server: use associated type instead of generic
      pattern: error out in case of reference loop
      handle: move is_testing to rust
      handle: move the whole fontmap hack to tests
      text: whitespace cleanup
      text: move conversion trait for TextRendering
      drawing_ctx: add get_snapshot method
      drawing_ctx: add mask_surface method
      handle: move the size_func in the rust handle
      handle: move rsvg_handle_get_dimensions_sub to rust
      handle: move rsvg_handle_get_position_sub to rust
      handle: remove now unused function
      handle: move rsvg_handle_get_dimensions to rust
      handle: move is_loaded checks to rust
      handle: move the base_uri field to rust
      handle: check start state in the rust side of set_base_uri
      dpi: export function to C
      handle: consolidate allowed url check
      svg: store handle interally
      node: split resolve_resources method
      handle: cleanup read_stream_sync


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]