[librsvg] (80 commits) Non-fast-forward update to branch alatiera/debian-pixbuf-loader



The branch 'alatiera/debian-pixbuf-loader' was changed in a way that was not a fast-forward update.
NOTE: This may cause problems for people pulling from the branch. For more information,
please see:

 https://wiki.gnome.org/Git/Help/NonFastForward

Commits removed from the branch:

  0b4e666... CI: Work around a debian issue
  fc1609f... FIXME: Drop this commit

Commits added to the branch:

  3b2782e... CONTRIBUTING.md: Update rustfmt documentation (*)
  90698bf... Merge branch 'alatiera/rustfmt-docs' into 'master' (*)
  97c6998... Fix a feConvolveMatrix crash when kernel isn't set (*)
  7f672c3... Fix filters crashing on non-invertible paffine (*)
  1ebd485... Fix upper bound in PixelRectangle get_pixel clamp (*)
  e6cfd7d... Add a sanity check to PixelRectangle (*)
  aeae9f7... Merge branch 'YaLTeR/librsvg-fix-crashes' (*)
  121a76d... Update NEWS (*)
  cd0bea5... Remove unused macro_use (*)
  1e4c6cd... (#337) - Don't panic with "ex" or "em" units in the font-si (*)
  5992ad6... (#338): Don't panic when an image element doesn't have widt (*)
  c9fcf30... (#340): Don't panic when a marker has a zero-sized viewBox  (*)
  c647b69... AcquiredNodes: Use a Rc<...> instead of a raw pointer into  (*)
  0e3cfd8... AcquiredNode.get(): Return a reference, not a cloned Rc<> (*)
  cf2da58... NodeUse: release the acquired child as soon as possible (*)
  4b031aa... (#342): Don't crash if a <use> node references one of its a (*)
  c5f3175... Remove unused function (*)
  580beab... filters::render() - Take the computed values of the node be (*)
  470042d... Fix error message (*)
  2a45d8c... Minimal docs for AttributeError and NodeError (*)
  7e629ca... Rename AttributeError to ValueErrorKind (*)
  ca897b6... Rename methods to set styles from a pbag (*)
  252f3b7... Tighten an unsafe block (*)
  bfc7194... Split the scary Node.set_style() into three smaller functio (*)
  8e80f49... Node: add an element_name field (*)
  00c8801... Now that nodes know their element name, don't pass it down  (*)
  6d7e2a5... AspectRatio: don't use a helper function to parse (*)
  6169934... Align::parse_xy() - Take the full ident, not the &str versi (*)
  a45df3f... parse_align_xy(): This should be a standalone function, not (*)
  2bea05a... parse_fit_mode(): This should be a standalone function, not (*)
  90f327b... Makefile.am: Fix the location of the enum timestamp files (*)
  011dca9... (#341): Don't infinite-loop with cyclic pattern references (*)
  860e457... Makefile.am: Don't generate a ChangeLog for distribution an (*)
  7a9f9b2... Update NEWS (*)
  07c1745... Delete old samples and bugs directories (*)
  d558202... path_parser.rs: format the tests nicely and ask rustfmt to  (*)
  78c2ab1... (#345): path_parser.rs: Numbers must have digits; they can' (*)
  1b1fba9... with_discrete_layer(): Propagate errors from cairo::ImageSu (*)
  359be38... Remove stray printlns (*)
  f2b79f5... FilterContext::into_output(): propagate errors more simply (*)
  0fae07d... with_discrete_layer(): Separate out the filter rendering an (*)
  1833673... Update NEWS (*)
  ef53f00... rustfmt (*)
  7b44030... (#344): Don't let a viewBox with overflowing numbers pass t (*)
  ad6ab81... Update NEWS (*)
  a7c8410... Remove unused function (*)
  08f2881... css.rs: New file; start porting the CSS processing code to  (*)
  56248f8... Add FilterError::ChildNodeInError (*)
  5a7b60e... rsvg_handle_get_dimensions_sub() - Don't panic if we get pa (*)
  7239005... rsvg-dimensions.c: Fix the GOptionEntry for G_OPTION_REMAIN (*)
  8bee563... rsvg-dimensions.c: Be clear on whether a fragment is not fo (*)
  7b399da... compute_text_bbox(): Don't mutate the bbox directly; use it (*)
  8420e17... BoundingBox::with_ink_rect() - new method, analogous to wit (*)
  99e1440... tests/dimensions.c: Add infrastructure to test for object p (*)
  fb2612a... (#347): Set the ink_rect of Pango layouts, not just their o (*)
  529c9dd... Merge branch 'sub-positions' into 'master' (*)
  76d9a7c... (#343): Handle child being in error in feComponentTransfer (*)
  c534dcf... Handle child being in error in feMerge (*)
  4e01194... Handle child being in error in feLighting (*)
  0a847cc... (#346): Return Cairo errors from filters (*)
  a55db39... Merge branch 'YaLTeR/librsvg-fix-filters' (*)
  5de9090... Oops, add css.rs to Makefile.am (*)
  6f5ab7c... tests/Makefile.am: List the dimensions and styles fixtures  (*)
  ff392a8... croco.rs: Minimal hand-written binding to the part of libcr (*)
  62effee... css.rs: Basic skeleton for the CRDocHandler vtable (*)
  114a7d9... css.rs: Move most of the libcroco callbacks to Rust (*)
  3af8281... Move CSS importing to Rust (*)
  18d692e... Move rsvg_css_parse_color_() to rsvg-base.c (*)
  1040b17... Remove rsvg-styles.c - yay! (*)
  3ea5758... Add test for CSS imports. (*)
  1c63d21... Merge branch 'css-processing' into 'master' (*)
  611d74f... DrawingCtx.get_pango_context() - Use dpi_y for the Pango co (*)
  d8a9824... Round when converting userspace units to Pango units, which (*)
  dc4f584... (#348): Fix incorrect font sizing (*)
  5af45ef... Merge branch 'font-size-scaling' into 'master' (*)
  4386196... (#349): Don't panic when loading an external image that is  (*)
  a2acf5b... Merge branch 'too-large-image-data' into 'master' (*)
  2801ac0... css.rs: Fix usize cast (*)
  081300d... Merge branch 'alatiera/ulong' into 'master' (*)
  41f807a... CI: Workaround issue #331

(*) This commit already existed in another branch; no separate mail sent


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]