[gnome-shell/gbsneto/remove-generic-container: 23/39] appMenuButton: Rename show/hide to fadeIn/fadeOut
- From: Georges Basile Stavracas Neto <gbsneto src gnome org>
- To: commits-list gnome org
- Cc:
- Subject: [gnome-shell/gbsneto/remove-generic-container: 23/39] appMenuButton: Rename show/hide to fadeIn/fadeOut
- Date: Fri, 5 Oct 2018 21:36:22 +0000 (UTC)
commit 4566a281f09845c7cee326b7876fe31d0868a077
Author: Georges Basile Stavracas Neto <georges stavracas gmail com>
Date: Tue Aug 21 06:48:19 2018 -0300
appMenuButton: Rename show/hide to fadeIn/fadeOut
In the next commit, we will turn PanelMenu.ButtonBox into a
St.Widget subclass. As a domino effect, PanelMenu.Button will
become one too, and so will Panel.AppMenuButton.
When that happens, the current show() and hide() functions in
Panel.AppMenuButton will clash with Clutter.Actor's ones.
To avoid that, rename these functions to fadeIn() and fadeOut()
and avoid a name clash.
https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/153
js/ui/panel.js | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
---
diff --git a/js/ui/panel.js b/js/ui/panel.js
index 27ebec322..b6e831069 100644
--- a/js/ui/panel.js
+++ b/js/ui/panel.js
@@ -149,7 +149,7 @@ var AppMenuButton = new Lang.Class({
this._sync();
},
- show() {
+ fadeIn() {
if (this._visible)
return;
@@ -163,7 +163,7 @@ var AppMenuButton = new Lang.Class({
transition: 'easeOutQuad' });
},
- hide() {
+ fadeOut() {
if (!this._visible)
return;
@@ -314,9 +314,9 @@ var AppMenuButton = new Lang.Class({
shellShowsAppMenu &&
!Main.overview.visibleTarget);
if (visible)
- this.show();
+ this.fadeIn();
else
- this.hide();
+ this.fadeOut();
let isBusy = (this._targetApp != null &&
(this._targetApp.get_state() == Shell.AppState.STARTING ||
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]