[librsvg] Created tag 2.42.4



The signed tag '2.42.4' was created.

Tagger: Federico Mena Quintero <federico gnome org>
Date: 1525724562 -0500

    Tag for 2.42.4

Changes since the last tag '2.42.3':

Dmitry Kontsevoy (4):
      yield the identity transform for empty transform attribute
      aspect_ratio.rs: split AlignMode into (x,y)
      aspect_ratio.rs: use cssparser
      aspect_ratio.rs: move (x,y) parsing to AlignXY

Federico Mena Quintero (112):
      gitlab#214 - Pass cargo flags to "cargo test"
      Merge branch 'librsvg-2.42' into 'librsvg-2.42'
      Depend on float-cmp so we can get traits for approximate comparisons for floats
      New trait FixedEqCairo with a fixed_eq_cairo() method
      New trait ApproxEqCairo
      path_builder.rs: Use approx_eq_cairo() instead of direct float comparisons
      pattern.rs: Tighten division-by-zero guards; use approx_eq_cairo()
      util.rs: Make DBL_EPSILON private; we'll remove it soon
      RsvgBbox: use approx_eq_cairo() instead of double_equals()
      marker.rs: Use approx_eq_cairo() and float_cmp::ApproxEq instead of double_equals()
      structure.rs: Use approx_eq_cairo() instead of double_equals()
      viewport.rs: Use approx_eq_cairo() instead of double_equals()
      util.rs: Remove DBL_EPSILON and double_equals().  Yay!
      Use ApproxEq again in ApproxEqCairo.  This lets us compare big numbers, too.
      CONTRIBUTING.md: Link to ARCHITECTURE.md
      ARCHITECTURE.md: Document how to compare floating-point numbers
      CI: Do all the distros at the same time
      Remove unexported/unused rsvg_cairo_to_pixbuf()
      Aaaaargh, remove parse_transform.lalrpop - it's been unused for ages
      gitlab#227 - Catch negative values in stroke-dasharray
      gradient.rs: Release acquired nodes if they are not of the type we expect
      NodeUse: release the acquired node as soon as possible; to refactor later
      AcquiredNode: new wrapper over acquire_node()/release_node()
      gradient.rs: Use AcquiredNode
      marker.rs: Don't pass an extra c_node; we can get it from the node
      marker.rs: use AcquiredNode
      paint_server.rs: Use AcquiredNode
      structure.rs: Use AcquiredNode
      pattern.rs: Use AcquiredNode
      drawing_ctx.rs: Removed unused acquire_node()/acquire_node_of_type()/release_node()
      pattern.rs: Remove the FallbackSource stack
      pattern.rs: Handle patterns with no children in a cleaner way
      Prettify the rather horrible while() loop in resolve_pattern()
      gradient.rs: Remove FallbackSource; use acquired nodes instead
      gradient.rs: Refactor the resolution loop similarly to pattern.rs
      AspectRatio.is_slice: new method, so image.rs can avoid peeking into the struct's innards
      AspectRatio: make everything but the toplevel struct private
      aspect_ratio.rs: Return AttributeError from the helper parsers
      aspect_ratio.rs: Simplify parse_align()
      aspect_ratio.rs: Inline the default of Align into AspectRatio::default
      Appease cargo fmt
      rsvg_cairo_render_set_affine(): Share this function between drawing and clipping
      rsvg_cairo_render_path_builder(): Set the fill rule in the same place as the clipping code
      rsvg_cairo_render_path_builder(): Move the functions that frob the cr
      Set the fill_rule as late as possible
      Rename rsvg_render_path_builder() and rsvg_render_surface()
      Make the clipping and rendering code use a single rsvg_draw_path_builder()
      rsvg_cairo_render_set_affine_on_cr(): Renamed; have callers pass the cr they wish to modify
      Make set_affine_on_cr() a vfunc on RsvgRender
      drawing_ctx::set_affine_on_cr(): Bind to Rust
      state::get_clip_rule() / state::get_fill_rule() - bind to Rust
      RsvgPathBuilder::to_cairo() - make public
      Factor out function to compute bbox contributions from a path
      rsvg_drawing_ctx_insert_bbox(): Turn this into a vmethod to enable Rustification
      state::get_stroke_width() - Bind to Rust
      drawing_ctx::insert_bbox() - bind to Rust
      Bind to Rust: stroke_opacity, miter_limit, line_cap, line_join
      StrokeDasharray.set_on_cairo(): New function; ported from the C code
      fix: get_shape_rendering_type
      Set the stroke_dasharray on the cairo::Context in the Rust code
      wip: start draw.rs
      Move all the method-like RsvgState functions from drawing_ctx.rs to state.rs
      state::get_stroke_dasharray() / get_dash_offset(): Bind to Rust
      Move rsvg_setup_cr_for_stroke() to Rust
      state::get_affine() - Bind to Rust
      RsvgBbox: new methods new(), insert(), clip()
      RsvgBbox.set_rect() - new method
      state::get_stroke() - Bind to Rust
      rsvg_compute_bbox_from_stroke_and_fill(): Move to Rust
      state::get_fill() / get_fill_opacity() - Bind to Rust
      rsvg_set_source_rsvg_paint_server(): Rename in the Rust code; this will go away soon
      rsvg_draw_path_builder(): Finally move to Rust.  Yay!
      cargo fmt
      Start an rsvg_draw_pango_layout() with a clipping argument
      rsvg_draw_pango_layout(): Fetch the cr from the RsvgDrawingContext, not from the Render
      rsvg_draw_pango_layout(): Only insert the bbox once
      compute_text_bbox(): Move this chunk to its own function
      rsvg_draw_pango_layout(): Always set up the stroke parameters
      rsvg_draw_pango_layout(): Do rotation outside the stroke/fill specifics
      rsvg_draw_pango_layout(): Factor out the save/move/rotate/restore step
      rsvg_draw_pango_layout(): Collapse the if's
      rsvg_draw_pango_layout(): Generalize the drawing and clipping processes
      rsvg_cairo_clip_render_pango_layout(): Just use rsvg_draw_pango_layout() in clipping mode
      state::get_text_rendering_type() - Bind to Rust
      text::gravity_is_vertical() - Make public
      Cargo.toml: Bring in the pangocairo crate
      Clean up the imports a bit
      rsvg_draw_pango_layout(): Move to Rust.  Yay!
      Bump version to 2.42.4
      Update NEWS
      Remove librsvg-2.42 temporarily so we can cherry-pick in peace
      Run the stage_2 CI for the librsvg-2.42 branch.
      CI: add a distcheck stage that runs "make distcheck" to build a tarball
      CI: run the stage_2 in the librsvg-2.42 branch everywhere
      Ahem, run autogen.sh before "make distcheck"
      Run distcheck first, to test this
      Install cargo-vendor
      Try not to refresh the gdk-pixbuf loader database
      Add openssl-devel to build cargo-vendor
      Install libssh2-devel to build cargo-vendor
      Install libgit2-devel to build cargo-vendor
      Install cmake to build cargo-vendor
      Install xz so "make distcheck" can run tar
      Add missing Rust files to Makefile.am
      CI: Go back to running distcheck after lint
      CI: use a DESTDIR that can be accessed
      CONTRIBUTING.md: Document the CI infrastructure a bit and cargo fmt
      ARCHITECTURE.md: Start describing our single-pass CSS cascade / rendering process
      ARCHITECTURE.md: Finish documenting the CSS cascade process
      RsvgHandle: Document the preferred way to load SVGs from memory
      Update NEWS
      Add missing source file to Makefile.am

Ivan Molodetskikh (11):
      node.rs: Add an iterator over Node's children
      Replace uses of node.foreach_child() with iteration
      node.rs: Fix line being too long
      node.rs: Impl DoubleEndedIterator for Children
      node.rs: Add a test for Children
      node.rs: Add C API for node.children() and tests
      rsvg-private.h: Declare node children iter functions
      rsvg-base.c: Replace rsvg_node_foreach_child() with iterators
      rsvg-text.c: Replace rsvg_node_foreach_child() with iterators
      rsvg-filter.c: Replace rsvg_node_foreach_child() with iterators
      Remove Node::foreach_child()

Jordan Petridis (21):
      aspect_ratio: Remove unnecessary enum.
      aspect_ratio: Fix failling test.
      gradient.rs: Refactor a for-loop to iterator combinators chain.
      Bump the minimum rustc version to 1.21
      Cargo fmt
      aspect_ratio: Remove AlignXY struct.
      aspect_ratio: Move impl Defualts under the struct declarations.
      aspect_ratio: make tests more compact.
      aspect_ratio: Use seperate types for Aling X and Align Y.
      gitlabci: switch clippy image to a prebuilt one.
      gitlabci: remove dead codde/template.
      gitlabci: fix rawhide typo.
      gitlabci: Limit cross-distos tests to only the GNOME/librsvg repo.
      gitlabci: Document the different stage setup.
      gitlabci: demote fedora_release to stgage 3.
      gitlabci: Add mutliple rustc builds.
      gitlabci: Add ubuntu builds.
      Update COMPILING.md. Fixes #213.
      gitlabci: Add test for rustc v1.25
      gitlabci: Remove most amd64 release builds.
      cond.rs: Use AsciiExt to maintain backwards compatibility.

Paolo Borelli (5):
      Simplify code in rsvg_cond_parse_system_language
      Use g_get_language_names in rsvg_cond_parse_system_language
      Compare with all the system languages
      Add reftest for system language attribute
      Implement svg switch conditions in rust


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]