[librsvg] Created tag 2.43.1



The signed tag '2.43.1' was created.

Tagger: Federico Mena Quintero <federico gnome org>
Date: 1529697727 -0500

    Tag for 2.43.1

Changes since the last tag '2.43.0':

Federico Mena Quintero (92):
      Post-release version bump to 2.43.1
      Require Rust 1.24 or later, for RefCell::replace()
      rustfmt
      CoordUnits: use a cssparser
      AspectRatio: don't inline the creation of the Parser
      MarkerUnits: use a cssparser
      color.rs: Don't inline the creation of a cssparser
      transform.rs: Use a cssparser from the toplevel impl Parse
      gradient.rs: Use a cssparser
      parsers::number_list() - Take a Parser instead of a &str
      make_property!() - Use a cssparser
      filters/composite.rs: Use a cssparser
      parsers::angle_degrees() - Take a cssparser, not a &str
      marker.rs: parse MarkerOrient completely with cssparser; don't parse bits of the string by hand
      filters::Input::parse() - implement as a standalone method, not a trait impl
      BaselineShift: parse with cssparser
      TextDecoration: parse using cssparser
      parse_dash_array(): Use cssparser
      parse_dash_array(): Take a cssparser, not a &str
      Test the full parser of Dasharray, not just the inner parser
      cond.rs: Expose from_attribute() creators, not Parse implementations
      Trait method Parse::parse() takes a cssparser now, not a &str
      Merge branch 'YaLTeR/librsvg-filters-to-rust-4'
      Update NEWS
      tests/Makefile.am: Also distribute svg1.1/images/*
      Merge branch 'draw-ctx-rs' into 'master'
      rsvg_drawing_ctx_pop_bounding_box(): Don't leak the old bbox
      get_acquired_node_of_type() - take an Option<&str> to simplify some callers
      pattern.rs: Let our call pattern_node.draw_children() push the layer; don't do it ourselves
      clip_path.rs: Let our call do draw_children push a layer - it will be a no-op because we are clipping
      marker.rs: Let our call to node.draw_children() push a layer itself
      marker.rs: Don't use a secondary cr; the layer is not pushed here yet
      Remove unused prototype
      draw_node_from_stack(): Remove the with_layer argument; it was true in all callers.
      NodeUse: draw_in_viewport() already pushes a layer; no need to push another one
      Merge branch 'drawing-ctx' into 'master'
      Remove the with_layer argument throughout
      draw_children(): Remove the node argument; it's unused now
      drawing_ctx::with_discrete_layer() - New function, will replace push/pop
      shapes.rs: Use with_discrete_layer()
      structure.rs: Use with_discrete_layer()
      marker.rs: Use with_discrete_layer()
      text.rs: Use with_discrete_layer() - now it needs an FnMut
      link.rs: Use with_discrete_layer()
      mask.rs: Use with_discrete_layer()
      with_discrete_layer(): take a &mut FnMut
      viewport.rs: Simplify setting the clip rectangle for ClipToViewport
      viewport.rs: Inline everything into draw_in_viewport(); remove the tests (!)
      draw_in_viewport(): Take a draw_fn: &mut FnMut, similar to with_discrete_layer()
      viewport.rs: use with_discrete_layer()
      pattern.rs: Use with_discrete_layer()
      push/pop_discrete_layer(): Removed - inline them in with_discrete_layer()
      pop_render_stack(): Get the child_cr closer to where it is used
      push/pop_render_stack(): Removed; inlined them in with_discrete_layer()
      with_discrete_layer(): Don't have two huge if's, just a single one
      with_discrete_layer(): Reduce the number of times we re-get the original cr
      with_discrete_layer(): Don't bind the same variables twice
      with_discrete_layer(): Rename clip_uri variable
      with_discrete_layer(): Don't acquire the clip_node more than once
      with_discrete_layer(): Refactor obtaining the clip node and clip units
      with_discrete_layer(): Factor out the needs_temporary_surface computation
      with_discrete_layer(): Better identify the intermediate surface and its cr
      with_discrete_layer(): Replace a chain of "else" with .or()
      with_discrete_layer(): We know that we can go back to the original_cr; don't re-fetch it
      with_discrete_layer(): No need to restore the original_cr's matrix
      IRI::get() - new method
      with_discrete_layer(): Use IRI::get() on the IRI fields for less verbosity
      Update NEWS
      (#259): Make test fonts work for installed tests
      Update NEWS
      (#292): Don't panic if we try to clip with an empty bounding box
      CONTRIBUTING.md: Note on formatting commit messages
      Clone the draw_ctx's bbox so the ctx doesn't get borrowed
      Compute effects region in a way to not cause a double mutable borrow
      Store RsvgNode in draw_ctx.acquired_nodes, not pointers to RsvgNode
      Use a RefCell for the vector of acquired nodes
      Clone a bbox to avoid causing a borrow
      DrawCtx is always mutable in the filter context
      DrawingCtx.get_cr_stack() doesn't need a mutable ctx
      Don't keep a &DrawingCtx in FilterContext; pass it around to filter render functions
      link.rs: Remove the with_tag() convenience function; use the primitives
      add_node_and_ancestors_to_stack(): Fix mutability
      impl Drop for AcquiredNode: Fix mutability
      draw_node_from_stack(): Don't use an anonymous function helper
      Merge branch 'master' into drawing-ctx-wip
      rsvg_drawing_ctx_new() - fix the type of the cr argument
      drawing_ctx.rs: Restore the original behavior of the cr_stack
      is_cairo_context_nested(): Oops, the condition was backwards.
      draw_node_from_stack(): Ahem, make this work in the original way.
      sax_processing_instruction_cb(): Don't leak the pbag iterator
      rsvg-test.c: Don't leak the cwd
      Update NEWS

Ivan Molodetskikh (46):
      WIP: partially port Image to Rust
      Add drawing_ctx::draw_node_on_surface()
      Make FilterContext::drawing_context() return *mut
      Port (more or less) the rest of feImage
      Don't render filter if bbox rect is empty
      Big filter bounds computation refactor
      Fix missing linearization in composite arithmetic
      Add notice about attributes into feOffset
      Add a missing dot
      Compute the filter effects region only once
      Use a better name for test-bbox
      Change feOffset attributes to be numbers
      Add comments into feMerge
      Use correct CSS values in compute_effects_region()
      Use correct CSS values in with_primitive_units()
      Rename new tests
      Fix bbox computation in draw_surface()
      Revert composite linearization fix
      Remove leftover debug comment
      Don't render filters if they are in error
      Refactor parse to parse{,_and_validate}
      Validate units in <filter> attributes
      Validate units in filter primitive attributes
      Replace normalize_ignoring_units with get_unitless
      Ensure width and height are >=0 in filters
      Implement FillPaint and StrokePaint
      Make {get,set}_pixel() conformant to cairo specs
      Port feFlood
      Remove leftover rsvg_filter_render definition
      ImageSurfaceDataShared::new => new_unchecked
      Return cairo::Status error from ImgSurfDataShared
      Refactor srgb::
      Remake feOffset in terms of cairo
      Fix extends in draw_surface()
      Port feBlend to Rust
      Derive Clone on node::Children
      Add unbounded list size to parsers::number_list()
      Port feComponentTransfer to Rust
      Remove two obsolete functions
      Don't truncate offsets in feOffset
      Change ImageSurfaceDataShared to a safe version
      Add a comment on channelmap
      Enable LTO in benchmarks
      Remove an extra inline(always)
      Implement color-interpolation-filters
      Remove {un,}linearization boilerplate

Jordan Petridis (1):
      CI: remove some rustc jobs.

Paolo Borelli (15):
      Fix typo (overriden -> overridden)
      node: move cond to the node itself
      state: remove unused method
      node: simplify code that deals with state
      drawing_ctx: refactor functions to manipulate list of acquired node
      drawing_ctx: move get/remove_acquired_node to rust
      load: fix compiler warning
      handle: factor out function
      drawing_ctx: move add_node_and_ancestors to rust
      bbox: add with_extents method
      drawing_ctx: add ink_rect getter
      image: remove unneeded cairo_save/restore
      wip: try to port drawing_ctx to rust
      bbox: remove the C export
      drawing_ctx: pass the context to the draw callback


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]