[librsvg] Created tag 2.45.2



The signed tag '2.45.2' was created.

Tagger: Federico Mena Quintero <federico gnome org>
Date: 1546027651 -0600

    Tag for version 2.45.2

Changes since the last tag '2.45.1':

Andre Klapper (1):
      Comment invalid <category> in DOAP file to pass git pre-receive hook

Federico Mena Quintero (79):
      Check that RsvgHandle finished loading correctly before rendering-stage functions
      Check that RsvgHandle is not yet started loading for some API entry points
      convert_no_alpha() - Removed; we only convert CAIRO_FORMAT_ARGB32 surfaces anyway
      NodeChars.measure(): Oops, actually add the width to the running length
      NodeChars.measure(): Return a value; don't mutate an argument
      text.rs: Don't pass a mutable length to all measure() functions; make them return values instead
      text.rs: Don't mutate the arguments of the render() functions; return values instead
      text.rs: Don't obviate TextAnchor::End with "_"; spell it out explicitly
      rsvg-view: Allow quitting the program with Ctrl-Q or Ctrl-W
      Split into Span and MeasuredSpan
      Factor out NodeChars.make_span() from duplicated code
      PositionedSpan: move the span positioning logic to here
      PositionedSpan: store both the nominal position and the rendered position
      Chunk: remove the final positions, leave only the specified ones
      text.rs: Start logic to turn a NodeText and its children to Chunks
      text.rs: new MeasuredChunk, analogous to MeasuredSpan
      PositionedChunk: implement the layout logic
      text.rs: Reorder the impls a bit
      MeasuredChunk: compute the advance of all the MeasuredSpans
      WritingMode.is_vertical(): new convenience function
      PositionedChunk: Adjust the position based on the text_anchor
      text.rs: Oops, use the child when iterating, not the parent node
      NodeText.draw(): implement in terms of chunks and spans
      children_to_chunks(): Do not create chunks here; assume the caller already did it
      NodeText::draw(): Use the current's chunk position if available
      NodeText::draw() - Oops, use a layer so the text node gets opacity/filters/etc.
      text.rs: Remove the old code
      rustfmt
      NodeTSpan: make the dx/dy fields Option<Length>
      text.rs: Implement dx/dy for NodeText and NodeTSpan
      Annotate each Span with its nesting depth within the topmost <text> element
      Remove the C-callable functions
      Implement tref
      NodeChars.to_chunks(): Extract this common function
      Add text-tref-01-b.svg to the tests
      Add text-tref-02-b.svg; make all nodes accept NodeChars children
      Add text-tref-03-b.svg
      Merge branch 'fix-merge-crashs' into 'master'
      (#393): Don't drop nodes recursively to avoid stack overflow
      Merge branch 'pborelli/librsvg-marker'
      rsvg_handle_new_from_data(): Implement with a GMemoryInputStream, not the write/close API
      LoadOptions: new struct to represent RsvgHandleFlags in the Rust code
      LoadState: move the RsvgHandlePrivate.hstate field to Rust
      rsvg-private.h: Move the structs/enums to rsvg-handle.c
      rsvg_handle_read_stream_sync(): Port the implementation to Rust
      rsvg_handle_write()/close(): Port entirely to Rust.  Yay!
      Remove a bunch of unused functions
      Merge branch 'pborelli/librsvg-property_bag'
      rustfmt
      Factor out common calls in rsvg_handle_create_drawing_ctx_for_node()
      rsvg_handle_create_drawing_ctx_for_node(): Port to Rust
      rsvg_handle_get_node_geometry(): Port to Rust
      Handle::defs_lookup() - Move the implementation from rsvg_handle_defs_lookup()
      rsvg_handle_get_geometry_sub(): Untangle this function a bit
      rsvg_handle_rust_get_geometry_sub(): Port to Rust.
      NodeSvg::get_size(): Take a Dpi, not separate dpi_x/dpi_y values
      Fix two leaks out of callers of rsvg_defs_lookup()
      rsvg_handle_rust_has_sub(): Port to Rust.
      rsvg_handle_render_cairo_sub(): Port to Rust
      Remove a bunch of unused functions
      Add deprecation attribute to rsvg_cleanup
      Remove all calls to rsvg_cleanup() since it's a no-op now
      rsvg-handle.c: Don't call xmlInitParser()
      Add some more no-op functions to the API tests
      Merge branch 'pborelli/librsvg-xml'
      Make a couple of unsafe calls nicer
      Use unwrap_or_default(); RsvgRectangle implements Default.
      Move failing test to ignore-filters-displace-01-f.svg
      text.rs: Remove debugging printlns
      Merge branch 'text-refactor'
      Handle::get_pixbuf_sub(): Use the same code as elsewhere to get the dimensions
      Handle::get_geometry_sub() / get_node_geometry(): Return a RenderingError, not ()
      Handle::get_dimensions(): Extract this bit of common code from other places
      Bump version to 2.45.2
      Update NEWS
      configure.ac: Remove rsvg_extra_version - we never used it
      Separate out the libtool version components from the package version
      rsvg_lt_version_info: set this directly, not with mysterious computations
      (#390): Increment library version number

Ivan Molodetskikh (2):
      Add a test for a crash in filter color conversion
      Make sure to convert to sRGB in filter get_input

Jordan Petridis (4):
      Export rsvg_handle_read_stream_sync
      Merge branch 'alatiera/pub-export' into 'master'
      rsvg_internals: remove unused extern crate declaration
      Merge branch 'alatiera/unused' into 'master'

Kornel (1):
      Deprecation notice

Kornel LesiƄski (1):
      Remove references to libxml2

Paolo Borelli (13):
      marker: move bisection tests to angle.rs
      marker: add impl Segment
      marker: add a Segments struct and move code to its impl
      property_bag: do not store the key string
      property_bag: remove ffi leftovers
      xml: do not store current context separately
      xml: do not store element name in the context
      xml: remove the Context struct, we just need the enum
      xml: remove impl Context
      tests: move compare_surfaces to test-utils
      tests: test pixbuf contents
      handle: port get_pixbuf_sub to rust
      rect: move IRect to rect.rs


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]