[librsvg] Created tag 2.45.1
- From: Federico Mena Quintero <federico src gnome org>
- To: commits-list gnome org
- Cc:
- Subject: [librsvg] Created tag 2.45.1
- Date: Tue, 11 Dec 2018 01:01:09 +0000 (UTC)
The signed tag '2.45.1' was created.
Tagger: Federico Mena Quintero <federico gnome org>
Date: 1544490000 -0600
Tag for 2.45.1
Changes since the last tag '2.45.0':
Daniel GarcĂa Moreno (2):
Add localization support with gettext
CI: Add gettext package for distro testing
Emmanuele Bassi (1):
Pass required out parameter
Federico Mena Quintero (172):
rsvg-pixbuf.c: Don't acquire data by hand; just let the stream reader do it
Merge branch 'cleanups' into 'master'
Merge branch 'paint-server' into 'master'
Cargo.toml: sort the dependencies
Port data: url parsing to Rust
Merge branch 'data-uri' into 'master'
rsvg_decode_data_uri(): Restore ability to pass a null out_mime_type
rsvg_handle_new_from_file(): implement in terms of rsvg_handle_new_from_gfile_sync()
(#377): xml.rs: ignore character data outside the toplevel XML element
xml.rs: Preserve the context without mem::replace()
rsvg_load_handle_xml_xinclude(): use the error code from xmlParseDocument
Defs: decouple from RsvgHandle
Use g_clear_pointer()
rsvg_load_steal_result(): Renamed from rsvg_handle_steal_tree()
rsvg_xml_state_steal_result(): Renamed from rsvg_xml_state_steal_tree()
Don't create the RsvgDefs in the RsvgHandle; do it in the XmlState
Don't pass a RsvgHandle where we just need a CssStyles
(#377): data: URLs with a fragment identifier should return an error
Merge branch 'xinclude-error-handling'
sax_error_cb(): Construct a string with the error message
Notify the XmlState when libxml2 finds a parsing error
Distinguish between fatal errors and resource errors in xinclude
Move storage of libxml2 entities to Rust
rsvg-io.c: Use rsvg_acquire_gvfs_stream() for all cases
rsvg-load.c: Parse CSS data in XML processing instructions in Rust
css_import_style(): Use handle::load_css() instead of duplicating that code
rsvg_get_input_stream_for_loading(): Extract into its own separate function
error.rs: Add an empty RsvgError and impl glib::error:ErrorDomain for it
rsvg_get_input_stream_for_loading(): Port to Rust
create_node_and_register_id(): Renamed from rsvg_load_new_node()
create_node.rs: Renamed from load.rs
Audit for "href" vs. "uri" in function prototypes
rsvg_acquire_gvfs_stream(): Don't resolve relative files here; we get passed a full URI
rsvg_acquire_gvfs_data: Don't resolve relative files here; we get passed a full URI
Remove superfluous use of g_propagate_error()
Remove superfluous checks
Merge branch 'xinclude-error-handling'
rsvg_acquire_gvfs_stream(): Remove the out_mime_type argument after all
rsvg_io_acquire_stream(): Port to Rust
image_surface_new_from_href(): Don't get the mime_type from the pixbuf loader
handle::acquire_stream(): Bind to Rust
rsvg_io_acquire_data(): Port to Rust.
Merge branch 'xinclude-error-handling'
Merge branch 'jsparber/librsvg-cairopango'
Import the url crate
Start draining RsvgHandlePrivate into a Rust struct
Handle: move the base_url here
rsvg_handle_load_extern(): Use a stream; don't slurp the whole file first
Defs::get_extern_handle() - return a Result, not a raw pointer
handle::load_extern() - return a Result
allowed_url.rs: New file; logic to decide whether to allow loading files
rsvg_handle_acquire_data(): Move to Rust
rsvg_handle_acquire_stream(): Move to Rust
Defs::get_extern_handle(): use AllowedUrl instead of rsvg_handle_resolve_uri()
Makefile.am: Oops, add allowed_url.rs to the list of sources
rustfmt
css: The DocHandlerData is our closure data; it should be mutable
css::parse_into_css_styles(): Take a &mut CssStyles instead of extracting it from the handle
handle::load_css() - Take a &mut CssStyles, don't extract it from the handle
rsvg_handle_load_css(): Take in the css_styles to modify
XmlState: create the CssStyles here, not in the caller
Remove unused prototype
Merge branch 'coypoop/librsvg-test'
(#385): Don't crash if there is no rsvg_handle_write() before close()
Don't call the size_func in _get_geometry_sub()
GI annotations for the arguments of rsvg_handle_get_geometry_sub()
Use the "Since:" annotation in the docs for rsvg_handle_get_geometry_sub
From the Rust code, return the lack of bounding boxes as 0-sized Cairo rectangles
Reference: store owned Strings internally, not string slices
Reference::parse(): Return a ReferenceError, not a ()
Add more error cases to ReferenceError
Document Reference::parse()
Reference::with_fragment(), without_fragment() - New convenience methods
rsvg_decode_data_uri(): Remove unused function
Defs::lookup() - Take a Reference, not a plain href
Rename Reference to Href
filters/image.rs: Tweak how we match the Href
filters/image.rs: Pass the Href to the worker functions, not a string
impl Error for AllowedUrlError
handle::acquire_data() - Take an AllowedUrl, not a string href
handle::acquire_stream(): Take an AllowedUrl, not a string href
rsvg_handle_acquire_data() / acquire_stream(): Return more descriptive errors
impl std::Error for LoadingError
handle::acquire_data(): Return a LoadingError
handle::acquire_stream(): Return a LoadingError
handle::load_image_to_surface() - Renamed from image_surface_new_from_href()
load_image_to_surface(): take an AllowedUrl, not a string
Href::WithFragment - consolidate the FragmentId and UriWithFragmentId variants into one
Extract a Fragment structure, and make the the contents of Href::WithFragment(f)
Defs::lookup() - Take a Fragment, not just any Href that may not have one
Mark rsvg_defs_lookup() as G_GNUC_INTERNAL
rsvg_g_warning(): Mechanism to call g_warning() from Rust
rsvg_defs_lookup(): Do not allow looking up extern references
Use helper functions get_acquired_href*() everywhere
image.rs: use Href::without_fragment()
filters/image.rs: Use the fragment directly in the case where it is needed
Prettify an array comparison
filters/image.rs: Parse the href at loading time, in set_atts()
Document the purpose of the IRI type
IRI: store a Fragment, not just a plain String
Fragment::parse(): New convenience function
AttributeResultExt: helper trait to convert Result<O, E> to Result<O, NodeError>
Use AttributeResultExt in pattern.rs
gradient.rs: Use Fragment instead of String for the fallback name
NodeUse: use Fragment instead of String for the link
PaintServer: use a Fragment for the iri case, not a String
NodeTRef: use a Fragment for the link, not a String
DrawingCtx: remove helper methods get_acquired_href*()
Merge branch 'i18n' into 'master'
Merge branch 'jsparber/librsvg-geometry'
rsvg_drawing_ctx_new(): Don't pass the defs; the DrawingCtx can get them from the handle
Defs: store the externs as HashMap<AllowedUrl, handle> instead of a String key
handle::load_extern(): Port to Rust
Consolidate (tree, defs, css_styles) into an Svg type, invisible to C
rsvg-private.h: Clean up unused prototypes
Merge branch 'pborelli/librsvg-node'
lib.rs: Export some missing functions, oops
tests/dimensions.c: Use our own macros instead of g_assert_cmpfloat_with_epsilon()
Only handle internal general entities from libxml2
Update NEWS
rsvg-handle.c: Don't use deprecated functions to register private instance data
xml2.rs: Minimal binding to the parts of libxml2 we need
Move XML processing instruction code to Rust
Merge branch 'pborelli/librsvg-tree_utils'
rsvg-load.c: Strip the namespaces in the Rust code
rsvg_xml_state_start_element(): Create the property bag here, not in the caller
property_bag.rs: Remove the C API. Yay!
xml.rs: Don't pass the handle around; we already have it in XmlState
create_xml_{push,stream}_parser() - Take in the unlimited_size parameter
rsvg-load.c: Make all the SAX callbacks take an RsvgXmlState, not an RsvgLoad
Rename create_xml_*_parser() to rsvg_create_xml_*_parser()
xml2_load.rs: Move all the libxml2 callbacks to here; port them to Rust.
rsvg_load_handle_xml_xinclude(): Use the handle's cancellable
rsvg_load_read_stream_sync(): No need to set the load->xml.ctxt; use a local variable
RsvgLoad: don't store a GCancellable
parse_xml_from_stream(): Extract this common function from two duplicated places
RsvgLoad: Don't store an error field; it's all in local variables now
rsvg_xml_state_parse_from_stream(): Rename and port to Rust
Oops, export rsvg_set_error_from_xml
Don't extract a GCancellable from the RsvgHandle
Merge branch 'ub-enums' into 'master'
Don't use zero-sized structs for FFI pointers where the structs originate in Rust
xml2_load.rs: Clarify which errors are GIO errors vs. XML parsing errors
xml2_error_to_string(): Extract this function from rsvg_set_error_from_xml()
xml_state_parse_from_stream(): Extract; also introduce ParseFromStreamError
create_xml_stream_parser(): Don't return a glib::Error; use a custom error code
Xml2Parser: Move the parse-from-stream machinery to a struct
Don't pass a temporary GError location to Xml2Parser::from_stream()
Xml2Parser: Use an Rc instead of box-a-pointer shenanigans
XmlState::acquire_xml() - Port rsvg_load_handle_xml_xinclude() to Rust into here
rsvg_load_read_stream_sync(): Untangle a bit so we can port to Rust
rsvg_load_read_stream_sync(): Port most of this to Rust
rsvg_load_read_stream_sync(): Don't use an extra GError
rsvg-attributes.h: Removed; it is no longer used. Yay!
Merge branch 'dpi' into 'master'
Merge branch 'pborelli/librsvg-angle'
Angle::from_degrees(): Use f64::to_radians()
rsvg-load.c: Extract the unlimited_size flag from the handle
rsvg-load.c: Slurp the entire file for the write/close API, not just compressed ones
rsvg-load.c: Move the rust_state up to the main struct
rsvg-load.c: Accumulate to a GByteArray, not a GMemoryInputStream
Move the loading validation code from rsvg-load.c to rsvg-handle.c
rsvg_load_read_stream_sync(): Removed; inlined in its only two callers
rsvg_load_new(): Take the unlimited_size argument again
RsvgLoad: rename rust_state field to xml
rsvg_load_new(): Take an RsvgXmlState instead of an RsvgHandle
load.rs: Port all of RsvgLoad to Rust. Yay!
rsvg.h: Deprecate rsvg_handle_write() / rsvg_handle_close()
Add deprecation annotations to rsvg_handle_get_{position,dimensions}_sub
Merge branch 'pborelli/librsvg-angle'
cargo fmt
Update NEWS for 2.45.1
Jordan Petridis (12):
Cargo: update deps
Upgrade gtk-rs crates
cargo: upgrade owning_ref
Merge branch 'alatiera/update-deps' into 'master'
Merge branch 'no-mime-type' into 'master'
CI: Disable the opensuse job
CI: merge stage 2 into stage 1
CI: remove stage_1 tag and shuffle some jobs around
(#383): bring glib and gio into the namespace.
Merge branch 'alatiera/include-things' into 'master'
Revert "CI: Add gettext package for distro testing"
(391): Avoid undefined behavior casting opaque pointers to empty enums
Julian Sparber (10):
use cairopango instead of the sys bindings
fix formating issues after rustfmt update
handle: add new API to get node geometry
handle: enable doc gen for get_geometry_sub()
readd wilber test
add test for rsvg_handle_get_geometry_sub() and disable wilber
use get_geometry_sub() internaly for get_position_sub() and get_dimension_sub()
deprecate get_postion_sub() and get_dimension_sub()
use gdouble in dimension test
use RsvgRectangle as out arguments for get_geometry_sub()
Maya Rashish (1):
Avoid unportable test(1) operator
Paolo Borelli (18):
mask: use cairo-rs mask_surface method
pattern: shorten code
paint_server: introduce PaintSource trait
node: remove marker types
node: introduce different types for feFunc variants
node: introduce different types for light sources
node: clarify hacks for partially supported elements
node: add element_name method for the NodeType enum
node: do not store the element name as a string
Split off a generic refcounted tree module
handle: rework C dpi handling
tests: improve dpi api unit test
handle: move dpi to rust
drawing_ctx: use the new Dpi struct
marker: simplify normalize_angle
marker: factor out an Angle struct
marker: impl Parse for Angle
Move Angle to its own file
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]