[gnome-boxes/wip/rishi/rhel: 3/14] wizard-source: Use 'requires' instead of 'assert'
- From: Debarshi Ray <debarshir src gnome org>
- To: commits-list gnome org
- Cc:
- Subject: [gnome-boxes/wip/rishi/rhel: 3/14] wizard-source: Use 'requires' instead of 'assert'
- Date: Thu, 7 Sep 2017 11:58:58 +0000 (UTC)
commit c4f02a03d984fb73695d80845b535a9f84dceebb
Author: Debarshi Ray <debarshir gnome org>
Date: Wed Aug 23 18:44:26 2017 +0200
wizard-source: Use 'requires' instead of 'assert'
It seems nicer to use 'requires' (and 'ensures') for expressing post
and pre-conditions. It is more readable and doesn't crash hard when an
invariant is violated.
https://bugzilla.gnome.org/show_bug.cgi?id=786689
src/wizard-source.vala | 4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
---
diff --git a/src/wizard-source.vala b/src/wizard-source.vala
index 70936a4..228720d 100644
--- a/src/wizard-source.vala
+++ b/src/wizard-source.vala
@@ -177,8 +177,8 @@ private class Boxes.WizardSource: Gtk.Stack {
transition_type = Gtk.StackTransitionType.SLIDE_LEFT_RIGHT; // FIXME: Why this won't work from .ui
file?
}
- public void setup_ui (AppWindow window) {
- assert (window != null);
+ public void setup_ui (AppWindow window)
+ requires (window != null) {
this.window = window;
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]