[gnome-shell/wip/abono/maximize: 1/5] windowManager: Rename variable



commit a0c4b28a5dbb3fd5e240772c4591d3a7aacae5b1
Author: Alessandro Bono <abono gnome org>
Date:   Sat May 20 17:06:28 2017 +0200

    windowManager: Rename variable
    
    Since there is already targetRect that represents where
    the window is going to move. Rename oldRect to sourceRect
    to represent from where the window is moving
    
    https://bugzilla.gnome.org/show_bug.cgi?id=766685

 js/ui/windowManager.js |    8 ++++----
 1 files changed, 4 insertions(+), 4 deletions(-)
---
diff --git a/js/ui/windowManager.js b/js/ui/windowManager.js
index 43871fb..b987467 100644
--- a/js/ui/windowManager.js
+++ b/js/ui/windowManager.js
@@ -1366,10 +1366,10 @@ const WindowManager = new Lang.Class({
                          });
 
         let monitor = Main.layoutManager.monitors[actor.meta_window.get_monitor()];
-        let oldRect = actor.__fullscreenInfo.oldRect;
-        if (oldRect) {
-            actor.translation_x = oldRect.x - monitor.x;
-            actor.translation_y = oldRect.y - monitor.y;
+        let sourceRect = actor.__fullscreenInfo.oldRect;
+        if (sourceRect) {
+            actor.translation_x = sourceRect.x - monitor.x;
+            actor.translation_y = sourceRect.y - monitor.y;
         } else {
             actor.translation_x = -(targetRect.x - monitor.x);
             actor.translation_y = -(targetRect.y - monitor.y);


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]