[devhelp] Created tag 3.25.1

The unsigned tag '3.25.1' was created.

Tagger: Sébastien Wilmet <swilmet gnome org>
Date: Sun May 21 11:31:39 2017 +0200

    Release 3.25.1

Changes since the last tag '3.24.0':

Andika Triwidada (1):
      Update Indonesian translation

Balázs Úr (2):
      Update Hungarian translation
      Update Hungarian translation

Kukuh Syafaat (1):
      Update Indonesian translation

Mario Blättermann (1):
      Update German translation

Piotr Drąg (3):
      Update po/Makevars
      Use Unicode in translatable strings
      Update Polish translation

Rico Tzschichholz (1):
      build: Make sure to link LIBM

Sébastien Wilmet (164):
      post release version bump
      flatpak: use git.gnome.org URL
      flatpak: move json manifest to a new flatpak/ directory
      flatpak: add scripts to test the flatpak manifest
      flatpak: remove --disable-man-pages
      build: disable -Werror by default
      flatpak: remove --disable-Werror
      Add myself as maintainer
      Update authors
      Make the doap file valid by adding a description
      doap: https URLs
      Remove TODO
      Update README
      build: use git.mk
      settings: remove search-notebook GSettings (no longer used)
      DhSettings: code cleanup and coding style improvements
      DhSettings: move init after class_init
      DhSettings: use g_signal_connect_object()
      DhSettings: rename function parameter
      DhSettings: rename get() -> get_instance()
      DhSettings: have a real singleton
      DhSettings: free singleton at the end of main()
      DhSettings: rename get_instance() -> get_singleton()
      DhSettings: same schema IDs order as in the *.gschema.xml file
      DhSettings: add missing g_returns to public functions
      Pass NULL to g_signal_new() instead of g_cclosure_marshal_generic
      Do not prefix macro names with underscores
      AssistantView: use more modern GObject style for the Private struct
      build: check for gsettings-desktop-schemas with pkg-config
      DhLink: fix/improve the gtk-doc comments
      DhLink: minor code improvements
      DhLink: small improvements
      DhLink: deprecate dh_link_get_page_name()
      Window: use gtk_show_uri_on_window()
      Book: tidy up a little the header
      Book: small coding style improvements
      Book: fix/improve the gtk-doc comments
      Book: add a return value to unref_node_link() to be a GNodeTraverseFunc
      Book: remove useless instance variable initializations in init()
      Book: move function to avoid prototype
      guint for storing signal IDs
      Always use generic marshaller when creating signals
      Use G_PARAM_STATIC_STRINGS when creating properties
      docs: add the version since the functions are deprecated
      BookManager: improve class_init
      BookManager: avoid prototypes for get/set_property()
      BookManager: move function to avoid prototype
      BookManager: small coding style improvements
      BookManager: improve the gtk-doc comments
      docs: fix/improve gtk-doc devhelp-sections.txt
      BookTree: fix/improve the gtk-doc comments
      dh-error: make it private
      KeywordModel: improve the gtk-doc comments
      Sidebar: tidy up a little the header
      Sidebar: fix/improve the gtk-doc comments
      Sidebar: better create the link-selected signal
      DhSettings: send fonts-changed signal when system fonts change
      KeywordModel: fix gtk-doc comment for filter() function
      Book: remove deprecated functions
      BookManager: remove deprecated function
      DhLanguage: remove deprecated function
      AssistantView: improve a little the gtk-doc comments
      AssistantView: more logical function order
      AssistantView: remove #if GLIB_CHECK_VERSION
      DhSettings: set singleton to NULL in finalize() only if == object
      BookManager: populate it in init()
      BookManager: re-order the functions to avoid prototypes
      BookManager: add get_singleton() and free_singleton()
      BookManager: deprecate new()
      App: do not store the DhBookManager
      AssistantView: remove dh_assistant_view_set_book_manager()
      Preferences: do not store the DhBookManager
      KeywordModel: remove dh_keyword_model_set_words()
      BookTree: remove book-manager property
      BookTree: move code from constructed() to init()
      BookTree: more precise return type for new()
      Sidebar: remove book-manager property
      Sidebar: move code from constructed() to init()
      Window: use dh_book_manager_get_singleton()
      App: remove dh_app_peek_book_manager()
      Call dh_book_manager_free_singleton() at the end of main()
      NEWS: write summary of latest changes
      Assistant: first step to make it private
      Window: first step to make it private
      App: first step to make it private
      App: replace #include "devhelp.h" by more precise #includes
      build: re-organize src/Makefile.am
      Generate enum types for the application
      Compile DhApp, DhAssistant and DhWindow in the app, not the lib
      build: introspection: analyze also built public source files
      docs: do not ignore dh-enum-types.h
      DhLanguage: make it private
      Remove #include "dh-language.h" from devhelp.h
      Rename dh-common.c -> dh-init.c
      Create dh-init.h public header
      Add dh_free_resources() public function
      Make the *_free_singleton() functions private
      docs: add index of new symbols in 3.26
      docs: add "Since: 3.26" to dh_book_manager_get_singleton()
      Always name N_SIGNALS the number of signals in a certain class
      Use directly DhBook type in DhBookManager signals callbacks
      BookTree: better specify columns when calling gtk_tree_store_new()
      BookTree: configure GtkTreeView in init()
      BookTree: add context menu with Collapse All action
      Sidebar: force a new search when calling set_search_string()
      Window: improve code to update back/forward buttons sensitivity
      build: use AX_PKG_CHECK_MODULES
      Bump version
      docs: improve structure
      Rename string "Side pane" to "Side panel"
      Rename string "Side panel" to "Side Panel"
      docs: rename "De-initialization" to "Finalization"
      docs: write class descriptions for "the data" part
      docs: improve docs for dh_book_get_tree() and dh_book_get_keywords()
      parser: set correct DhLinkType for signals
      docs: improve docs of DhLinkType
      docs: write class descriptions for the "Side Panel" part
      docs: write class description for DhAssistantView
      docs: provide FIXXREF_OPTIONS for WebKitGTK+
      init: init i18n in dh_init()
      init: unref singletons only once
      Rename functions *_free_singleton() -> *_unref_singleton()
      docs: document what #include is needed
      build: better compile GResources
      build: AC_SUBST only one variable for the libtool version
      build: do not build dh-resources.h
      Book: cosmetic code changes in dh_book_new()
      Book: improve a little the docs wrt the path
      Book: rename instance variable path -> index_file_path
      parser: rename variables path -> index_file_path
      parser: rename instance variable m_parser -> markup_parser
      parser: some cosmetic code changes
      parser: use GIO to load the index files
      parser: take a GFile parameter
      parser: check dh_parser_read_file() arguments
      parser: make clearer that out parameters are stored in the struct
      parser: follow more closely Linux coding style
      parser: improve coding style of parser_start_node_book()
      parser: improve code of parser_start_node_keyword()
      parser: improve code of parser_start_node_chapter()
      parser: avoid crash if the first element is <chapters> or <functions>
      parser: fix/improve error messages and do not translate them
      parser: take into account also \r in replace_newlines_by_spaces()
      parser: add missing dh_link_ref() when storing link in the GNode
      parser: rename instance variable parent -> parent_node
      parser: add more g_asserts and a g_return
      parser: more logical order in parser_start_node_cb()
      parser: update FIXME comment, it's indeed broken
      parser: add comment about the namespace
      parser: set out parameters only in dh_parser_read_file()
      Create util function to free GNode book tree
      parser: add comment about possible things to do for version 3
      dh-error: spring clean-up
      parser: add FIXME comment related to what gtk-doc generates
      DhLink: improve the docs and parameter names
      DhLink: rename instance variable id -> book_id
      DhLink: rename instance variable base -> base_path
      DhLink: rename instance variable filename -> relative_url
      parser: add one more possible thing to do for version 3
      parser: rename variables keywords -> all_links
      Sidebar: add missing (nullable) annotation
      docs: document API breaks in the reference manual
      NEWS: write summary of latest changes and document API breaks
      Release 3.25.1

Tom Tryfonidis (1):
      Update Greek translation

Yuras Shumovich (1):
      Update Belarusian translation

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]