[gtk+] Created tag 2.24.31



The unsigned tag '2.24.31' was created.

Tagger: Matthias Clasen <mclasen redhat com>
Date: Fri Sep 9 16:05:22 2016 -0400

    2.24.31

Changes since the last tag '2.24.30':

Benjamin Otte (56):
      filechooserentry: Don't use a magic number
      filechooserentry: Use the actual discarding function to discard a folder
      filechooserentry: Reorganize function
      filechooserentry: Fold function into other
      filechooserentry: force_reload is never TRUE
      filechooserentry: Keep finished_loading variable ourselves
      filechooserentry: Make the filesystem a construct-only argument
      filechooserentry: The file system cannot be NULL
      filechooserentry: Fold in start_loading_current_folder()
      filechooserentry: Don't trim away the slash after directories
      filechooserentry: Only append / to directory names once
      filechooserentry: Make appending / to directories simpler
      filechooserentry: Store the liststore as a treemodel
      filechooserentry: Use a GtkFileSystemModel
      filechooserentry: Move _gtk_file_system_parse()
      filechooserentry: Simplify code
      filechooserentry: Remove file_system argument
      filechooserentry: Start autocomplete immediately
      filechooserentry: Don't complain about incomplete hostnames
      filechooserentry: Ensure the base folder is always valid
      filechooserentry: Simplify code
      filechooserentry: Split out function
      filechooserentry: Modify _gtk_file_chooser_entry_get_current_folder()
      filechooserentry: Redo _gtk_file_chooser_entry_get_file_part()
      filechooserentry: Keep an extra column for the full path
      filechooserentry: Simplify match_selected function
      filechooserentry: Set the text column of the entry completion
      filechooserentry: Merge function
      filechooserentry: Use inline completion
      filechooserentry: Get rid of RefreshMode
      filechooserentry: Redo completion popup trigger
      filechooserentry: Remove completion feedback
      filechooserentry: Simplify append_common_prefix()
      filechooserentry: Don't override activate
      filechooserentry: Don't update the folder when completing
      filechooserentry: Add gtk_file_chooser_entry_get_completion_text()
      filechooserentry: Use completion for completion
      filechooserentry: Remove _gtk_file_chooser_entry_set_file_part()
      filechooserentry: Get rid of unused member variable
      filechooserentry: Simplify refresh_current_folder_and_file_part()
      filechooserentry: Set minimum key length to 0
      filechooserentry: Refactor function
      filechooserentry: Simplify code
      filechooserentry: Remove the file column
      filechooserentry: Use a GtkFileFilter for filtering
      filechooserentry: Simplify load completion
      filechooserentry: Remove beep function
      filechooserentry: Don't show files when selecting directory
      filechooserentry: Allow NULL as base folder again
      filechooserentry: Remove unused enum
      filechooserentry: Do inline completion only when opening files
      filechooserentry: Catch tab key earlier
      filesystemmodel: Add a missing check
      filesystemmodel: Add a toggle for whether directories are filtered
      entry: Don't try to handle Tab in entry completions
      entry: Move freeze/thaw into begin/end_change

Chun-wei Fan (2):
      MSVC builds: Look for headers in include/gio-win32-2.0
      MSVC builds: Add experimental introspection support

Dariusz Gadomski (1):
      printing: Properly initialize auth_info in gtkprintbackend.c

Emmanuele Bassi (1):
      Freeze file system model during editing

Federico Mena Quintero (17):
      GtkFileChooserEntry: don't inline-complete if the entry doesn't have the focus
      Sync missing comment
      Make _gtk_entry_completion_compute_prefix() public-internal
      Remove superfluous check in node_set_filtered()
      Make it clear that 'filtered' means 'filtered_out'
      Make computing and setting the visibility/filters atomic operations
      Rename gtk_tree_path_new_from_node() to tree_path_new_from_node()
      Remove argument to _gtk_file_system_model_update_file() that should not be part of the internal API
      Comments on how the filtering and sorting processes work
      Make freeze_updates() and thaw_updates() static functions
      bgo#687196 - Fix model corruption during file removal
      Cherry-pick e709c965a4d9d48c8007905de7e715bc7fef728f - don't leak queried file info
      Ref/sink the GtkFileFilter used for GtkEntryCompletion; it's a GtkObject here
      GtkFileChooserEntry: regenerate the completions if the dir_part changes
      GtkFileChooserEntry: Oops, free the temporary dir_part
      GtkFileChooserEntry: move the cursor after the user chooses a completion from the list
      entrycompletion: Don't reconnect signals all the time

Jeremy Tan (1):
      GDK W32: Fix bounding rect calculation on window creation

Ken VanDine (1):
      Include <package/> tag in generated GIR

Kristian Rietveld (3):
      quartz: handle didMove and didResize in the same way
      quartz: introduce gdk_quartz_window_is_quartz function
      imquartz: fix regression introduced by commit 4ba1fb

Matthias Clasen (15):
      Avoid integer overflow
      filechooser: Fix entry completion
      Avoid a critical in the file chooser
      Formatting fix
      file chooser entry: Special-case ., .. and ~
      Remove debug spew
      Emit row-changed notification
      GtkFileChooser: Don't crash if invisible files are deleted
      Fix up signal ordering issues in GtkEntry
      GtkEntry: don't forget to disconnect idles
      Make GtkEntryCompletion::match-selected arguments consistent
      Fix signal parameters in GtkEntryCompletion
      GtkEntry: Explicitly disconnect keymap signals
      Update NEWS for 2.24.31
      2.24.31

Paul Davis (1):
      Improve fullscreen behavior on recent OS X

Timothy Arceri (1):
      filechooser: Show FUSE mounted locations in shortcuts

William Jon McCann (1):
      Desensitize filtered folders when in folder selection mode

Руслан Ижбулатов (2):
      Try to delete any existing W32 status icons when DPI changes
      GDK W32: Support UTF-16 surrogate pairs passed via VK_PACKET


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]