[libchamplain] Created tag LIBCHAMPLAIN_0_12_14



The unsigned tag 'LIBCHAMPLAIN_0_12_14' was created.

Tagger: Jiří Techet <techet gmail com>
Date: Tue Sep 6 23:34:43 2016 +0200

    0.12.14

Changes since the last tag 'LIBCHAMPLAIN_0_12_13':

Jiří Techet (27):
      Always check whether to wrap when viewport moved
      Remove left clones as they are always invisible
      Position master correctly when enabling/disabling wrap
      Optimize x_to_wrap_x()
      Create get_map_width() utility function and use it when needed
      Fix return value type warning
      Some whitespace changes to follow libchamplain coding style and removal of unneeded code
      Remove clones of user_layers
      Don't use zoom-level signal to update clones
      Reposition viewport after zooming and view scaling
      Use gdouble in x_to_wrap_x to avoid precision loss
      Post release version bump
      Update required libsoup version in README
      Whitespace
      Don't think that left+right mouse buttons pressed mean multitouch
      Remove unused uri_format in champlain_map_source_new_memphis()
      Revert "factory: remove Mapquest map source"
      Remove Maemo stuff
      Deprecate CHAMPLAIN_MAP_SOURCE_OSM_MAPQUEST and CHAMPLAIN_MAP_SOURCE_OSM_AERIAL_MAP
      Return NULL from all factory functions if the map source with the given name doesn't exist
      Add missing deprecated docstring
      Update vapi and libchamplain-sections.txt with new functions
      Fix "Since" in new network tile source API
      Add python demo demonstrating custom tile source
      Merge branch 'wrap2'
      Add comment describing viewport limits
      0.12.14

Jonas Danielsson (4):
      view: Make tile_map functions hash table agnostic
      view: Add visible tiles hash table
      view: Implement and add horizontal-wrap property
      launcher-gtk: Add horizontal wrap toggle button

Marius Stanciu (35):
      champlain-view: Add valid bouding-box check for champlain_view_set_world
      champlain-view: Add safety check to view_find_suitable_zoom function
      champlain-bounding-box: Include extremities in champlain_bounding_box_is_valid function
      champlain-view: Fix memory leak in tile_map_set
      champlain-map-source-factory: Fix memory leak in map source constructors
      Add viewport offset to champlain_view_x_to_longitude
      Fix zooming animation.
      Add swappable user layer clones.
      Sample neighboring user layer slots for reactive child actors.
      Merge commit 'origin/wrap~10'
      Make path layer draw all visible areas.
      Explicitly set map_layer size on relocation.
      Change enter-event to motion-event for user layer slot swapping.
      Make path layer anchor aware.
      Fix clutter_canvas_set_size errors in console.
      Pick up wrap events at viewport level, not clones.
      Destroy zoom_actor even if no tiles finished downloading.
      Reposition user_layers after disabling horizontal_wrap.
      Static sizes are not needed anymore for user layers.
      Fix coding style.
      Move variable declarations at the beginning of blocks.
      Factor out repetitive actor initialization code for the path layer.
      Add descriptive comment on path layer rendering.
      Fix clone_index check in viewport_motion_cb.
      Ensure sample_user_layer_at_pos returns a reactive user_layers child.
      Remove unnecessary checks in load_visible_tiles.
      User layers are now unreactive by default, no need to explicitly set     them anymore.
      Add descriptive comment to show_zoom_actor hwrap behavior.
      Enable get_map_size in champlain_path_layer to return the sizes separately.
      Make path layer exportablility compatible with recent wrap changes.
      Make the view export a wrapped map.
      Fix memory management for surfaces in path layer.
      Add descriptive comments.
      Hide left_actor in path layer when no clone is visible.
      Add extra clone on the left.

Mattias Bengtsson (3):
      Ignore some files
      NetworkTileSrc: Make max-conns settable
      NetworkTileSrc: Define magic number

Nayan Deshmukh (5):
      launcher.js: add sample marker
      Update deprecated libsoup code
      Update deprecated gdk_cursor method
      Check for existing factory in registered_sources
      factory: remove Mapquest map source


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]