[gtk+] (102 commits) Non-fast-forward update to branch wip/csoriano/pathbar-prototype



The branch 'wip/csoriano/pathbar-prototype' was changed in a way that was not a fast-forward update.
NOTE: This may cause problems for people pulling from the branch. For more information,
please see:

 https://wiki.gnome.org/Git/Help/NonFastForward

Commits removed from the branch:

  ccfb68d... Add GtkHidingBox
  49a4ab2... gtkhidingbox: use full variable names
  0b32a0d... gtkhidingbox: reorder variables
  58ee60b... gtkhidingbox: reorder variables
  8de465f... gtkhidingbox: we can assume we have min and nat pointers
  5c28f7f... gtkhidingbox: use the parameters directly
  f373418... gtkhidingbox: use full variable names
  74ab56d... gtkhidingbox: assume we always have min and nat pointers
  b21c9e0... gtkhidingbox: use directly the parameters
  a031327... gtkhidingbox: use full variable names
  145b896... gtkhidingbox: don't nest unneeded loop
  642ea8c... gtkhidingbox: use class_install_properties
  01514ee... gtkhidingbox: remove unneeded comment
  7cf1aeb... gtkhidingbox: take into account child expand property
  4358994... gtkhidingbox: simplify visibility management
  8354df0... gtkhidingbox: add property to choose side to handle overflo
  327d4e4... gtkhidingbox: remove extra widgets pixels
  e3a82a7... gtkhidingbox: use internal gtk_widget_simple_clip
  bc14107... gtkhidingbox: fix wrong extra space distribution
  b68bac2... gtkhidingbox: add getter for overflow children
  ecd3dea... gtkhidingbox: prefer width for height
  b803b06... gtkhidingbox: add copyright and authors
  41b9de3... Implement new GtkPathBar
  0649096... another try
  43c7685... another meh
  79f2695... f
  d2f1c47... gdkdisplay: fix warning
  63deb75... experiment with revealers
  2e22ff9... experiment with scrolled window

Commits added to the branch:

  358eec2... DND: Avoid a use-after-free (*)
  c891ceb... Docs: Clarify life cycle issue (*)
  b514631... Adwaita: hide separator on button.font and button.file (*)
  16afc59... Adwaita: bold size label on font button (*)
  46b789b... Adwaita: brighter pushed button background (*)
  e463e09... wayland: Avoid unitialized memory reads (*)
  63be0de... toolbar: Limit item position to number of contained element (*)
  4cce90d... colorbutton: Stop using state-changed (*)
  a992131... listbox: Don't compare int to uint (*)
  c34bb3b... query-settings: Don't compare int to uint (*)
  301652d... Remove useless casts from gdk_event_triggers_context_menu c (*)
  292e0c2... stack: Remove some code duplication (*)
  0d8993f... stack: Don't underallocate the last_child (*)
  d4f0c98... query-settings: Indicate deprecated settings (*)
  f0f8d6d... gdkwindow: Use GList less (*)
  30d2dc4... scrolledwindow: destroy children in destroy() (*)
  ddcf470... widget: No longer postpone style-updated on unrealized widg (*)
  cd305c1... widget: fix GtkLabelAccessible NULL links. (*)
  38f7117... scale: Avoid a crash (*)
  0bc7520... Updated Portuguese translation (*)
  a4c93d1... Updated Portuguese translation (*)
  0dfd6a7... Updated Spanish translation (*)
  101da71... Use upstream gettext (*)
  175cf7e... stack: always update window position at transition start (*)
  df98140... scrolledwindow: Fix typo in get_preferred_height calculatio (*)
  2b628e9... Updated Kazakh translation (cherry picked from commit d1585 (*)
  c81cd94... scrolledwindow: Remove redundant use of MAX (*)
  3078f18... gtk3-demo: Add context-menu cursor (*)
  4b8dfd8... gtk-demo: Update no-drop cursor image (*)
  0d18a42... Update cursor docs (*)
  096bea3... scrolledwindow: Better size requisition for GTK_SCROLL_NATU (*)
  2893526... gdk/wayland: use the multi-thread safe wayland API (*)
  783c302... wayland: Avoid spurious crossing events from master touch d (*)
  1d04bdf... x11/dnd: Ignore grab broken events from other devices than  (*)
  f516faa... Revert "scrolledwindow: Better size requisition for GTK_SCR (*)
  fa9f22e... scale: Bring back marks-related style classes (*)
  d288a13... display: Add vfunc for get_monitor_at_window (*)
  ca77de0... wayland: Add API to retrieve the Wayland output (*)
  b03784e... wayland: Add get_monitor_at_window to Wayland backend (*)
  6c939c0... Updated Slovak translation (*)
  0b58c96... wayland: Make gdk_wayland_window_get_wl_output() private (*)
  d14305f... wayland: Survive lack of settings (*)
  de7c156... icon theme: Add a warning (*)
  4151cb1... scale: Use more succinct names for style classes (*)
  fab70d3... gtkselectionprivate: minor style fix (*)
  5ae7f62... Adwaita: fix scale theming (*)
  cca2a22... color scale: Really sync style classes with GtkScale (*)
  6293a50... color scale: Sync style classes with GtkScale (*)
  eace965... scale css node test: Adapt to changes (*)
  d3adf47... treeview: Fix a rubberbanding-related crash (*)
  64eca0b... gtktextview: fix < public > comment (*)
  55751fc... Improve external drives detection (*)
  0d5b477... Adwaita: shave 1px from the switch (*)
  386ead4... Adwaita: add vertical margins to switches on a headerbar (*)
  57efcab... stack: Only map children when necessary (*)
  3d0e8cf... Update Arabic translation (*)
  ebf703f... Typo (*)
  76a5e3f... popover: set priv->window before setting doing add_popover( (*)
  9318dc1... Updated Swedish translation (*)
  fe68407... gl: Add a realize() fallback (*)
  9c3802f... gdk: Provide safe fallback for creating GL contexts (*)
  b5d52a2... Updated Norwegian bokmål translation. (*)
  16bca98... infobar: Update documentation (*)
  f39a7ec... Remove an unused variable (*)
  46b51e3... Trivial typo fix (*)
  30c3d6a... Improve CSS docs a bit (*)
  b90ae2c... Add a deprecation note (*)
  5759e2a... gtktextview: document how to get line space (*)
  b9f55df... window: Unfreeze window on unmap (*)
  c201cb3... Fix a duplicate word in the docs (*)
  10b8c08... Update migration guide a bit (*)
  e92e54c... Move release notes to online docs (*)
  17d798d... Updated German translation (*)
  c9903e0... Add GtkHidingBox
  947bf99... gtkhidingbox: use full variable names
  9a0ac6c... gtkhidingbox: reorder variables
  559ce33... gtkhidingbox: reorder variables
  a1ba8ac... gtkhidingbox: we can assume we have min and nat pointers
  b8dfa1d... gtkhidingbox: use the parameters directly
  3ea9dda... gtkhidingbox: use full variable names
  a831aec... gtkhidingbox: assume we always have min and nat pointers
  f66ab18... gtkhidingbox: use directly the parameters
  84844d1... gtkhidingbox: use full variable names
  0b044ea... gtkhidingbox: don't nest unneeded loop
  04f1171... gtkhidingbox: use class_install_properties
  871cdf2... gtkhidingbox: remove unneeded comment
  0fa8ff0... gtkhidingbox: take into account child expand property
  facee99... gtkhidingbox: simplify visibility management
  c498037... gtkhidingbox: add property to choose side to handle overflo
  be7a757... gtkhidingbox: remove extra widgets pixels
  212a95c... gtkhidingbox: use internal gtk_widget_simple_clip
  21f0fdd... gtkhidingbox: fix wrong extra space distribution
  c68cea3... gtkhidingbox: add getter for overflow children
  48e971f... gtkhidingbox: prefer width for height
  f973143... gtkhidingbox: add copyright and authors
  c90bc86... Implement new GtkPathBar
  973927c... another try
  82c8d2c... another meh
  36cf8ad... f
  acf2652... gdkdisplay: fix warning
  dfaf3bf... experiment with revealers
  e6d3c3c... experiment with scrolled window

(*) This commit already existed in another branch; no separate mail sent


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]