[gnome-software] (3 commits) Non-fast-forward update to branch wip/rancell/paid
- From: Robert Ancell <rancell src gnome org>
- To: commits-list gnome org
- Cc:
- Subject: [gnome-software] (3 commits) Non-fast-forward update to branch wip/rancell/paid
- Date: Tue, 23 Feb 2016 02:17:46 +0000 (UTC)
The branch 'wip/rancell/paid' was changed in a way that was not a fast-forward update.
NOTE: This may cause problems for people pulling from the branch. For more information,
please see:
https://wiki.gnome.org/Git/Help/NonFastForward
Commits removed from the branch:
4428454... Add stub reviews API
c1be2d4... Add flag for refining reviews
20b2795... Fix typos
99d136e... Add a review widget
7773ccc... Improve review widget
005587f... Pull review information from GsApp object
ebff611... Download reviews from Ubuntu reviews server
3d9e4e6... Only download reviews once
142d265... Fix star rating for downloaded reviews
06a0099... Fix review text alignment issues
373fdf9... Fix typo
02fcfaf... Clean whitespace
87a8f66... Tidy up docstrings
36dc4ff... Work on writing review UI / plugin
f362aec... Fix typo
5b2f343... Use rating when clicking on stars to start review
28e299c... Add an ability for plugins to request authorization for pos
df4d682... Get review auths when creating review dialog - next step pr
2c15041... Only show reviews widgets if a plugin supports it
c01830b... Set ratings from Ubuntu review stats. Disable local ratings
52a70af... Fix grammar
d13386b... Don't g_object_unref reviews which is a GPtrArray
fb28068... Set post button to GTK_RESPONSE_OK
a588e36... Add D-Bus interfaces to Ubuntu SSO
02e144f... Hook reviews into Ubuntu SSO client service
96914c8... Tidy up Makefile for new D-Bus code
945f8b3... Don't need plugins to report review auth - the plugin does
da0cc3a... Fix build by building generated files first and pretty prin
5578980... Drop unnecessary Makefile rules
03cbcc6... Prevent segfault due to indirectly freeing the OAuth creden
32f4600... Use OA_PLAINTEXT instead of OA_HMAC.
cdbb314... Add a write review button instead of hijacking the existing
478b4f3... Add self_review in GsApp.to_string
92c9dc9... Merge branch 'master' into wip/rancell/reviews
2dfeac3... Coding style changes from review
0b6871b... Bump copyright headers to 2016
dfb83a8... Coding style changes from review
8597bbb... Drop FIXME setting name of reviews - let the plugin set the
8f5b3f8... Drop special plugin function to report reviews support - we
87fb2dc... Fix bad merge
d4f3d14... Fix module checking for reviews
61b2e1e... Rename GsAppReview to GsReview
d778150... Update review dialog to match design
06233eb... Update reviews to match design
bbc99d3... Use widget style instead of sensitive to set labels to gray
40309b7... Add scrolled window to review text in dialog - this means i
3b89e80... Show total review count
7b0d8c1... Show review histogram
4d2e784... Stop using ubuntu-sso-client for credentials
e727fb8... Add Ubuntu One sign-in UI
4f8cb05... Add UbuntuLoginDialog
1ecb671... Use UbuntuLoginDialog to get credentials
abf63fb... Use a custom widget to render review bars
77c2347... Merge branch 'master' into wip/rancell/reviews
8f4a90d... Show login dialog in GDK thread
f412fb5... Release dangling reference
905f7f2... Fix password entry character
0c7827f... Rename .glade file to .ui
1690938... Make Ubuntu login dialog translatable
1518709... Use GLib i18n macro
613e678... Merge branch 'master' into wip/rancell/reviews
1df074a... Use the review rating count for total reviews
cb7b259... trivial: Use a safer method accessing a GArray
bc27cc8... trivial: Fix alignment of review text
20bba06... Add templates for new review functions
0d2dfed... Implement usefulness/report/delete review functions (not te
6db0826... trivial: Only show review count label if have reviews
a141cb0... Fix missing whitespace
fdb00f6... Merge branch 'master' into wip/rancell/reviews
43e4aa8... Merge branch 'master' into wip/rancell/reviews
018895d... Fix coding style of Ubuntu login dialog
14da93d... Use a template for login dialog UI
ff0abd6... Rename UbunutLoginDialog to GsUbuntuLoginDialog and fix var
8e746f4... Revert debugging change
7880fe2... Use HeaderBar for U1 dialog
a51b9a1... Simplify cancel button in U1 dialog
e47d25b... Merge branch 'master' into wip/rancell/reviews
a91c1b4... Use minimal limits for review content
9ba330b... trivial: Allow arbitrary variables to be read from /etc/os-
494cdf5... Correctly set origin and distroseries
a5f42e6... Correctly set review language
b95ad0d... Add note about where we need to get arch_tag from
3ceb49b... Don't hard-code the user agent
1828e52... Don't unnecessarily try and share SoupSession
2c31741... Use consistent method ordering
78e81ed... Use type-safe methods, not properties
073adbb... Whitespace alignment
8ee9634... Make code easier to read
4e75015... Add send_request () helpers
9b40862... Simplify download_review_stats ()
ac538f5... Simplify download_reviews ()
ecf394a... Simplify set_package_review ()
4ff9047... Simplify set_review_usefulness ()
6ca7b49... Simplify report_review ()
7573560... Simplify remove_review ()
2a3d6ba... Don't hold reference to spell checker
8df6964... Remove notify emissions of old properties
0c49f40... Fix requests in login dialog
f7d6c46... Revert "Don't hold reference to spell checker"
3954cf4... trivial: Turns out you don't need to manually unref GtkSpel
619d8e2... Merge branch 'master' into wip/rancell/reviews
deefc67... Revert "Simplify remove_review ()"
0ff79f6... Revert "Simplify report_review ()"
43f8633... Revert "Simplify set_review_usefulness ()"
c102bf0... Revert "Simplify set_package_review ()"
e8d8bb2... Revert "Simplify download_reviews ()"
7bbec27... Revert "Simplify download_review_stats ()"
862d450... Revert "Add send_request () helpers"
f2f5040... Refactor common code for sending requests to reviews.ubuntu
743d073... Merge branch 'master' into wip/rancell/reviews
66d863b... Merge branch 'master' into wip/rancell/reviews
afc89ff... Use shared SoupSession
6a5c30a... Update for automake variable rename
9ebb43a... De-dup json-glib package checking
676712c... Merge branch 'master' into wip/rancell/reviews
47947bd... Fix compile warnings
a87559e... Merge branch 'master' into wip/rancell/reviews
19fa9df... Start adding the concept of currency
Commits added to the branch:
3ee3a3c... trivial: Fix memory leak in GsApp (*)
4706dc3... Start adding the concept of currency
455462a... Mark owned apps
(*) This commit already existed in another branch; no separate mail sent
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]