[gtk+] Created tag 3.19.9



The unsigned tag '3.19.9' was created.

Tagger: Matthias Clasen <mclasen redhat com>
Date: Tue Feb 16 20:15:27 2016 -0500

    3.19.9

Changes since the last tag '3.19.8':

Alberts Muktupāvels (3):
      gtksettings: reset property to correct default value
      gtksettings: fix critical warning
      gdkwindow-x11: always set _GTK_THEME_VARIANT property

Alexandre Franke (1):
      Updated French translation     (cherry picked from commit 85fb4c1c0a17906a65e0b732770b88353b6214c4)

Anders Jonsson (2):
      Updated Swedish translation
      Updated Swedish translation

Balázs Meskó (1):
      Updated Hungarian translation

Baurzhan Muftakhidinov (1):
      Updated Kazakh translation

Benjamin Otte (83):
      entry: Draw progress in the right place
      entry: Simplify drawing code
      entry: Turn progress node into a gadget
      immodule: Use correct sign for function prototype
      composetable: Fix gcc warnings
      broadway: Define variables where they are used
      entry: queue an allocate when pulsing
      cssprovider: Change location of builtin themes
      inspector: Don't hardcode builtin themes
      build: Don't break windows build
      win32: Delete classic theme
      win32: Get rid of XP theme
      widget: Set a css name
      css: Add rem unit
      css: Properly convert em, ex and rem to pixels
      css: Convert numbers with GTK's dpi
      cssimageradial: Only emit one error for wrong position
      cssimageradial: Only allow at "<position>" after other props
      inspector: Drop type name from node list
      cssmatcher: Remove type argument from name matcher
      cssselector: Remove type references
      win32: Fix empty body warning
      win32: Use g_set_object()
      win32: Remove deprecation warnings in devicemanager code
      win32: Remove deprecation warnings in dnd code
      immodule: Stop gcc from complaining
      mountoperation: Silence gcc
      printoperation-win32: Silence gcc
      filechoosernativewin32: Define MSC_VER at top of file
      filechoosernativewin32: Add missing return type
      filechoosernativewin32: Silence gcc
      win32embedwidget: Mark deprecated sections
      win32: Stop using _gdk_display global in device code
      win32: Make cursor code work without _gdk_display
      win32: Remove _gdk_display usge from dnd code
      win32 theme: Do a quick'n'dirty search/replace
      win32 theme: Replace pseudoclasses with undeprecated ones
      win32 theme: Get rid of deprecated style properties
      tests: Remove unused variable
      testgtk: Compile without warnings on win32
      imcontextsimple: Remove unused variable on win32
      filechoosernativewin32: Remove unused variables
      testsuite: No warnings on type conversions please
      win32: Always pass a window to the default event filters
      win32: Remove unused functions / header includes
      win32: Remove XP-specific code
      win32: Capture WM_THEMECHANGED
      win32 theme: Add a GtkWin32Theme object
      win32: Move init code into windows-specific code
      inspector: Don't use unused variables
      cssimageradial: Don't print 2 spaces
      linear-gradient: Remove the hack using NUMBER
      cssnumbervalue: Remove gtk_css_number_value_get_unit()
      css: Turn number values into a virtual type
      css: Add gtk_css_number_value_can_parse()
      css: Add initial support for calc()
      css: Add support for sums to calc()
      css: Add API to handle order when printing calc()
      css: Add support for '*' and '/' to calc()
      calc: Allow subterms with '(' ')' bracketing
      css: Implement transitions for numbers of different units
      tests: Port testlockbutton to GTask
      testsuite: Don't use deprecated APIs
      paned: rtl-flip with the correct rectangle
      paned: Use content allocation instead of widget allocation
      paned: Fix drawing
      css: Add a number value handling win32 sizes
      win32: Add gtk_win32_theme_parse()
      win32: Canonicalize theme-name before adding to hash table
      win32: Update color handling to recent GtkWin32Theme changes
      win32 theme: Use same spinner as Adwaita
      win32 theme: Don't set the color on *
      win32: Add support for -gtk-win32-part-width/height to CSS
      cssimagecrossfade: Fix order of images when parsing/printing
      win32 theme: Draw checkmarks and radiomarks properly
      win32 theme: Remove a bunch of workarounds that are no longer necessary
      cellrenderertoggle: Use "check" and "radio" names
      widget-factory: Add myself
      cellrenderertoggle: Split out a function
      cellrendertoggle: Draw background + frame for mark
      win32 theme: Always include the win32 theme
      win32 theme: Include the default win32 colors
      cellrenderertoggle: Change "indicator-size" handling

Caolán McNamara (7):
      gtk-demo: Add a menu to foreigndrawing
      gtk-demo: attempt at a notebook with active box-shadow in tab
      cannot not -> must
      gtk-demo: spinbutton and menubar examples
      gtk-demo: add menu check and radio examples
      gtk-demo: add combobox demos
      gtk-demo: add menu separator demo

Carlos Garcia Campos (2):
      notebook: Do not reorder tabs after a grab notify if there isn't an ongoing reorder operation
      Revert "Remove _gtk_box_get_children"

Carlos Garnacho (4):
      x11: Avoid setting has_pointer_focus if a EWMH compliant WM is present
      gdk: Add GdkDragCancelReason enum as argument to GdkDragContext::cancel
      gdkdnd: Make GtkDragContext::cancel RUN_LAST
      gdkdnd: Stick to the first gdk_drag_drop_done() result

Carlos Soriano (1):
      gtkplacessidebar: remove notification handling

Chao-Hsiung Liao (2):
      Updated Chinese (Taiwan) translation
      Updated Chinese (Taiwan) translation

Christoph Reiter (1):
      Add -gtk-image-effect alias for -gtk-icon-effect

Chun-wei Fan (2):
      Fix 'make dist'
      gtk/gtkentry.c: Fix build on pre-C99

Colomban Wendling (1):
      treeview: Make sure the editing widget's top left is always visible

Daniel Mustieles (4):
      Updated Spanish translation
      Updated Spanish translation
      Updated Spanish translation
      Updated Spanish translation

Dušan Kazik (1):
      Updated Slovak translation

Emmanuele Bassi (2):
      Revert "Add missing (out) annotation to gdk_rgba_parse"
      mir: Add C++ guards

Ignacio Casal Quinteiro (1):
      win32: properly handle show and focus

Jakub Steiner (1):
      Adwaita: make popovers less 1995

John Ralls (1):
      Fix Quartz clipboard image retrieval.

Jonas Ådahl (2):
      wayland: Handle after-paint invocations when nothing was painted
      wayland: Only attach the buffer if there was damage

Lapo Calamandrei (35):
      Adwaita: fix vertical spinbutton style
      Adwaita: notebook with hidden header style fix
      Adwaita: fix headerbar spinbutton size
      Adwaita: removed some old cruft from _drawing.scss
      Adwaita: darker background for popovers
      Adwaita: animate check and radios
      Adwaita: fix bogus selector...
      Adwaita: notebook arrow styling.
      Adwaita: remove an unneded selector.
      Revert "Adwaita: remove an unneded selector."
      Adwaita: try being smarter wrt extending buttons.
      Adwaita: fix scale popup button size
      Adwaita: scss cosmetic changes
      Adwaita: don't set a border for drop targets
      Adwaita: correct spacing for mixed buttons
      Adwaita: image-button sizing fix
      Adwaita: flatten up search bars and inline toolbars
      Adwaita: fix treeview dnd column headers
      Adwaita: no rounded corners for backdrop tiled windows
      Adwaita: shortcutswindow fixes
      Revert "Adwaita: no rounded corners for backdrop tiled windows"
      Adwaita: no rounded corner for tiled backdrop windows
      Adwaita: sidebar background-color
      Adwaita: notebook fixes
      Adwaita: correct size for ssd titlebars
      Adwaita: correctly style arrows wrt tab position
      Adwaita: stop using assets for treeview check/radio...
      Adwaita: be more specific about menu items height
      Adwaita: make tab buttons square once again
      Adwaita: places sidebar sizing with min-height...
      Adwaita: places sidebar eject button sizing
      Adwaita: make tab child not cover the active tab indication
      Adwaita: add back a bottom border on the pathbar/entry box
      Adwaita: use Matthias provided ID for the previous commit style
      Adwaita: add a top border to the filechooser bottom bar

Mario Blättermann (1):
      Updated German translation

Matthias Clasen (74):
      Throw an error when a display is missing
      Document gtk_parse_args limitations
      treeview: Draw background when empty
      wayland: Reduce warning level for parentless temporaries
      Fix some reftests under wayland
      Fix another reftest
      Fix the border-image-excess-size reftest
      combobox: Avoid a misleading indentation
      Don't include the builtin sequence table in multiple places
      file chooser: Avoid a crash
      gtk-builder-tool: Accept --help
      gtk-launch: Add --version
      gtk-builder-tool: Expand the preview command
      reftests: Make animation-direction test more reliable
      reftests: Rename a source file
      reftests: Add a message to the test output
      reftests: Make label-text-shadow-changes-modify-clip test more reliable
      Trivial formatting fix
      reftests: Make separator-size test pass in HighContrastInverse
      print dialog: Fix layout preview drawing
      Move private widget path functions away
      Document rem as CSS unit
      Fix indentation
      levelbar: Make discrete levelbars behave as before
      css tests: Fix expected output
      css tests: Fix style tests
      Update CSS docs regarding type names
      Fix stylecontext tests
      level bar: Make the full offset official
      level bar: Improve documentation
      level bar: Fix offset behavior
      level bar: Document buildable syntax
      Fix levelbar css node tests
      widget-factory: Update levelbar example
      box gadget: Fix allocation without baseline
      Adwaita: No rounded corners for fullscreen
      Add css node tests for box packing
      inspector: Avoid crash in magnifier
      text view: Improve tag pointer tracking
      gtk-demo: Improve the tag implementation
      testgtk: Remove an unused variable
      gtk-demo: Add more foreign drawing examples
      notebook: fix arrow states
      Adwaita: tone down treeview separators
      placesview: Fix some minor issues
      Adwaita: Don't grow flat entries
      placessidebar: Increase padding
      paned: Don't overdraw
      paned: Draw handle before children
      Adwaita: Insensitive notebook arrows
      file chooser: Use the right model when getting the selection
      file chooser: Avoid nonworking search+save combinations
      gadget: Be careful in geometry calculations
      Docuemnt calc() support in CSS
      widget-factory: Add an inline toolbar example
      gtk-demo: modernize the application demo
      gtk-demo: Add window size saving example
      gtk-demo: Fix the size saving for CSD
      gtk-demo: Streamline application
      gtk3-demo: Fontify all source files
      Adwaita: Fix a padding problem in action bars
      places sidebar: use a box
      Expand the docs for gtk_window_set_default_size()
      notebook: Fix a misplaced tab label
      Some more CSS node tests for notebooks
      file chooser: Reload current dir when switching from search mode
      Add a release note about window size saving
      Add a release note about level bar changes
      Updates
      file chooser: Add an ID to the box around the pathbar
      printing: Add message contexts
      Add message contexts to translated strings
      places sidebar: Use the right marshallers
      3.19.9

Michael Catanzaro (1):
      Fix a typo

Piotr Drąg (1):
      Updated Polish translation

Rafael Fontenelle (1):
      Updated Brazilian Portuguese translation

Ray Strode (8):
      wayland: rename window->surface to window->wl_surface
      wayland: move server proxy objects to substructure
      wayland: rename cairo surface user data key to be more specific
      wayland: use g_clear_pointer when destroying cairo surfaces
      wayland: always return FALSE from begin_paint
      wayland: don't handle buffer release centrally
      wayland: stage uncommitted changes to dedicated buffer
      wayland: rework buffer management code (3 changes)

Rico Tzschichholz (1):
      gtk: Fix some return-values annotations (transfer none/full)

Rui Matos (1):
      gtkmagnifier: Avoid a crash if the inspected widget is finalized

Timm Bäder (24):
      colorchooserwidgeet: Reset the selected swatch when removing
      widget: Annotate out params of _translate_coordinates as optional
      entry: Fix icon areas
      colorswatch: Remove unused constant
      Remove _gtk_box_get_children
      statusbar: Remove unused include
      actionbar: Remove unnecessary map/unmap implementations
      Range: Group all three gestures
      switch: Don't queue draws after setting state flags
      Remove more unnecessary redraws
      iconhelper: Un-duplicate some code
      cssstylechange: Add helper function to print change
      csstypes: Add GTK_CSS_AFFECTS_SYMBOLIC_ICON
      stylepropertyimpl: Use GTK_CSS_AFFECTS_SYMBOLIC_ICON
      iconhelper: Save whether the surface is symbolic
      Add and use gtk_icon_helper_invalidate_for_change
      Make gtk_icon_helper_invalidate private
      image: _get_style_context never returns NULL
      Various documentation fixes
      A few more documentation fixes
      css node tree: Fix crash
      spinbutton: Free the gadget in finalize
      frame: Set border gadget state after creating it
      overlay: set css name

William Hua (2):
      gdkborder: remove unneeded definition
      x11: don't apply scaling factor twice

Yevgen Muntyan (1):
      win32: on focus restore the window if iconified

Руслан Ижбулатов (1):
      Don't do remote checks on NULL files


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]