[glibmm] RemoteActionGroup: Rename some vfuncs to add _full().
- From: Murray Cumming <murrayc src gnome org>
- To: commits-list gnome org
- Cc:
- Subject: [glibmm] RemoteActionGroup: Rename some vfuncs to add _full().
- Date: Fri, 9 Dec 2016 10:41:50 +0000 (UTC)
commit 70378096afc2a703d84c27347f94bdeedded7e7f
Author: Murray Cumming <murrayc murrayc com>
Date: Fri Dec 9 11:39:03 2016 +0100
RemoteActionGroup: Rename some vfuncs to add _full().
Rename activate_action_vfunc() to activate_action_full_vfunc() ad
rename change_action_state_vfunc() to change_action_state_full_vfunc(),
matching the underlying C vfuncs.
Now that this class derives from ActionGroup, this was causing warnings
such as this, at least with clang++:
/opt/gnome/include/giomm-2.52/giomm/remoteactiongroup.h:180:18: error:
'Gio::RemoteActionGroup::activate_action_vfunc' hides overloaded virtual
function [-Werror,-Woverloaded-virtual]
virtual void activate_action_vfunc(const Glib::ustring& action_name, const Glib::VariantBase&
parameter, const Glib::VariantBase& platform_data);
^
/opt/gnome/include/giomm-2.52/giomm/actiongroup.h:574:18: note: hidden overloaded virtual function
'Gio::ActionGroup::activate_action_vfunc' declared
here: different number of parameters (2 vs 3)
virtual void activate_action_vfunc(const Glib::ustring& name, const Glib::VariantBase& parameter);
gio/src/remoteactiongroup.hg | 4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
---
diff --git a/gio/src/remoteactiongroup.hg b/gio/src/remoteactiongroup.hg
index 5a70ac6..57ec71d 100644
--- a/gio/src/remoteactiongroup.hg
+++ b/gio/src/remoteactiongroup.hg
@@ -61,8 +61,8 @@ public:
#m4 _CONVERSION(`GVariant*',`const Glib::VariantBase&',`Glib::wrap($3, true)')
- _WRAP_VFUNC(void activate_action(const Glib::ustring& action_name, const Glib::VariantBase& parameter,
const Glib::VariantBase& platform_data), "activate_action_full")
- _WRAP_VFUNC(void change_action_state(const Glib::ustring& action_name, const Glib::VariantBase& value,
const Glib::VariantBase& platform_data), "change_action_state_full")
+ _WRAP_VFUNC(void activate_action_full(const Glib::ustring& action_name, const Glib::VariantBase&
parameter, const Glib::VariantBase& platform_data), "activate_action_full")
+ _WRAP_VFUNC(void change_action_state_full(const Glib::ustring& action_name, const Glib::VariantBase&
value, const Glib::VariantBase& platform_data), "change_action_state_full")
};
} // namespace Gio
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]