[gparted] Rename Device::add_path() to set_path() (#767842)
- From: Curtis Gedak <gedakc src gnome org>
- To: commits-list gnome org
- Cc:
- Subject: [gparted] Rename Device::add_path() to set_path() (#767842)
- Date: Sun, 7 Aug 2016 20:53:00 +0000 (UTC)
commit 1dc8a0c628ecc4585b519bc16a1f110703b77d31
Author: Mike Fleetwood <mike fleetwood googlemail com>
Date: Thu Jun 2 12:55:45 2016 +0100
Rename Device::add_path() to set_path() (#767842)
To reflect that there is only a single path in the Device object now.
Also get rid of the now unneeded optional parameter which was only
relevant when there was a vector of paths.
Bug 767842 - File system usage missing when tools report alternate block
device names
include/Device.h | 2 +-
src/Device.cc | 2 +-
src/GParted_Core.cc | 2 +-
3 files changed, 3 insertions(+), 3 deletions(-)
---
diff --git a/include/Device.h b/include/Device.h
index 8c0ebcc..b8ddc13 100644
--- a/include/Device.h
+++ b/include/Device.h
@@ -32,7 +32,7 @@ public:
~Device() ;
Device get_copy_without_partitions() const;
- void add_path( const Glib::ustring & path, bool clear_paths = false ) ;
+ void set_path( const Glib::ustring & path );
Glib::ustring get_path() const ;
void enable_partition_naming( int length ); // > 0 => enable partition naming support
bool partition_naming_supported() const;
diff --git a/src/Device.cc b/src/Device.cc
index 687f461..8419baa 100644
--- a/src/Device.cc
+++ b/src/Device.cc
@@ -58,7 +58,7 @@ Device Device::get_copy_without_partitions() const
return new_device; // (3) Return by value.
}
-void Device::add_path( const Glib::ustring & path, bool clear_paths )
+void Device::set_path( const Glib::ustring & path )
{
this->path = path;
}
diff --git a/src/GParted_Core.cc b/src/GParted_Core.cc
index e840f85..a68a3cc 100644
--- a/src/GParted_Core.cc
+++ b/src/GParted_Core.cc
@@ -277,7 +277,7 @@ void GParted_Core::set_devices_thread( std::vector<Device> * pdevices )
temp_device .Reset() ;
//device info..
- temp_device .add_path( device_paths[ t ] ) ;
+ temp_device.set_path( device_paths[t] );
temp_device .model = lp_device ->model ;
temp_device .length = lp_device ->length ;
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]