[gtk+] Created tag 3.21.1



The unsigned tag '3.21.1' was created.

Tagger: Matthias Clasen <mclasen redhat com>
Date: Wed Apr 27 13:57:39 2016 -0400

    3.21.1

Changes since the last tag '3.20.1':

Alexander Larsson (1):
      gdkwindow: Remove O(n-children) code in gdk_window_invalidate

Arash Mousavi (1):
      Update Persian translations

Aurimas Černius (1):
      Updated Lithuanian translation

Balló György (1):
      GtkTrayIcon: fix uninitialised variable

Balázs Úr (1):
      Updated Hungarian translation

Bastien Nocera (6):
      ui-manager: Fix "format not a string literal" errors
      about-dialog: Fix "format not a string literal" errors
      file-chooser-widget: Fix "format not a string literal" error
      recent-manager: Fix "format not a string literal" error
      cups: Fix "format not a string literal" error
      cups: Fix gettext usage

Benjamin Otte (10):
      window: Remove suspicious branch
      widget: queue a redraw only if resize highlighting is enabled
      iconhelper: Invalidate on clear()
      win32 theme: Fix functions to not have spaces
      theme: Split out _solid() function
      theme: linear-gradient() needs 2 color-stops
      cssimage: Warn if gradients only have 1 color stop
      cssbgsizevalue: Avoid allocating new value if not needed
      cssbordervalue: Avoid allocating new value if not needed
      cssshadowsvalue: Avoid allocating new value if not needed

Bernhard Reutner-Fischer (1):
      docs: typo in GTK_STYLE_CLASS_LIST_ROW docs

Carlos Garnacho (29):
      wayland: Avoid NULL slave devices in GdkSeat::get_slaves
      device: Add distance/rotation/slider GdkAxisUse values
      device: Add gdk_device_get_axes(), and ::axes property
      gdkdevice: Add GdkDeviceTool to identify device tools
      gdkdevice: Add GdkDevice::tool-changed signal
      gdk: Add GdkSeat::tool-added/removed signals
      GdkSeatDefault: Add functions to add/remove tools
      events: Add gdk_event_[gs]et_device_tool()
      gdk: Forward tools in client-side windows event translation
      x11: Update GdkDevices on "Wacom Serial IDs" property changes
      x11: Set GdkDeviceTool on motion/button events
      gtk3-demo: Show multiple master devices on the "Event axes" demo
      demos: Set crossing events mask explicitly on event-axes demo.
      demos: Enable multidevice behavior on event-axes demo
      x11: Use XInternAtom directly on poking device hardware IDs
      wayland: Refactor master pointer data into a separate struct
      build: Bump wayland-protocols dependency to 1.3
      wayland: Translate pen buttons into button events
      wayland: Hook tablets to GdkSeat
      gtk3-demo: Add tool information to "Event axes" demo
      wayland: Check the tablet manager before creating a wp_tablet_seat
      gdkevents: Fix GDK_AVAILABLE_IN annotation
      wayland: Propagate slider/rotation axes from tools to devices
      demos: Show slider/rotation axes in "Event axes" demo
      GtkWindow: Ensure the toplevel is realized before realizing popovers
      gdk: Make GDK_TOUCH_CANCEL be dealt with similarly to GDK_TOUCH_END
      wayland: Do not check the pointer focus when receiving wl_pointer.frame
      wayland: Improve checks when flushing scroll events
      wayland: Perform seat grab focus checks on native windows

Christian Hergert (8):
      frame-clock: avoid g_signal_emit_by_name()
      debug: remove open-coded debug checks in gtktextsegment
      kineticscrolling: avoid stutter at tail of kinetic deceleration
      quartz: fix quartz build
      builtinicon: avoid calculating font-metrics in vast majority of cases
      wayland: avoid jitter in keyboard repeat
      frametimings: reuse previous frame timing in common case
      pixelcache: reuse existing timeout source when possible

Christoph Reiter (1):
      inspector: add slider for adjusting the font scale

Chun-wei Fan (3):
      MSVC builds: Update how introspection builds are done
      Visual Studio builds: Generate .pc files
      gdk/gdkglcontext.c: Avoid a GCCism

Cosimo Cecchi (6):
      scale: cache pango layouts for mark labels
      scale: remove impossible case
      range: use gadget pointers for grab/mouse locations
      scale: fix marks node position for scales with value
      GtkCssSection: remove duplicated documentation
      GtkClipboard: fix a typo

Daniel Mustieles (1):
      Updated Spanish translation

Daniel Stone (1):
      wayland: Ignore NoSymbol keys

Debarshi Ray (2):
      window: Fix gtk_window_set_geometry_hints documentation
      window: Make the sample code obey the party line on geometry widgets

Emanuele Aina (1):
      glarea: Relay the use-es flag to context creation

Emmanuele Bassi (29):
      Bump to 3.21.0
      Assign a recent manager if one is set
      recent-manager: Emit ::changed on file deletion
      recent-manager: Fix the error domain and message on move_item()
      recent-manager: Always ensure that size is reset on creation
      gl: Add 'use-es' flag
      gl: Relay use-es from context to paint data
      gdk: Move GLSL shaders into GResource
      gdk: Add 'GDK_GL=gles' flag
      gdk: Add GLES shaders
      gl: Add more OpenGL ES checks
      gl: Use the appropriate format on GLES
      gl: Use the appropriate formats when reading buffers on GLES
      gl: Tweak the swizzle for GLES texture fragments
      wayland: Implement asking for a GLES context
      wayland: Honour GDK_GL=gles on context creation
      wayland: Add debugging notes for EGL context creation
      wayland: Bind the appropriate OpenGL API
      x11: Allow creating GLES contexts
      gl: Add fallback for missing subimage unpacking
      gl: Use a uniform to flip R and B colors on GLES
      tests: Add GLES shaders to testglarea
      tests: Add GLES support to GtkGears
      demo: Add GLES support to the GtkGLArea demo
      glarea: Use the appropriate texture format for GLES
      docs: Clarify the platform-dependency of GdkGLContext:use-es
      docs: Add new GdkGLContext symbols
      docs: Add new GtkGLArea symbols
      gdk: Ensure resources registration happens once

Felipe Borges (2):
      cups: Fix more "format not a string literal" error
      cups: make string non-literals translatable again

Frediano Ziglio (1):
      Save scancode inside GdkEventPrivate

Friedrich Beckmann (1):
      quartz: zoom/rotate change compile/runtime check from 10.7 to 10.8

GNOME Translation Robot (1):
      Updated Scottish Gaelic translation

Georges Basile Stavracas Neto (3):
      placesview: provide guidance on server addresses
      placesview: follow up fixes
      placesview: update a leftover function name

Gábor Kelemen (1):
      Updated Hungarian translation

Ignacio Casal Quinteiro (2):
      win32: add missing empty lines
      win32: rollback change and use _gdk_display

Jeremy Tan (2):
      GDK W32: Fix bounding rect calculation on window creation The bounding rect specifies the top left and 
bottom right corners - the bottom right corner must account for the current window position.
      GDK W32: Fix positioning of reparented window

Jonas Ådahl (4):
      wayland: Clean up naming of GdkWaylandDisplay pointers
      wayland: Track orphaned dialogs per display
      gdk/dnd: Add missing signal parameter documentation
      gdk/dnd: Don't use default display when getting cursor

Jonathan Matthew (1):
      gtkmenusectionbox: remove submenus when the parent item is removed

Jordi Mas (2):
      Fix Catalan translation
      Update Catalan translation

Kristjan SCHMIDT (2):
      Updated Esperanto translation
      Updated Esperanto translation

Lapo Calamandrei (42):
      Adwaita: cosmetic fix
      Adwaita: set caret-color for drop targets
      Adwaita: set secondary caret color to selection blue
      Adwaita: cosmetic fixes
      Adwaita: style textview border
      Adwaita: transparent textview border border
      Adwaita: better solid-csd styling
      Adwaita: fix backdrop solid-csd
      Adwaita: really fix solid-csd
      Adwaita: ensure titlebar corners are not rounded...
      Adwaita: flatten scale and progressbar trough
      Adwaita: delete unused mixin
      Adwaita: flatten entries and similar widgets
      Adwaita: flatten the switch base
      Adwaita: lighten border color a bit
      Adwaita: more border color tweaking
      Adwaita: ensure dialogs titlebar rounded corners
      Adwaita: button style tweak
      Adwaita: pushed button style tweak
      Adwaita: dark variant borders color tweaks
      Adwaita: cosmetics
      Adwaita: more borders color tweaks
      Adwaita: flatten colorswatches
      Adwaita: fix scale slider border color
      Adwaita: clean up pushed button mixin
      Adwaita: increase opacity on scale label and marks
      Adwaita: colorbutton colorswatch shadow fix
      Adwaita: cosmetics
      Adwaita: fix infobar text color in backdrop windows
      Adwaita: better shadow stacking mixin
      Adwaita: add shadows back...
      Adwaita: stop using images for solid backgrounds...
      Adwaita: fix insensitive switch styling
      Adwaita: fix switch styling
      Adwaita: scale with marks style fix
      Adwaita: link button style fix
      Adwaita: use an image for backdrop button background
      Adwaita: spinbutton fixes
      Adwaita: solid bg for disabled pushed button
      Adwaita: cosmetics
      Adwaita: backdrop active button color tweaks
      Adwaita: color tweaks

Lukas K (1):
      Fix gtk_scrollable_get_border annotation

Matt Watson (20):
      progresstracker: simple struct to track animation progress
      progresstracker: add GTK_SLOWDOWN environment variable
      inspector: add slider to control slowdown factor
      stack: port to progress tracker
      stack: skip first frame for animations
      revealer: port to progress tracker
      switch: port to progress tracker
      popover: port to progress tracker
      scrolledwindow: port indicator fade to progress tracker
      progressbar: port to progress tracker
      entry: port to progress tracker
      csstransition: port to progress tracker
      cssanimation: port to progress tracker
      animatedstyle: fail to create new style if timestamp goes backwards
      animatedstyle: just ref current style if timestamp the same
      animatedstyle: don't share styleanimations
      css: always get default font size in pixels
      reftests: test em size
      reftests: test rem size
      Fix label css test

Matthias Clasen (111):
      add a css style test for font: smaller
      Add a css node test for scales
      dnd: Move GtkDragDest to a separate file
      stack switcher: Add a missing include
      gtk3-demo: Rename "CSS Theming" group
      gtk3-demo: Show more button styles
      HighContrastInverse: Fix suggested-action colors
      Make gdk_visual_get_*_pixel_details work again
      wayland: Fully initialize the visual
      Add a test for the system rgba visual
      range: Avoid miscalculating highlight allocation
      range: Simplify highlight allocation
      Add version macros for 3.22
      Deprecate gdk_visual_get_bits_per_rgb
      Add some more visual tests
      wayland: Fix up visual implementation
      Deprecate gdk_visual_get_byte_order
      Deprecate gdk_visual_get_colormap_size
      wayland: Add debug output for pixel formats
      Revert "window: Remove suspicious branch"
      Split off copied pango utils in their own source
      Stop using pango_split_file_list
      Drop irritating FIXMEs in docs
      wayland: Get min/max keycode from xkb keymap
      file chooser: Drop unused code
      Drop some more code
      filter model: Mark property nicks and blurbs for translation
      Remove private clipboard api from public headers
      Add a function to get the selection of a clipboard
      Add an index for 3.22 api additions
      places sidebar: Plug a small memory leak
      Use dngettext instead of ngettext
      Move autotestkeywords to testsuite
      Add tests for seat apis
      Expand visual tests a bit
      Add some tests for GdkRectangle
      Accel cell renderer: Set a css name
      Adwaita: theme acceleditor > label
      Use AM_DISTCHECK_CONFIGURE_FLAGS
      icon theme: Make the builtin hicolor index match reality
      wayland: Print out more debug info
      wayland: Remove unused field
      wayland: Remove an unused vfunc
      Add an index for 3.22 api additions
      Move GdkDeviceManager to deprecated section
      inspector: Give the font scale an entry
      inspector: Add an origin mark to the slowdown scale
      inspector: Use GdkAxes instead of GdkAxisUse
      Move GdkDeviceTool into its own files
      inspector: simplify some code
      Mention geometry handling changes in release notes
      wayland: Keyboard don't have x/y
      Add a note about GDK_AXIS_X/Y
      listbox: Fix css node ordering
      gdkdevice: Expose tool as property
      GtkBuilder: Mention how GVariant properties are parsed
      inspector: Don't lie with statistics
      Clarify docs a bit
      wayland: Implement virtual modifiers
      wayland: Fix the map_virtual_modifiers implementation
      menuitem: Fix some possible problems with arrow_gadget
      wayland: Make virtual modifier mapping more similar to X
      Add some more accelerator / modifier tests
      Add a help overlay to bloatpad
      shortcuts: Follow changes of accels
      bloatpad: Make shortcuts window update
      Add gdk_pango_context_get_for_display
      widget: Use gdk_pango_get_for_display
      Add docs for new API
      css style: Rename some static functions
      Fix the css style font test
      Export some font parsing functions
      Fix parsing of the font: shorthand
      Adwaita: Fix use of font: shorthand
      Add backwards compat back
      HighContrast: Fix font: usage
      Fix a typo
      Expand css style font tests
      font button: Convert from pango to css properly
      Add a comment to explain numbers here
      wayland: Add debug output for keymaps
      wayland: Some more debug spew
      magnifier: Only connect to ::draw when needed
      Add some va marshallers to frequent signals
      menushell: Add a va marshaller for ::insert
      text buffer: Add va marshallers for signals
      text tag: Add a va marshaller to ::event
      css gadget: Don't get display flags twice
      Use qdata for debug flags
      css gadget: Fix baseline debug
      widget: Don't show widget resizes in the inspector
      Add a dnd test using a window as icon
      Ad d new API to the docs
      Fix formatting
      font button: Fix translation of font-name default
      notify test: Skip GtkFontButton::font-name
      Raleigh: Fix font syntax
      css: Fix printing of images
      Fix css parser tests
      Remove debug spew
      label css style test: fix font syntax
      Updates
      Expand the drag widget testcase
      testdnd2: Actually test gtk_drag_set_icon_widget
      dnd: Fix lifecycle issues with widgets as drag icons
      progressbar: Enforce invariants
      dnd: Set attributes from all widgets for text drag icons
      Fix indentation
      dnd: Fix some issues with drag icons
      Updates
      3.21.1

Milo Casagrande (1):
      Updated Italian translation     (cherry picked from commit be624e71f43ffe8ec5351fbce575388561c5a240)

Mohammed Sadik (4):
      gtkaboutdialog: Add support for GNU Affero GPLv3+
      gtkaboutdialog: don't break ABI in GtkLicense enum
      broadway: fix documentation
      documentation: trivial typo fixes in GtkWidget

Olivier Fourdan (4):
      popover: raise when showing
      wayland: Do not resize with the same size
      wayland: do not update shadows for child windows
      test: do not remove files on distclean

Paolo Borelli (2):
      textiter: add unit test for forward_to_line_end
      inspector: do not leak seat capabilities descriprion

Piotr Drąg (5):
      Updated POTFILES.in
      Updated POTFILES.skip
      Updated POTFILES.in and POTFILES.skip
      Updated Polish translation
      cups: Fix duplicate string

Razvan Chitu (1):
      trashmonitor: change trash monitoring process

Rico Tzschichholz (1):
      gtk: Annotate GtkFlowBoxCreateWidgetFunc as "transfer full"

Rui Matos (2):
      gtkwindow: Don't allow unresizable windows to be smaller than required
      wayland: Leave existing mods on map_virtual_modifiers

Sebastien Bacher (1):
      gtkplacessidebar: don't margins in the code

Stephen Chandler Paul (9):
      GdkDeviceTool: Add GdkDeviceToolType to identify the physical tool type
      GdkDeviceTool: Add GdkAxisFlags info to tablet tools
      gtk-demo: Use GdkAxisUse instead of axis labels
      gtk-demo: Add support for distance in event_axes
      gdkcursor-wayland.c: Minor indentation fix
      Wayland: Add initial support for drawing tablets
      Wayland: Implement proximity/crossing/motion event emission on tablets
      Wayland: Translate tool axes in motion events
      Wayland: Translate wl_tablet.down/up into button events

Sébastien Wilmet (15):
      docs: trivial fixes in GtkApplication-related documentation
      app: fix indentation
      app: avoid code duplication for setting accels
      app: improve doc of gtk_application_set_accels_for_action()
      app: improve doc of gtk_application_get_window_by_id()
      app: don't use deprecated function
      app: use g_set_object()
      app: improve code of extract_accels_from_menu()
      app: minor code improvements
      app: add missing g_returns
      app: write higher-level gtk_application_accels static functions
      app: extract GtkApplicationAccels private class
      app-accels: rename static functions
      app: share function to normalise detailed action name
      app: replace private accels functions by get_application_accels()

Theppitak Karoonboonyanan (1):
      Updated Thai translation.

Timm Bäder (7):
      gtkapplication: _get_app_menu can return NULL
      widget: Always warn when underallocating widgets
      headerbar: Don't underallocate the label box
      gtkcssimagebuiltin: Save/restore around cairo_clip
      listbox: Make sure page down/up move at least one row
      GtkLabel: Don't manually iterate over link list
      GtkLabel: Use g_clear_object

Tom Tryfonidis (1):
      Updated Greek translation     (cherry picked from commit 40afffb9fde9f2fc46d1fafd9dcdca7692e065ef)

Wolfgang Stöggl (2):
      Updated German translation     (cherry picked from commit c08f4bd2a93e779158ed221c7ea75a9df8ffd35f)
      Updated German translation     (cherry picked from commit 5e5372ce74cfd06498dee1938f0249d1039ede16)

Wouter Verhelst (1):
      Clarify that one cannot use the same variable

YunQiang Su (2):
      update zh_CN translation
      update zh_CN translation

Zahari Yurukov (1):
      Updated Bulgarian translation

Руслан Ижбулатов (15):
      GDK W32: Print more debug info about events
      GDK W32: Print error code along with the error message
      GDK W32: Optimize clipboard handling a bit
      GDK W32: Implement show_window_menu()
      GDK W32: Erase hidden layered windows before showing them
      GDK W32: Re-implement AeroSnap for CSD windows
      GDK W32: Improve AeroSnap - don't resize windows that fit
      GDK W32: Add drag-to-snap feature to AeroSnap
      GDK W32: Draw snap indicators for AeroSnap
      GDK W32: Add/subtract shadow when drag-resizing
      GDK W32: Add/subtract shadow when (un)snapping
      GDK W32: Use a dumb window class for decorative windows
      GDK W32: Don't move windows into top-left corner on style change
      GDK W32: Deduplicate reparenting
      gtk-builder-tool: use g_printf() instead of g_print()


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]