[libsigcplusplus] Created tag 2.99.6



The unsigned tag '2.99.6' was created.

Tagger: Murray Cumming <murrayc murrayc com>
Date: Wed Apr 27 13:59:02 2016 +0200

    2.99.6

Changes since the last tag '2.99.5':

Marcin Kolny (1):
      slot: use pointer for functor_ member

Murray Cumming (92):
      slot_rep: Make =deleted operations public.
      signal_exec: =delete copy and move operations.
      slot_rep::notify(): Rearrange a comment.
      with_type/with_type_pointer: Use is_base_of_or_same_v<> in declaration.
      limit_derived_type: Move with_type and with_type_pointer into class.
      limit_derived_target: Add some comments.
      Remove now-irrelevant comment.
      visit_each_type(): Remove unnecessary intermediate alias.
      test_functor_trait: Rearange to make tests self-contained.
      Remove now-irrelevant comments.
      test_functor_trait: Rename to test_visit_each_type.
      visit_each_type(): Add comment about how it is used.
      signal_emit: Make call_type private and remove iterator_type.
      Add a comment.
      visit_each_type: More comments.
      Remove now-irrelevant comment.
      limit_derived_target(): Remove the specialization for pointer types.
      Rename visit_each_type<T_Type>() to visit_each_trackable().
      limit_derived_target<T_Target>: Rename to limit_trackable_target<>.
      Update comment.
      test_visit_each_type: Rename to test_visit_each_trackable.
      self_and_iter: Take the iterator by const ref and store it as const.
      visit_each: Prototype trackable as struct, not class.
      Correct some comments.
      limit_trackable_target: =delete copy/move operations.
      Replace some reinterpret_cast<>s with static_casts<>.
      Minor uses of auto.
      concepts: bind: Use the origin::Copy_constructible C++ concept.
      Always use typename rather than class for template types.
      Revert "Always use typename rather than class for template types."
      Use typename instead of class for all template parameters.
      Header guards: Remove leading underscores (and trailing underscores).
      Remove _A_ prefixes from method arguments.
      signal: Remove __ prefix on tmp variables.
      signal: Rename list_ to sig_impl_.
      Revert "concepts: bind: Use the origin::Copy_constructible C++ concept."
      tuple_transform_each: Don't use typename for a template template parameter.
      Update copyright years.
      tests: Add missing copyright headers.
      Remove unnecessary -*- c++ - *-* comments.
      tests: Move copyright headers to top.
      Added missing copyright headers.
      Remove another unecessary c++ marker comment.
      Correct a doxygen comment.
      Correct some doxygen comments for variadic parameters.
      Add original benchmark code.
      benchmark: Update for the newer libsigc++ API.
      benchmark: Add copyright header.
      benchmark: Rearrange.
      benchmark: Make the 1000 a constant, so we can change it.
      benchmark: Increase count.
      benchmark: Use the newer syntax.
      benchmark: Use boost::timer instead of Glib::Timer.
      Update tests/.gitignore
      slot_rep: Add and use unset_parent().
      signal_impl::insert(): Rename a variable for clarity.
      signal_base: Make notify() private.
      signal_base: Rename notify() to notify_self_and_iter().
      signal_base::insert(): Add and use help method to avoid copy/pasting.
      signal: connect(), insert(): Remove unnecessary static_cast<>s.
      signal: Remove emit_reverse().
      signal: Remove slots().
      Remove now-unused slot_reverse_iterator_buf.
      signal: Rename iterator to connection.
      signal: Remove public emitter_type alias.
      Remove unused const_*_iterator.
      slot_list: Remove this now-unused class.
      signal::connect(): Return a sigc::connection.
      connection: Take the slot_base directly, without the intermediate slot_iterator.
      connection: Make notify() private.
      connection: Rename notify() for clarity.
      signal_emit: Remove some public type aliases.
      signal_emit: Make a_ private.
      Fixed missing newline in doxygen comment.
      Use temp_slot_list as const.
      test_accum_iter: Use of decltype(auto).
      signal_impl: Rename notify_self_and_iter_invalidated().
      slot_rep: Rename notify() for clarity.
      test_size: Add comments with the results, so we can notice changes.
      typed_slot_rep: Make constructor explicit.
      temp_slot_list: Make constructor explicit.
      signal_emit: Make constructor explicit.
      Connection: Constructor: Take slot_base as reference.
      limit_reference: Make constructor explicit.
      limit_refernce: =default copy/move operations.
      tests: Make single argument constructors explicit.
      test_disconnect: Add comment to explain potential leak.
      signal_impl: Trying to do the ref-counting with std::shared_ptr.
      signal_exec: Rename to signal_exec_holder.
      signal_impl_holder: Split into this and signal_exec_holder.
      copy operations: Name all parameters src.
      2.99.6


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]