[libgames-support] Created tag 0.1



The unsigned tag '0.1' was created.

Tagger: Michael Catanzaro <mcatanzaro gnome org>
Date: Mon Sep 21 19:12:19 2015 -0500

    libgames-support 0.1

Changes:

Anders Jonsson (1):
      Added Swedish translation

Andika Triwidada (1):
      Added Indonesian translation

Balázs Úr (3):
      Added hu entry
      Initial Hungarian translation
      Updated Hungarian translation

Cheng-Chia Tseng (1):
      Added Chinese (Taiwan) translation

Christian Kirbach (1):
      Added German translation

Daniel Mustieles (2):
      Updated Spanish Translation
      Updated Spanish translation

Dušan Kazik (2):
      Added Slovak translation
      Updated Slovak translation

Enrico Nicoletto (1):
      Added Brazilian Portuguese translation

Iulian Radu (3):
      Make the scores dialog look good when no scores are present
      Even out spacing between columns in the high scores dialog.
      scores: make get_best_n_scores public

Josef Andersson (1):
      Updated Swedish translation

Juan R. García Blanco (2):
      Load scores in has_scores()
      scores: store scores in dedicated subfolder

Marek Černocký (3):
      Czech translation
      Added the Czech language
      Updated Czech translation

Maria Savidi (1):
      Added Greek translation

Matej Urbančič (3):
      Added Slovenian translation
      Added sl for Slovenian translation
      Updated Slovenian translation

Michael Catanzaro (112):
      Initial commit
      Add pkg-config support
      Restore ability to save player names
      Handle unknown result of g_get_real_name()
      Do not distribute games-scores-backend.h
      Do not use GtkStock
      Add access key for New Game button
      Remove games_scores_backend_startup()
      Remove a couple obsolete FIXME comments
      Fix games_scores_backend_new()
      Set a name for the one GSource we create
      trivial: use G_SOURCE_REMOVE instead of FALSE
      Fix import of scores from 3.12 C games
      Add a README
      Add TODO file
      Start the version number at 0.1
      Update TODO
      Remove dead assignment
      Silence spurious static analyzer warning
      Update TODO
      Vala
      Make main runnable
      Fix pkg-config cflags
      Rename scores.vala to context.vala
      Fix configure
      Run dialog in Context.run_dialog()
      Make the stack members appear
      Update TODO
      Update TODO
      Update TODO
      Update libgames-scores.pc.in
      Update TODO
      Update README
      Update TODO
      Update TODO
      Relicense to LGPLv3+
      Update doap
      Update doap
      Update TODO
      Dialog: visual improvements
      Update TODO
      Update doap to libgames-support.doap
      Fix halign of grid on scores dialog
      Rename the library and reorganize the repository
      Update git.mk
      Remove unused/forgotten makefile
      scores: add Context.has_scores()
      scores: warn when a dialog is created without any scores
      Update README
      scores: Rename Dialog.scores -> Dialog.context
      scores: rename Dialog.scores_latest_score -> Dialog.latest_score
      scores: Replace Context.high_score_added with DialogMode
      scores: Remove unused Context.score_added
      Fix whitespace error
      scores: Rename a local variable
      scores: update score when entry text changes
      scores: Reorder parameters of Context.update_score_name()
      scores: Remove short-lived DialogMode and Context.latest_score
      Update POTFILES.in and POTFILES.skip
      scores: Add precondition for run_dialog_internal()
      scores: Save scores after running the dialog
      scores: load scores from file when creating the Context
      scores: rearrange context.vala
      scores: Context: add warning about sync I/O
      scores: move a comment to a better spot
      Add a FIXME
      Add another FIXME
      scores: warn if the game does not connect to Context.request_category()
      scores: Rename Context.request_category() to Context.category_request()
      Remove an old FIXME
      Remove TODO
      scores: Add and use Context.load_scores_if_needed
      Add coding style checker
      Stop using gnome-common
      configure.ac: quote more things
      configure.ac: don't use AC_CONFIG_SRCDIR
      configure.ac: Simplify a bit more
      Add API version to pkg-config file
      Move code to games subdirectory
      Move tests to a subdirectory
      configure.ac: Consistent indentation
      Make some usage errors fatal
      Fix typo
      Add the API version to the vapi
      Rename .vapi and header file to match the new .pc name
      Add Games.GridFrame
      Add workaround to fix Continuous
      Center the "no scores yet" box
      Minor style tweak
      scores: get_best_n_scores should call load_scores_if_needed
      Fix some crashes in the style checker
      scores: Replace category-request signal with a delegate
      Run the style checker through pep8 style checker
      Avoid warning about copying delegates
      Load scores in the constructor, instead of lazily
      Rename possibly confusing variable
      Fix typo in style checker
      Make add_scores an async API
      Remove error API from run_dialog
      style-checker: missing space before ( in string template is OK
      Update tests for async add_score
      Simplify load_scores_from_files a bit
      Simplify add_score a bit
      Simplify scores directory creation code
      Get rid of blocking I/O in save_score_to_file
      Add optional cancellable parameter to add_score
      Fix paretheses mistake in the style checker
      Split load_scores_from_file from load_scores_from_files
      Add myself as a copyright owner of context.vala
      Remove API guarantee from readme
      Prepare 0.1
      Stop running the tests

Necdet Yücel (1):
      Added Turkish translation

Nikhar (3):
      Update TODO
      Update TODO
      Update TODO

Nikhar Agrawal (72):
      Removed games-score.h from the public interface
      Add missing file.
      Moved most functions from games-scores.h to games-scores-private.
      Fixups for the previous commit
      Prefixed function definitions of functions in private header with underscore.
      Merged games-scores-backend with games-scores.
      Revert "Merged games-scores-backend with games-scores."
      Truly merged games-scores-backend with games-scores.
      Remove GamesScoresCategoryInternal
      Add scores and read and save scores to disk.
      Cleaned up version of last commit.
      Data now written to disc when Scores object goes out of scope.
      Removed compiler errors.
      Saving and loading from disc throws errors.
      The time member of Score Class is now of time int64.
      Scores are now appended to file rather than overwritten.
      Added a method to get best n scores per category.
      Renamed class from Scores to Context.
      Added changes based on comments on last commits.
      Added test cases.
      Removed extra \n.
      Delete whole directory in delete_scores function instead of just categries.
      Commit to save progress. Very unclean. DO NOT USE.
      Fixed the error with test cases.
      Changed the location of save directory.
      Very minor commit. Uncommented a line.
      Added combobox. Style improvements.
      Display top 10 scores per category.
      Added label, removed time from dialog.
      Dialog opens with category to which latest score's added.
      Added a function to check if the newest score is high score.
      Players can change their name while adding a high score.
      Added Window object to Context constructor.
      Now uses grid of labels to display scores.
      Improved spacing and margins.
      Signals. First draft.
      Better spacing in dialog.
      Replaced labels with stacks.
      Allows player to edit names on high scores.
      A possible crash fix.
      Converted Category struct to Category class.
      Only display label instead of combo box on adding high score.
      Scores with changed names now saved to files.
      Set header title and subtitle on high score.
      Only one dialog displayed now.
      Added support for importing scores from C games.
      Horizontally center the game type above the list of high scores.
      Merge branch 'master' of https://github.com/Catanzaro/libgames-scores
      Reduced row spacing.
      Merge branch 'master' of https://github.com/Catanzaro/libgames-scores
      Made column headers bold.
      Added signals to retrieve names from games.
      Ignore non score files from ~/.local/share/game_name.
      Centered label and combobox.
      Merge branch 'master' of https://github.com/Catanzaro/libgames-scores
      Cleaner code with better styling.
      Added done button.
      Used suggested-action style class.
      Removed tabs.
      Style improvements. Part - 1
      Merge branch 'master' of https://github.com/Catanzaro/libgames-scores
      Stylistic improvements. Part 2.
      Style improvements. Part 3.
      Style Improvements. Part 4.
      Style improvements. Part 5.
      Style improvements. Part 6.
      Style improvements. Part 7.
      Style improvements. Part 8.
      Conditionally run dialog on adding score.
      Merge branch 'master' of https://github.com/Catanzaro/libgames-scores
      Fixed warnings.
      Scores are now loading again.

Piotr Drąg (2):
      Added Polish translation
      Updated Polish translation

Sahil Sareen (2):
      Fix style checker to work with the *all* flag
      Fix false positive detected by style checker

Yanko Kaneti (1):
      build: Do not explicitly dist files already handled by autotools

Yosef Or Boczko (1):
      Added Hebrew translation

Мирослав Николић (1):
      Added Serbian translation


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]