[meld] Created tag 3.15.0



The unsigned tag '3.15.0' was created.

Tagger: Kai Willadsen <kai willadsen gmail com>
Date: Mon Oct 5 12:38:47 2015 +1000

    2015-10-05 meld 3.15.0
    ======================
    
      Features:
    
       * New API for version control plugins with more consistent interfaces and
         data structures across different plugins, enabling many minor
         improvements (Kai Willadsen)
         * Support the conflict resolution prompt in file comparisons for all VCs
         * Improve caching behaviour for some version control plugins
         * Better sensitivity handling for version control actions
         * Cache and show more metadata (e.g., file renames)
         * Several version control plugins have not been ported to the new API; the
           current list of support plugins is: Git, Mercurial, Subversion 1.7+,
           Bazaar
       * Faster rendering in file comparison view, enabled by new GtkTextView API
         (Kai Willadsen)
       * Move to using GtkSourceView style schemes with Meld-specific colour tags
         for highlight colours; this lets themes include colours that match the
         sourceview theme (Kai Willadsen)
       * Offer to open binary files externally (Pratik Dayama)
       * Show the common ancestor in conflicting regions (and the merged file
         everywhere else) when viewing conflicts through Meld's version control
         view; currently this is only supported under Git (Kai Willadsen)
       * Support showing staged/partially staged status of files under Git (Kai
         Willadsen)
       * Update preferences dialog to new style with headerbar (Kai Willadsen)
    
      Fixes:
    
       * Documentation updates (Andrew Beyer)
       * Fix crash with some GTK+ versions when using --output (Kai Willadsen)
       * Fix merge-all action not working at all (Kai Willadsen)
       * Fix creating patches with unicode path names (Kai Willadsen)
       * Fix copy-to-clipboard option in patch dialog (Kai Willadsen)
       * Fix diffmap alignment for new GTK+ allocation behaviour (Kai Willadsen)
       * Improve float accuracy in folder comparison timestamp resolution (Kai
         Willadsen)
       * Fix default SVN keyword filter to escape $ characters (Kai Willadsen)
       * Fix display of unicode --help from command line (Kai Willadsen)
       * Fix keyboard shortcut docs (Kai Willadsen)
       * Don't incorrectly show identical notification for changed folder
         comparisons (Kai Willadsen)
    
      Internal changes:
    
       * Requirements are now GTK+ 3.14, GtkSourceView 3.14 and GLib 2.36
       * Rewritten version control plugin API
       * Unified colour handling between linkmap, diffmap and file comparison
       * Move all textview drawing to a new GtkSourceView subclass, using the new
         GTK+ draw-layer API
    
      Translations:
    
       * Daniel Mustieles (es)
       * Gábor Kelemen (hu)
       * Jiri Grönroos (fi)
       * Josef Andersson (sv)
       * Marek Černocký (cs)
       * Piotr Drąg (pl)

Changes since the last tag '3.14.0':

Andrew Beyer (2):
      Update dependency versions in README
      Fix markdown escaping in README

Daniel Mustieles (2):
      Updated Spanish translation
      Updated Spanish translation

Gábor Kelemen (1):
      Updated Hungarian translation

Jiri Grönroos (1):
      Finnish translation update

Josef Andersson (2):
      Add Swedish help translation
      Updated Swedish translation

Kai Willadsen (209):
      meld.vc: Remove support for unmaintained VCs
      meld.vc: Make Subversion 1.7 and later the only supported versions
      meld.vc: Remove dead plugins from list
      meld.vc: All remaining VCs are 'cached', for what it's worth
      meld.vc: Format all the copyright headers format
      meld.vc: Get rid of the revision column, and rename "options"
      meld.vc.svn: Use new resolve API, and non-deprecated command
      meld.vc: Remove old-style resolved API
      meld.vc._vc: Remove revision from Entry objects
      meld.vc._vc: Simplify our Entry classes
      meld.vc._vc: Remove unused method
      meld.vc._vc: Simplify caching
      vc.svn: Enshorten the repo version detection code
      vc: _lookup_tree_cache is poorly named
      meld.vc._vc: Fix tree cache for some per-VC wrangling
      meld.vc: Fix caching API to disallow inadventantly discarding data
      meld.vc: Remove unused directory argument from _get_tree_cache
      meld.vc.bzr: Fix file gathering for new cache behaviour
      meld.vc.bzr: Adapt bzr to follow the same caching pattern as other VCs
      meld.vc: Pull out common cache_tree implementations
      meld.vc._vc: Pull cache_tree into its only access
      meld.vc: Make _tree_cache always be a dict
      meld.vc: Remove cache selection argument to cache updating
      meld.vc: Factor out common individual-path updating
      vcview: There's no reason to prime the cache; the VC will sort it out
      vc.bzr: Re-fix files-to-commit gathering
      vc.bzr: Don't populate the cache when committing
      meld.vc: Add the metadata cache for tree states everywhere
      vc: Add common _get_dirsandfiles implementation for generalisation
      vc._vc: listdir always takes a path
      vc.svn: Minimal adaptation of SVN to use saner tree cache format
      vc.svn: Make subversion use the commit _get_dirsandfiles version
      vc: Rename parameter for a marginally better indication of its use
      vc.svn: Root-walking is the default
      vc._vc: Use 'meta' information for folders and removed entries as well
      vc.bzr: Migrate to the common _get_dirsandfiles method
      vc._vc: Tidy up Entry creation slightly
      meld.vc: Remove Dir and File subclasses, and use Entry everywhere
      vc._vc: Comment additions
      vc._vc: PEP8
      vc._null: Use a less hacky implementation of a no-op tree cache
      vc._null: Update copyright
      vc.git: Fix bare except
      vc.git: Add run() as a per-repo subprocess helper
      vc.git: Improve some comments
      vc: Make all VCs show all columns, since there's only one extra
      vcview: Unindent some logic
      vcview, ui.vcdialogs: Move all VC command handling to vcview
      vc._vc: Make lookup_files require its directory argument
      vc._vc: Further simplify lookup_files
      vc._vc: Merge _get_dirsandfiles into lookup_files
      vcview: Use the newer get_entry API for individual file updating
      vc._vc: Use Gio for looking up files, and simplify lookup_files logic
      vc._vc: Pass off GFile and infos instead of derived data
      vc._vc: Concatenate meta information in the Entry
      vc._vc: Move necessary Entry creation logic into get_entry
      vc._vc: Update docstring for get_entry
      vcview: Expand top-level as the last thing we do for flattened views
      vc._vc: Absorb lookup_files into listdir
      vc._vc: Fix removed entry replacement for entry creation changes
      vc._vc: Rename listdir to get_entries and make it an iterator
      vc._vc: Require an explicit VC status refresh
      vc._vc: Unify the file and directory state updating
      vcview: Make _update_item_state do its own relative path calculations
      vc._vc: Handle both missing and deleted folders in traversal
      vcview: Move some CellRenderer creation into the UI file
      vcview: Get rid of the VCS changing lock, and rely on model sanity
      vcview: Tidy up the VC population logic slightly
      vcview, vc._null: Make sure VCs always have a name
      vcview: Refactor our handling around missing VCs
      vcview: Generate valid_vcs after the fact
      vcview: Refactor the current-active and VC maintaining logic
      vcview: Use the model as the main reference point
      vcview: Group code for clarity and remove overly explanatory comment
      tree: Python-ify the treeview search callback string handling
      tree: PEP8 fix
      vc: Add new-style commit API and use in git
      vc: Update other version control systems to new commit API
      vcview: Unsupport the now-unused commit_command API
      vcview: Fix required args list for commit when doing sensitivity check
      vc: Make update() not take files, and update svn and hg to new API
      vc: Update bzr and hg for new-style add() command
      vc: Update svn and hg for new-style add() command, remove old one
      vc: Update svn and hg for new-style revert() command, remove old one
      vc._vc: Add filter helpers to Entry, for future use in vcview
      vcview: Set up selection mode in the UI file
      vcview: Move most treeview column setup in to UI file
      vcview: Move remaining cell renderer creation to UI file
      vcview: Remove unused method
      vcview: Remove unused import
      vc: Move path state sensitivity checking to _vc and improve the API
      vcview: Refactor sensitivity setting for new valid actions API
      vcview: Remove valid_vc_actions, since it's now obsolete
      vcview: Remove unused action mapping
      vcview: Make cross-tab command helper actually return if we error out
      vc._vc, vcview: Fix cross-tab command API presence checks
      vcview: No need to set headers visible; they are by default
      vcview: Absorb local variable assignment
      vcview: Some minor correctness fixes for treeview context menu display
      vcview: Deprecation fix
      vcview: Use binding for location visibility and consolidate callbacks
      vcview: Comment clean
      vc.svn: Fix cwd usage in subversion
      vc.svn: Fix the only _command usage without a working directory
      vcview: Command helpers now require refresh and working_dir
      vcview: Remove logic for non-specified working directory
      vcview: Don't yield the command message, as it's never displayed
      vc: Make the working directory always be whatever we're given
      vcview: Use standard relative path calculations
      misc: Make read_pipe_iter require a working directory as well
      misc, vcview: Tidy up our iterable pipe handling slightly
      vcview: Improve some docstring
      vcview: Rename command scheduler to runner and add docstring
      misc, vcview, ui.vcdialogs: Remove custom common-prefix implementation
      vcview: Get rid of unnecessary column_index use
      vcview: Handle early refreshes caused by setting filters at bind time
      vcview: Consolidate filter handling code to use object property
      vcview, vc._vc: Move Entry filtering logic to a more suitable place
      vcview: PEP8
      vcview: Update imports, removing explicit relative imports
      vcview: Make it clearer that these are either/or cases
      vcview: Always expand the top directory
      vcview, vc: Update copyright headers
      Merge branch 'master' into VersionControlRework
      vcview: Remove unused variable
      vcview: Fix bad merge
      Post-release version bump
      Merge branch 'VersionControlRework'
      sourceview: Move all textview chunk drawing into MeldSourceView
      sourceview: Handle sourceview-specific colours in sourceview
      filediff: Refactor chunk animations slightly
      sourceview: Make MeldSourceView responsible for its own colours
      sourceview: Move current line highlighting logic from FileDiff
      sourceview: Add some comments for different drawing parts
      sourceview: Move fading highlight animation out of FileDiff
      misc: Factor out common colour loading for re-use in sourceview
      diffmap: Have DiffMap do its own colour lookup and handling
      linkmap: Make LinkMap do its own colour handling
      diffmap, linkmap: Fix style initialisation
      filediff: Remove unused variables
      sourceview: Move MeldBuffer creation and styling from FileDiff
      filediff: Reorder some initialization for clarity
      filediff: Remove unused imports
      filediff: Move font and line-height logic out to LinkMap and SourceView
      filediff: Minor reformatting
      filediff: Add decorator for functions requiring the current pane
      filediff: Use new focused pane decorator elsewhere
      sourceview: Support draw_layer
      filediff: Remove remnant comment
      sourceview: Update drawing to use cairo clip extents for bounds
      sourceview: Refactor some variable ordering
      gutterrendererchunk: Add cell background drawing for gutter chunk
      patchdialog: Use a plain GtkSourceView
      bin/meld: Remove CSS hacks
      meld.css: Fix minor CSS linter errors
      meld: Migrate from CSS to GtkSourceView style schemes
      data/styles: Fix tag for syncpoint
      misc: Make theme lookup fall back to default theme for missing colours
      Update CSS colour locations to handle style scheme changes instead
      linkmap: Re-remove line height calculations reintroduced by a bad merge
      data/styles: Added new dark style and removed existing dark CSS
      bin/meld: Remove dark CSS handling
      linkmap, sourceview: Fix some minor alignment issues
      linkmap: Fix off-by-one rendering when getting chunk-end lines
      linkmap: Fix clipping calculations for offset textviews
      linkmap: Stop rendering frame that doesn't work
      dirdiff: Remove style handling, as diffmap does this itself now
      dirdiff, tree: Give tree styles colours from the sourceview theme
      tree: PEP8
      tree: Update copyright years
      gutterrendererchunk: Fix highlight drawing for the current chunk
      data/ui/findbar.ui: Remove deprecated xalign properties
      data/ui: Replace deprecated margin-left and margin-right properties
      gutterrendererchunk: Initial Meld-specific line number renderer
      gutterrendererchunk: Factor out some common drawing
      gutterendererchunk: Minor refactoring for drawing logic
      gutterrendererchunk: Don't stroke non-existent outlines
      gutterendererchunk: Move settings handling to MeldGutterRenderer
      linkmap: Fix bad endpoints for insertion/deletion chunks
      filediff, sourceview: Override SourceView line number handling
      bin/meld: Hack the style to give LinkMaps GtkTextView's background
      Bump version requirements
      filediff: Fix incorrect signature for merge-all callback (bgo#753097)
      dirdiff: Clear out message areas on refresh (bgo#752936)
      vcview: Sort VC entries in the traditional order
      vcview: Fix colour use with new sourceview-theme-derived colours
      setup.py: Remove installation of obsolete theme CSS
      vc.svn: Only commit selected files (bgo#753368)
      gschema: Fix regex escaping for SVN keyword filter
      setup.py: Add sourceview styles to install (bgo#753358)
      dirdiff: Improve float accuracy in timestamp resolution (bgo#753753)
      setup.py: Make executable, and specify that we want python 2
      meldapp: Monkey-patch optparse's gettext alias for ugettext compat
      help: Fix keyboard shortcut docs
      diffmap: Fix scrollbar-alignment code for new GTK+ allocation behaviour
      diffmap: Use newer, more pythonic style property access
      diffmap: PEP8
      diffmap: Fix thinko with secondary steppers and offset calculations
      patchdialog: Hack around difflib not handling unicode file labels
      patchdialog: Fix copy-to-clipboard for pygobject port
      vc.git: Support showing (partially) staged status of files (bgo#755112)
      vcview: Delay refresh until outside of the scheduler task (bgo#753952)
      vc.svn: Fix for Subversion 1.8 repo detection
      preferences.ui: Update preferences dialog to new style with headerbar
      vc: Add support for showing BASE in Git conflicts
      vc.git: Split remerging logic out for reuse
      vc.git: Use new run helper
      vc.git: Add docstring explaining the idea of the diff3 re-merge
      Update NEWS

Marek Černocký (1):
      Updated Czech translation

Piotr Drąg (5):
      Updated POTFILES.in
      Updated Polish translation
      Updated Polish translation
      Updated Polish translation
      Updated Polish translation

Pratik Dayama (1):
      filediff: Offer to open binary files externally (bgo#665154)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]