[metacity/wip/gtk-theme: 12/52] theme: Rename button_rect() to get_button_rect()



commit 45be6b50c9accdccec8001c845e1dff9970ec474
Author: Florian Müllner <fmuellner gnome org>
Date:   Sat Sep 27 23:44:41 2014 +0200

    theme: Rename button_rect() to get_button_rect()
    
    Basically it's odd to have "button_rect" be a function with all the
    foo_rect GdkRectangles around - renaming to get_button_rect() will
    free the name for the generically named "rect" once buttons are the
    only movable pieces in the frame.
    
    https://bugzilla.gnome.org/show_bug.cgi?id=741917

 src/ui/theme.c |   10 +++++-----
 1 files changed, 5 insertions(+), 5 deletions(-)
---
diff --git a/src/ui/theme.c b/src/ui/theme.c
index a1dbc8c..3fff8db 100644
--- a/src/ui/theme.c
+++ b/src/ui/theme.c
@@ -4514,10 +4514,10 @@ meta_frame_style_validate (MetaFrameStyle    *style,
 }
 
 static void
-button_rect (MetaButtonType           type,
-             const MetaFrameGeometry *fgeom,
-             int                      middle_background_offset,
-             GdkRectangle            *rect)
+get_button_rect (MetaButtonType           type,
+                 const MetaFrameGeometry *fgeom,
+                 int                      middle_background_offset,
+                 GdkRectangle            *rect)
 {
   switch (type)
     {
@@ -4792,7 +4792,7 @@ meta_frame_style_draw_with_style (MetaFrameStyle          *style,
             {
               MetaButtonState button_state;
 
-              button_rect (j, fgeom, middle_bg_offset, &rect);
+              get_button_rect (j, fgeom, middle_bg_offset, &rect);
 
               button_state = map_button_state (j, fgeom, middle_bg_offset, button_states);
               op_list = get_button (style, j, button_state);


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]