[gtk+] Created tag 3.19.4



The unsigned tag '3.19.4' was created.

Tagger: Matthias Clasen <mclasen redhat com>
Date: Fri Dec 4 17:20:23 2015 -0500

    3.19.4

Changes since the last tag '3.19.3':

Benjamin Otte (56):
      iconhelper: Remove unused context argument
      iconhelper: Remove unused function
      iconhelper: Don't include gtk.h
      dnd: Remove unused struct members
      dnd: Just pass iconhelper instead of whole DragSourceSite
      dnd: Split GtkDragSourceSite into its own file
      window: Don't lose position information
      gtkwindow: fix regression with firefox dropdown menu
      wayland: Remove unused variable
      Revert "gdk_pixbuf_get_from_window: honor device scale"
      window: Remove suspicious branch
      imagedefinition: Split out from icon helper
      dragsource: Store an itemdefinition, not an iconhelper
      image: queue_resize() after changing icon-size property
      iconhelper: Move size computation
      iconhelper: Improve size determination for surfaces
      iconhelper: Move invalidation check
      dnd: Use surface for dnd icon instead of pixbuf
      iconhelper: Move invalidation check
      iconhelper: Don't store surface size
      iconhelper: Store surface in ensure_surface()
      iconhelper: Refactor ensure_surface()
      iconhelper: Add a scale argument to gtk_icon_helper_load_surface()
      entry: Use gtk_icon_helper_load_surface()
      dnd: Rewrite iconhelper code
      imagedefinition: Remove icon-size
      dnd: Add gtk_drag_set_icon_definition()
      statusicon: Use gtk_icon_helper_load_surface()
      iconhelper: Remove _gtk_icon_helper_ensure_pixbuf()
      iconfactory: Make state depend on image-effect
      iconhelper: Stop tracking state
      Stop using gtk_icon_size_lookup_for_settings()
      css: Rename -gtk-image-effect to -gtk-icon-effect
      stylecontext: Don't emit state warning for transient nodes
      spinner: Active spinners should be :checked, not :active
      css: Query icon theme from style, not from settings
      window: Listen to icon theme changes on CSS
      css: Add ability to specify icontheme in CSS
      Chain up in state_flags_changed
      widget: Don't update pango context in state_flags_changed
      image: Split out a function
      image: Remove unused code
      dnd: No need to reset the icon
      dnd: Add gtk_image_set_from_definition()
      css: Introduct -gtk-icon-palette
      window: Deprecate gtk_window_resize_to_geometry()
      tests: Rework some foreigndrawing code
      iconfactory: Drop caching infrastructure
      iconhelper: Fold function into only caller
      iconhelper: Refactor missing icon handling
      iconhelper: Return surface from icon-effect function
      render: Split out icon-effect apply function
      css: Leftover renaming gtk-image-effect => icon-effect
      iconhelper: Apply icon-effect directly
      iconhelper: Fold function into callers
      reftests: Add test for missing-image handling

Carlos Garnacho (8):
      wayland: Plug surface leak
      device: Fix dispose
      wayland: Do not store the grab cursor separately
      wayland: remove embarrassing g_print()s
      GtkWindow: Reset gestures after triggering right click titlebar action
      wayland: Refactor selection ownership
      wayland: Store requested target on GdkWaylandSelection
      wayland: Invert drop_finished/button release call order

Christian Hergert (1):
      filechooserbutton: add some spacing between icon and text

Christoph Reiter (1):
      dnd-quartz: fix missing icon helper include

Daniel Mustieles (2):
      Updated Spanish translation
      Updated Spanish translation

Emmanuele Bassi (1):
      scalebutton: Annotate the return type

Florian Müllner (1):
      listbox: Use :focus-on-click policy from row instead of list

Jonas Ådahl (2):
      wayland: Use pointer gestures protocol from wayland-protocols
      wayland: Use xdg shell protocol from wayland-protocols

Krzesimir Nowak (2):
      cssprovider: Pass NULL unconditionally
      imagedefinition: Assert when trying to free empty definition

Lapo Calamandrei (12):
      Adwaita: vertically linked insensitive entries
      Adwaita: button.color fix
      Adwaita: first stab at GtkScale and GtkProgressBar rewrite
      Adwaita: added back style for scales on selected list rows
      Adwaita: rename scale sass templates to be more specific
      Adwaita: scale fill style
      Adwaita: added back scale marks style
      Adwaita: scale with marks styling
      Adwaita: some OSD rationalization
      Adwaita: slight color tweaks
      Adwaita: fix scales with marks on the dark variant
      Adwaita: added back progressbar.osd style

Lionel Landwerlin (2):
      gdkoffscreenwindow: use embedder to derive surfaces & scale factor
      adwaita: fix property spelling mistake

Matthias Clasen (33):
      Add a test for deprecated css properties
      dialog: Use an element name
      Adwaita: No background for spinners
      stack: Update windows before allocating children
      testentryicons: Use an existing icon name
      testentryicons: update dnd example
      window: Use g_set_object
      inspector: Show the size request mode
      popover: Make it possible to constrain to toplevel
      Add gdk_drag_context_get_drag_window
      dnd: Fix issues with drag icons under Wayland
      DND: Drop support for using rgba cursors as icons
      dnd: Prevent black background in icons
      Drop gdk_wayland_drag_context_get_dnd_window
      dnd: Some simplifications
      dnd: Drop an unused argument
      popover: Port to g_object_install_properties
      popover: Make position property not CONSTRUCT
      Add an example of foreign drawing
      Add another hand-drawn scrollbar
      Make foreign drawing example work
      Add a selected text example
      css: Add a :dnd pseudoclass
      Use :dnd pseudoclass for drag highlighting
      entry: Use regular drag highlight
      Simplify foreign drawing example a bit
      Update gtk_drag_highlight() docs
      shortcuts: Extend the accelerator syntax more
      Add a css name to GtkShortcutsShortcut
      shortcut label: Tweak modifier key rendering
      testsuite: Fix notify tests
      Fix make check
      3.19.4

Olivier Fourdan (5):
      wayland: re-configure surface even if size matches
      gtkwindow: remove headerbar after disposing parent
      gtkwindow: apply CSD in configure size request
      gtkwindow: Document further resize with csd
      wayland: fix testtooltips

Pedro Albuquerque (2):
      Updated Portuguese translation
      Updated Portuguese translation

Piotr Drąg (2):
      Updated POTFILES.in
      Updated Polish translation

Sebastien Bacher (1):
      GtkAppChooserWidget: wrap the label, use a standard icon

Sébastien Wilmet (1):
      textiter: fix bug in case insensitive backward search

Timm Bäder (21):
      GtkStack: Add some missing nullable annotations
      GtkWidget: Add some missing nullable annotations
      inspector: Leave unneeded widgets out of source files
      GtkPopover: Restore tails
      GtkScaleButton: _get_(plus|minus)_button returns a GtkButton
      icon-browser: baseline-align the icon size labels
      icon-browser: Use proper "times" character
      icon-browser: Stop using GtkMisc properties
      GtkWidget: Add some missing nullable annotations
      GtkBox: The center widget can be NULL
      Add some more missing nullable annotations
      GtkScale: Add missing nullable annotations
      GtkRange: Use G_MININT as default mouse position, not -1
      GtkRange: Remove recalc_marks field
      GtkRange: Return proper constants in signal handlers
      GtkEntry: Remove unused fields
      GtkEntry: Remove recompute idle
      GtkTreeModel: Remove erroneous transfer annotation
      GtkEntry: Return proper constants from signal handlers
      GtkEntry: nullable annotations
      GtkEntry: Recompute in text-inserted/text-deleted

William Hua (1):
      mir: remove deprecated function call

Руслан Ижбулатов (3):
      GDK W32: Don't use SetWindowLong() to set/unset WS_EX_TOPMOST
      GDK W32: Clarify the use of the second argument to SetWindowPos()
      GDK W32: Add a comment for clarity


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]