[gtk+] Created tag 3.15.0



The unsigned tag '3.15.0' was created.

Tagger: Matthias Clasen <mclasen redhat com>
Date: Wed Oct 22 01:22:00 2014 -0400

    3.15.0

Changes since the last tag '3.14.1':

Adel Gadllah (1):
      gdkglcontext-x11: Fix pixmap creation

Alexander Larsson (18):
      Add internal gdk_cairo_region_from_clip helper
      Change the way the update area is tracked during paint
      Add gdk_window_mark_paint_from_clip and call from widget drawing
      gdk: Add support for OpenGL
      Add GDK_ALWAYS_USE_GL debug hack
      wayland: Set GdkVisual::bits_per_rgb to 8
      wayland: Add OpenGL support
      Add GtkGLArea widget
      Add tests/testglarea
      Add tests/gdkgears
      Add tests/testglblending
      Add glarea demo to gtk3-demo
      gl: Make all user GdkGLContexts not attached to any window
      Fix warning
      X11 GdkGLContext: Remove spurious XSync
      gl: Make gdk_gl_context_make_current() return void
      X11: Fix crash in gdk_x11_gl_context_texture_from_surface
      x11 glcontext: Always use RGBA texture format, as we use alphas

Alexandre Franke (1):
      Updated French translation

Andika Triwidada (2):
      Updated Indonesian translation
      Updated Indonesian translation

Arash Mousavi (1):
      Updates Persian Translations

Bastien Nocera (2):
      gtkwidget: Fix typo in comment
      wayland: Don't try to create a subsurface again

Baurzhan Muftakhidinov (1):
      Updated Kazakh translation

Benjamin Otte (99):
      tests: Add a test for a performance optimisation
      image: Implement clipping support for icon-shadow
      css: Have finer-grained definitions for effects of CSS props
      css: Queue resize for properties that affect clip
      stylecontext: Split render functions out into gtkrender.[ch]
      themingengine: Move actual render functions to gtkrender.c
      themingengine: Stop using it
      themingengine: Call real API render functions
      sidebar: Fix gcc warning
      entrycompletion: Remove outdated code
      combobox: Don't set cell view background
      label: Simplify rendering code
      scrolledwindow: Remove unused variable
      scrolledwindow: Don't use LIGHTEN operator
      scrolledwindow: Rewrite overshoot code with regular styling
      theming: Use gtk_style_context_peek_property()
      print: Improve sheet drawing a bit
      stylecontext: Deprecate functions
      cellrendereraccel: Remove unused variables
      fontchooserwidget: Use text attributes for the preview
      stylecontext: Add missing docs for deprecations
      gtk-demo: Properly override font color in combobox example
      gtk-demo: Remove unneeded code
      gtk-demo: Improve flowbox demo code
      gtk-demo: Remove useless code in colorsel example
      gtk-demo: Replace old code
      imcontextxim: Remove broken custom drawing code
      libgail: Add deprecation guards
      docs: Add a man page fro gtk3-demo-application
      print: Add a .paper style class
      docs: Fix some copy/paste errors
      x11: Remove unneeded and wrong return_if_fail()
      gdk: Remove overeager checks
      x11: Remove overeager check
      gdk: Deprecate static gravities
      gdk: Fix gdk_cairo_create() without begin_paint()
      colorswatch: Simplify drawing code
      colorswatch: Render focus with gtk_render_focus()
      colorswatch: Remove an unused variable
      colorswatch: Render background properly
      render: Overhaul gtk_render_handle()
      render: Make rendering the background a single function
      themingbackground: Use an array instead of 3 separate members
      themingbackground: Don't store bg_color in struct
      themingbackground: Don't store (almost) unused variables
      themingbackground: Call shadow function directly
      themingbackground: Add a quick exit for default case
      themingbackground: Use fill() instead of clip() + paint()
      colorswatch: Draw the image overlay over the whole widget
      colorswatch: Use a better name for the overlay
      tests: Exit test when main window is closed
      render: Optimize the no-borders case to exit early
      shadows: Respect scaled factors for cached surface
      menu: Respect borders properly for scroll arrows
      colorswatch: Remove unneeded save/restore
      configure: Require glib 2.43
      gdk: Deprecate compositing support
      testgtk: Don't trigger deprecation warnings
      tests: Update testoverlaystyleclass test
      tests: Don't force black background in testwindows
      tests: Update testtooltips for deprecations
      tests: Update testexpand example for deprecations
      examples: Add deprecation guards
      viewport: Remove wrong save/restore
      progressbar: Make the trough the default element
      switch: Set PRELIGHT state on widget
      switch: Use trough style class by default
      inspector: Split out a function
      inspector: Add type column to statistics
      inspector: increase type by right amount
      inspector: Update all statistics in same place
      inspector: Make all statistics columns visible always
      inspector: Kepp tree iter in type data
      inspector: Add a GraphData object for recording data
      inspector: Add a graph cell renderer
      inspector: Replace reload with record
      inspector: Add missing files
      tests: Make gtkgears compile without complaints
      render: Fix uninitialized variables
      stylecontext: Factor out a function
      stylecontext: Don't cache the root values
      stylecontext: Move next pointer out of GtkStyleInfo
      stylecontext: Make save/restore create a child CSS node
      scrolledwindow: Don't set .frame on overshoot boxes
      gdk: Add GDK_DEBUG=nogl
      glarea: Display the error message when an error occurred
      spinbutton: Set the correct state on the button contexts
      stylecontext: Split out functionality into custom object
      stylecontext: Use node declaration in hash
      stylecontext: Don't copy CSS values on context_save()
      computedvalues: Add to_string() and print() functions
      stylecontext: Return a ref in lookup_values_for_state
      stylecontext: Handle querying the wrong state better
      render: We use CHECKED now, not ACTIVE
      stylecontext: fix icon-source extents computation
      css: Add "-gtk-icon-source: builtin"
      inspector: Add missing directory when scanning for themes
      modelbutton: Fix up for style context changes
      cssnodedeclaration: Fix src/dest swap in memmove()

Carlos Garnacho (6):
      wayland: write wl_data_offer data asynchronously
      window: unset menubar before unsetting focus on dispose()
      scrolledwindow: Simplify _gtk_scrolled_window_set_adjustment_value()
      scrolledwindow: Allow overshooting on scroll events
      gtkgesturesingle: Unset button/sequence if parent handle_event failed
      scrolledwindow: Add ::edge-overshot signal

Carlos Soriano (3):
      gtkplacessidebar: Don't change location if clicked on eject button
      gtkplacessidebar: Open $HOME after unmounting or ejecting
      gtkplacessidebar: Fix commit f6870e5b79fd9ab

Changwoo Ryu (1):
      Updated Korean translation

Chun-wei Fan (1):
      Update README.txt for MSVC Builds

Daniel Mustieles (2):
      Updated Spanish translation
      Updated Spanish translation

Dariusz Gadomski (1):
      printing: Properly initialize auth_info in gtkprintbackend.c

Dušan Kazik (1):
      Updated Slovak translation

Emmanuele Bassi (1):
      build: Require libepoxy

GNOME Translation Robot (1):
      Updated Scottish Gaelic translation

Ikey Doherty (1):
      Add GtkSidebar

Jasper St. Pierre (7):
      label: Don't add in the allocation to our clip again
      reftests: Actually add a text-shadow to the text-shadow reftest
      cssshadowvalue: Rename shadow_key to original_cr_key
      cssshadowvalue: Move the check for blurring into its own function
      cssshadowvalue: Add a cache for blurred Pango layouts
      gdkwindow: Fix small typo
      gdkwindow-x11: Fix graphical regression from 5e325c4

Kalev Lember (1):
      gdk: Allow calling gdk_cairo_surface_create_from_pixbuf with scale 0

Lapo Calamandrei (32):
      Adwaita: selectors cleanup and some refactoring
      Adwaita: needs-attention on sidebar-item
      Adwaita: added style for vertically linked entries
      Adwaita: add vertically linked combos
      Adwaita: fix last vertically linked focused entry
      Adwaita: change spinbutton button color on backdrop
      Adwaita: don't round scrolled window frame corners
      Adwaita: colorchooser style rewrite
      Adwaita: color button changes
      Adwaita: style menu overflow button
      Adwaita: dim menu overflow button border color
      Adwaita: finally kill the scrollbar junction frame...
      Adwaita: fix the special cased sidebar scrollbar...
      Adwaita: fix colorchooser styling after latest gtk changes
      Adwaita: color treeview tree/grid lines
      Adwaita: avoid border clash on transitioning adiacent flat buttons
      Adwaita: tweak list row transition
      Adwaita: list row hover color
      Adwaita: ease-out-quad in place of ease-out
      Adwaita: fix stack-switcher button outline offset
      Adwaita: dimmed backdrop foreground color
      Adwaita: use $backdrop_fg_color where it should
      Adwaita: darkened a tiny bit bright variant background
      Adwaita: comment exported colors
      Adwaita: add back text color.
      Adwaita: darken a tiny bit more bright variant background color
      Adwaita: GtkPlacesSidebar treeview text color fix
      Adwaita: wide paned separator style
      Adwaita: properly fix places sidebar
      Adwaita: axes borders of notebooks inside frame
      Adwaita: colorswatch on selected elements style fix
      Adwaita: use -gtk-icon-source: none on paned...

Lars Uebernickel (2):
      Distribute gtk/resources/ui/*.ui.h
      Add GDK_DEP_LIBS to demos and tests

Marek Kasik (7):
      Remove redundant checks for NULL
      Update paper size names
      Create paper size from IPP media name
      Remove dead code from CUPS backend
      Get paper sizes from IPP query
      Get duplex option via IPP
      Get media-col-default attribute correctly

Marek Černocký (2):
      Updated Czech translation
      Updated Czech translation

Matthias Clasen (186):
      Bump version
      Use better typography for paper names
      GtkPrintUnixDialog: Better typography
      Printing: Better typography
      Broadway: Improve formatting of an error message
      GtkColorSelection: Better typography
      GtkBuilder: Improve error messages
      Progress widgets: Better typography
      GtkProgressBar: Mark the default text for translation
      GtkVolumeButton: Better typography
      GtkFileChooserWidget: Better typography
      GtkPlacesSidebar: Be consistent in messages
      GtkRecentChooserMenu: Better typography
      inspector: Better typography
      printing: Better typography
      printing: Better typography
      Add 3.16 version macros
      GtkLabel: add x/yalign properties
      Revert "Undreprecate GtkMisc::x/yalign for now"
      Keep GtkMisc:xalign working for labels
      GtkAssistant: Use GtkLabel:xalign
      GtkButton: Use GtkLabel:xalign
      GtkContainer: Support focus chain in GtkBuilder
      Add 3.16 deprecation macros too
      Deprecate GtkWidget override APIs
      Better typography for ppd paper names
      Provisional sidebar theming
      Add a few missing include guards
      Avoid compiler warnings
      Fix fonts in context menus
      Don't emit a useless warning
      Fix a typo
      Trivial formatting fix
      GtkCalendar: deal better with a large allocation
      GtkSidebar: not a listbox anymore
      GtkFontButton: Stop using deprecated API
      GtkColorEditor: Stop using deprecated API
      GtkColorEditor: Fix missing background in popups
      GtkFontChooserWidget: Stop using deprecated API
      GtkCellRendererAccel: Stop using deprecated API
      GtkSidebar: Scroll when needed
      gtk-demo: Make the sidebar demo scroll
      GtkExpander: Fix a problem with resize-toplevel
      Make non-ASCII strings in ui files work
      Properly extract strings from gtkprintunixdialog.ui
      widget-factory: Add a scale button
      GtkSidebar: Fix a property type
      GtkSidebar: Don't use internal API
      Trivial typography improvement
      GtkRadioButton: Allow setting group more than once
      widget-factory: Add more buttons
      Printing: Make the print dialog look better with bottom buttons
      widget-factory: Add a sidebar example
      widget-factory: Make the record button more interesting
      GtkBuilder: Undo the type name heuristic changes
      GtkBuilder: Don't use deprecated types in examples
      inspector: Fix a thinko
      Remove an unused variable
      print: Center sheet drawing vertically
      print: Center sheet drawing horizontally
      printing: Simplify sheet drawing
      Small code rearrangement
      inspector: Down the model tree
      printing: Another tweak to sheet drawing
      printing: Make GtkPrinter have a useful icon by default
      printing: Avoid missing icons
      widget-factory: More vertical linking examples
      widget-factory: Cosmetic improvement
      Trivial documentation tweaks
      Add a function to load css from a resource
      Fix a thinko in the previous commit
      docs: Add an index for 3.16 additions
      Add a label style class
      Use .label in the theme css
      Cosmetic documentation improvements
      GtkScrolledWindow: code cleanup
      GtkPlacesSidebar: Don't pile up duplicate bookmarks
      Cosmetic formatting fix
      GdkDevice: Avoid unnecessary critical
      Add GtkTextViewClass to the docs
      GtkStackSwitcher: Pick up the visible child from the stack
      GtkSidebar: Pick up the visible child from the stack
      GtkTextView: Add a monospace property
      Adwaita: Add .monospace style
      Inspector: Use the new monospace support
      Inspector: Use text attributes for monospace labels
      gtk3-demo: Don't use deprecated API
      Add a style class for touch selection popovers
      Make touch-selection popovers font-inert
      More removal of deprecated API
      ColorChooser: Fix an off-by-one error
      Remove an unused internal export
      GtkMenuButton: Submit to action
      Add a note about text view issues
      GtkScrolledWindow: Allow scrolling without bars
      Add an example for synchronized scrolling
      GtkScrolledWindow: Introduce a helper function
      inspector: Add a way to disable the warning dialog
      Add top/bottom style classes to scroll arrows
      inspector: Drop the button path
      inspector: Save some more space
      inspector: Fix up resource tab appearance
      inspector: Add more data to resource list
      inspector: Avoid a split pane for resources
      inspector: Drop unused python shell code
      inspector: Small reshuffling
      inspector: More refactoring
      inspector: More refactoring
      inspector: Avoid a split pane for objects
      inspector: Cosmetic fixes
      inspector: Cosmetic fixes
      inspector: Cosmetic fixes
      inspector: Small improvements to the resource tab
      inspector: Make resource list columns resizable
      inspector: Make the window smaller
      inspector: Remove a stray separator
      inspector: Cosmetics
      GtkToolButton: Apply expected button style classes
      inspector: Add a tab for object counts
      inspector: Some improvements for statistics
      inspector: Bring the selector back
      GtkColorSwatch: Avoid style context underflow
      GtkSearchBar: don't peek out
      GtkListBox: Support placeholders in ui files
      Correct Since tags
      Correct copyright year
      Trivial formatting fixes
      Correct another Since tag
      Nitpicky documentation fixes
      Nitpicky documentation changes
      Drop a reference to GtkGLArea::create-context
      Pedantic formatting fix
      Add GdkGLProfile and GdkGLError to the docs
      GtkBox: Ensure we only allow one center child
      Plug a memory leak
      GtkContainerAccessible: avoid resurrecting accessibles
      GtkFontChooserWidget: Plug several memleaks
      GtkPlacesSidebar: Don't leak an icon
      Revert "gtktrayicon-x11: Stop using set_double_buffered"
      Avoid deprecation warnings
      widget-factory: Add some vertical examples
      widget-factory: Add a missing scrolled window
      GtkEntry: plug a small memleak
      GtkWindow: Avoid an early exit
      Some documentation updates
      Work around a pkg-config bug
      GtkWindow: Add a getter for the custom titlebar
      Fix a few typos
      Fix the build
      Add a a drop-in test for the GtkBuilder parser
      GtkFileChooser: Make preview update more understandable
      Forgotten file
      testfilechooser: Test the preview again
      Clarify GtkSettings documentation
      Deprecate some GtkSettings api
      GtkMenuItem: Simplify code
      GtkSpinButton: Simplify code
      Deprecate gtk_settings_install_property APIs
      GtkToggleButton: Move nonexported API to a private header
      GtkTooltip: Move nonexported API to a private header
      GtkAboutDialog: Don't shout
      Improve tooltip-text/markup docs
      Add GtkGLArea fully to docs
      GtkPaned: Add a "wide-handle" property
      widget-factory: Add a wide-handle example
      widget-factory: Example for edge-overshot
      GtkRange: Add a style class during dragging
      Add an experiment for overlay scrollbars
      GtkScrolledWindow: Add overlay scrollbars
      Add some overlay scrollbar theming to Adwaita
      Port the overlayscroll example
      GtkScrolledWindow: Add documentation
      GL: Follow naming conventions
      Skip GdkX11GLContext in some object tests
      Add a 3.16 index
      Add new papersize api to the docs
      Add all sidebar API to the docs
      Fix docs for gtk_css_provider_load_from_resource
      Fix docs for gtk_settings_set_property_value
      Document gtk_printer_option_set_get_groups
      Document gtk_sidebar_get_stack
      GtkSidebar: Make docs show up
      Add GtkGLArea to the widget gallery
      Add GtkSidebar to the widget gallery
      3.15.0
      Drop a reference to gtkthemingengineprivate.h

Michael Catanzaro (1):
      tooltip: fix line wrapping

Milo Casagrande (1):
      Updated Italian translation

Piotr Drąg (6):
      Updated POTFILES.in
      Updated POTFILES.skip
      Updated POTFILES.in and POTFILES.skip
      Updated POTFILES.in and POTFILES.skip
      Updated POTFILES.in
      Updated Polish translation

Ryan Lortie (1):
      wayland: don't init if XDG_RUNTIME_DIR missing

Sébastien Wilmet (2):
      docs: documentation for GtkTextBufferClass
      docs: add missing symbol in GtkTextView

Thomas Lange (1):
      aboutdialog: Mark strings as translatable

Vasiliy Nuzha (1):
      Fix monitors enumeration bug

Wolfgang Stöggl (1):
      Updated German translation

Yosef Or Boczko (3):
      Updated Hebrew translation
      Updated POTFILES.in
      Updated Hebrew translation


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]