[gtk+] Created tag 3.15.2



The unsigned tag '3.15.2' was created.

Tagger: Matthias Clasen <mclasen redhat com>
Date: Sun Nov 23 20:53:17 2014 -0500

    3.15.2

Changes since the last tag '3.15.1':

Alberts Muktupāvels (1):
      gtkmenu: fix unnecessary scroll buttons

Alexander Larsson (49):
      GdkGLContextX11: Ensure we get the fbconfig with the exact same visual
      Pick the first rgba visual, not the last
      GdkGlContextWayland: Don't require specific bit depths
      GdkGLContextX11: Don't free NULL visual info
      X11: Pick better system and rgba visuals for GL
      Cache default gdk visuals in the GDK_VISUALS property on the root window
      GdkX11GLContext: Fix leak
      GdkWindowX11: Keep the impl window cairo surface around until destroy
      GdkGLContext: Change the way we track the current context
      GdkGLContext: Track shared context
      GdkWindow: destroy paint gl context on destroy
      GtkGLArea: Always destroy context on unrealize
      Remove GdkGLContext::visual
      Clarify docs for gdk_cairo_draw_from_gl
      Add GdkGLContext::profile
      gdk_x11_display_make_gl_context_current: move some code
      GtkGLArea: Major reworking
      GtkGLArea: Add INPUT_ONLY window so that we can get events
      GtkGLArea: Add profile property
      GtkGLArea: Add resize signal
      GdkGLArea: fix has_alpha changes at runtime
      GtkGLArea: Add create-context signal
      GtkGLArea: Don't dispose gl context on unrealize
      GdkGLContext: Add display property
      GtkGLArea: Correctly position/size input window on realize
      GdkGL: Fix and clean up gdk_cairo_draw_from_gl()
      GdkGLContextX11: Only set swap interval when it changed
      gdkgl: Don't constantly re-create the tmp framebuffer
      Add gdk_gl_texture_quad() helper
      GdkGLContextX11: Use passed in context, not get_current()
      gdk_cairo_draw_from_gl: Document that this changes the current context
      GdkGL: Rename "context" to "paint_context" to clarify things a bit
      gdk_gl_texture_quad: Use shaders to texture things
      GdkWindow: Try to use a Core 3.2 GL profile for the paint context
      gdk_cairo_draw_from_gl: Remove useless call
      Add GDK_GL env var and GdkGLFlags
      Add support for GDK_GL=texture-rectangles
      GdkGL: Fix up GL_ARB_texture_rectangle support
      Add gdk_gl_context_has_framebuffer_blit()
      GdkX11GLContext: Use bitblit for swap if no buffer age support
      gdk_gl_texture_quad: Fix handling of window scales
      gdk_gl_texture_from_surface: Enable scissor test
      GdkWindow: Drop gl matrix setup which is not needed anymore.
      gdk_window_end_paint: Flush destination surface after paint
      x11: Return the exact pixel coverage in get_frame_extents
      Add gdk_window_get_unscaled_size
      GL: Fix GL Y coordinate flipping to use unscaled window height
      GdkGLContext: Remove unused update vfunc
      GL: Fix typo in gdk_gl_texture_from_surface

Baurzhan Muftakhidinov (1):
      Updated Kazakh translation

Benjamin Otte (1):
      tests: Add deprecation guards

Carlos Garnacho (14):
      wayland: Emit GDK_OWNER_CHANGE events around wl_data_offer changes
      gtkwindow: Do not create the multipress gesture for plugs
      gtkwindow: Resort to regular event bubbling by all means on non-toplevels
      treeview: remove single-click activation from GtkGestureMultiPress::pressed
      gtkwindow: claim the press sequence when clicking on the titlebar
      wayland: Don't translate a NULL region into an empty one
      wayland: Schedule a clock tick instead of wl_surface_commit()ting directly
      scrolledwindow: Only render overshoot on the widget window
      gtkpopover: Fix allocation of child widget wrt margins
      scrolledwindow: Don't doubly draw overlay-indicator scrollbars
      scrolledwindow: Use a fully transparent background for the overlay window
      scrolledwindow: Only render background/frame on the widget window
      scrolledwindow: Avoid too frequent redraws of scrollbars
      wayland: Pass shadow width to the compositor

Chun-wei Fan (2):
      gdk/gdkgl.c: Fix Typo
      Visual Studio Builds: Fix gdkconfig.h Generation

Cosimo Cecchi (1):
      radiobutton: don't consider hidden buttons in the group for focus

Daniel Mustieles (5):
      Updated Spanish translation
      Updated Spanish translation
      Updated Spanish translation
      Updated Spanish translation
      Updated Spanish translation

Debarshi Ray (1):
      query, searchengine: Drop unused and undefined function declarations

Dimitris Spingos (2):
      Updated Greek translation
      Updated Greek translation

Emmanuele Bassi (4):
      Make global GDK libgtk_only functions more private
      Move GDK GL flags accessors to the private vtable
      Hide GdkWindow libgtk_only API in the private vtable
      window: GtkPlug is conditionally supported on X11 only

Jakub Steiner (1):
      theme: move HC theme from gnome-themes-standard

Jasper St. Pierre (18):
      gdkwindow: Specify some invariants for cursors
      gtkwindow: Use gdk_cursor_new_for_display
      gdkdisplay: Provide a default event_data_copy / event_data_free
      gdkevents: Use the correct display to copy event data
      wayland: Don't use the default display
      gdkgl: Make some helper functions static
      inspector: Remove unused variable
      gdkwindow-x11: Fix indentation
      quartz: Don't bother storing the paint_clip_region
      gdkwindow: Don't pass the region to the impl when beginning a paint
      gdkwindow: Clean up whitespace slightly
      gdkgl: Clean up program-manipulating code
      gdkgl: Use a GdkTexturedQuad struct to paint quads
      gdkglcontext-x11: Make sure to enable the scissor test
      gdkgl: Texture many quads at once for performance reasons
      gdkgl: Use one VBO for both position and uv attributes
      gdkgl: Texture quads in one giant draw call
      gdkinternals: Document our drawing and painting process better

Javier Jardón (1):
      configure.ac: Depend on cairo 1.14.0

Josef Andersson (2):
      Updated Swedish translation
      Updated Swedish translation

Kjartan Maraas (3):
      Updated Norwegian bokmål translation.
      Updated Norwegian bokmål translation.
      Updated Norwegian bokmål translation.

Lapo Calamandrei (31):
      Adwaita: first round of OSD style converage
      Adwaita: fix selected colorswatch white border
      Adwaita: fix for the previous colorswatch fix...
      Adwaita: osd rationalization and tweakings
      Adwaita: border radiusses rationalization
      Adwaita: slightly contrasting popover background
      Adwaita: darken a bit OSD background color
      Adwaita: simpler gtkcalendar style (once again)
      Adwaita: special case .default-decoration
      Adwaita: add borders to menus in a non composited env
      Adwaita: brighter dark variant header-bar bottom shade
      Adwaita: dim GtkPlacesSidebar icons color
      Adwaita: initial overlay indicator styling
      Adwaita: remove last child border on backdrop column headers
      Adwaita: scrollbar styling overhaul
      Adwaita: increase scrollbar slider contrast
      Adwaita: add a missing comma...
      Statusbar: add 'statusbar' style class
      gtkrange: consider css margin on the slider
      Adwaita: set scale trough margins where they belong.
      Adwaita: simplify scrollbar styling
      Adwaita: overshoot styling
      Adwaita: reset some properties in the overshoot mixin
      Adwaita: overshoot style tweaks
      Adwaita: more overshoot tweakings and typo fix
      Adwaita: popover scss cleanup
      Adwaita: :selected cleanup and rationalization
      entry: remove osd style class from touch selection popover
      textview: remove osd style class from touch selection popover
      Adwaita: no border radius for GtkTreeView:selected
      Adwaita: typo fix

Marco Trevisan (Treviño) (19):
      mir: actually pass the GdkMirScreen to display config change cb
      mir: unset config change callback on finalize
      mir: correctly get screen mm sizes
      mir: clear screen data
      mir: don't crash when querying infos for an invalid monitor
      mir: clear screen objects correctly
      mir: implement screen get_plug_name
      mir: don't request more surface formats than the supported ones
      mir: get/set window surface type
      mir: fix compilation in mirscreen
      mir: handle more surface types
      mir: invert scrolling delta
      mir: fix typo in GDK_IS_WINDOW_MIR definition
      mir: update surface type based on events
      mir: add OpenGL support
      mir: don't use struct MirConnection*, just the latter
      mir: add public getter for the internal MirSurface
      mir: use proper naming for mir window type checking macro
      mir: initialize surface name with program name

Matthias Clasen (140):
      GtkAboutDialog: Don't use gdk_cursor_new
      Deprecate gdk_cursor_new()
      Mention the 'same display' requirement in the docs too
      Don't return GDK_GRAB_SUCCESS on failure
      Drop an unused variable
      Add another multi-device invariant
      gtk-demo: Drop uses of gdk_cursor_new()
      Inspector: Make picking work without a grab
      Bump atk dep
      wayland: Make window opacity work
      Document Wayland opacity handling
      Plug some memory leaks in GL support
      Plug another memory leak
      Fix toplevel input shape for csd windows
      Drop an unused variable
      Make GtkModelButton public
      Make GtkModelButton a better GtkActionable
      Add a manual popover menu example
      Add GtkPopoverMenu
      GtkModelButton: Add a menu-name property
      Adapt the testpopover example
      Drop GtkModelButton:has-submenu
      Adapt the testpopover example
      GtkModelButton: Drop unused :accel property
      GtkModelButton: Rename action-role to role
      Adapt the testpopover example
      GtkModelButton: Don't require an explicit role
      Adapt the testpopover example
      GtkPopoverMenu: Simplify
      Adapt the testpopover example
      Add documentation
      Add a scale to the popover menu example
      GtkPopoverMenu: Add API to open a submenu
      Remove a redundant call
      Make the inspector window translucent instead of lowering
      HighContrast: Drop settings.ini
      HighContrast: Add sass parsing script
      Drop gtk.gresource.xml
      HighContrast: integrate in build machinery
      inspector: Add HighContrast to built-in themes list
      Improve warning
      inspector: Stop overeager activation
      inspector: Improve search in property list
      inspector: Improve search in style property list
      Trivial: sort file list alphabetically
      inspector: Add search to the object tree
      inspector: Refine object tree search
      inspector: Search refinements
      icon-browser: Add search
      GtkListBox: Fix a bug in unselection
      glade: Drop a no-longer existing private widget
      glade: Add GtkColorEditor to private widgets
      GtkVolumeButton: Fix annoying double formatting
      Fix an ordering issue in event destruction
      csd: Improve appearance inside glade
      GtkHeaderBar: Fix a corner-case in child properties
      GtkFileChooser: Add a menuitem for 'sort directories first'
      GtkIconTheme: Improve an error message
      Only warn once if inhibit-related dbus calls fail
      Add some more builder tests
      Make window scale changes work again
      GtkHeaderBar: Make the position child property writable
      widget-factory: Add another osd
      widget-factory: Fill up page 2 properly
      GtkHeaderBar: Queue a resize when pack-type is changed
      GtkModelButton: protect against show_all
      Drop an unneeded include
      Export API to set GL flags
      inspector: Add GL flags
      Add new API to docs
      Don't make the gl flags API
      inspector: include private gdk headers
      Revert "Add new API to docs"
      inspector: Look for themes in the right places
      inspector: Correct a tooltip
      inspector: Improve search in the resource tree
      inspector: Shorten some labels
      inspector: Move the record button up
      inspector: Improve search on the statistics page
      extract-strings: Handle property binding attributes
      inspector: Reserve space for buttons
      inspector: Add more GL information
      inspector: Set statistics button sensitivity
      Set the clip on range widgets
      inspector: Hide the inspector tab when empty
      inspector: Hide the size-groups tab when empty
      Inspector: hide the selector tab for non-widgets
      Move rendering mode into GdkDisplay
      gdk: Add private API for rendering mode
      inspector: Add a rendering mode control
      gdk: Make debug-updates a per-display setting
      inspector: Only set debug-updates for the default display
      GtkStack: Remove some clumsy use of GList API
      inspector: Turn off search where we don't have a search bar yet
      GtkActionBar: Rename center_box to box
      GtkActionBar: Make ::position writable
      Forgotten files
      gtk3-demo: Use better text margins
      widget-factory: Add some margins to text views
      GtkCssProvider: Factor out a function
      GtkCssProvider: Load themes from versioned directories
      inspector: Update misc-info while the tab is shown
      inspector: Show the refcount on the misc tab
      inspector: Add frame clock info
      GtkPopover: Survive attach_widget == NULL
      Trivial formatting fix
      Drop unused variables
      Make overlay scrollbar fading interruptible
      GtkPopoverMenu: Implement forall
      Make gtk_container_remove work on popover menus
      GtkStack: Fix an oversight in child renaming
      GtkPopoverMenu: expose more properties
      GtkPopoverMenu: be more careful about change notification
      GtkModelButton: Don't show both text and icon
      GtkGLArea: Formatting fixes
      inspector: Trivial typo fix
      inspector: Drop an unused argument
      inspector: Store object title on object
      inspector: Show object title in the misc tab
      inspector: Show object title in the properties tab
      inspector: Show object title in the signals tab
      inspector: Show object title in the gestures tab
      inspector: Show object title in the css tab
      inspector: Show object title in the classes tab
      inspector: Show object title in hierarchy tab
      inspector: Show object title in actions tab
      inspector: Show object title on selector tab
      inspector: Show object title on the style property list
      inspector: Show object title in data tab
      inspector: Show object title in size groups tab
      inspector: Add menu models to the tree
      inspector: Show object title in menu tab
      GtkModelButton: specify the proper default values
      GtkGLArea: avoid extraneous property notifications
      notify test: Exclude a few new properties
      Update expected results
      GtkModelButton: Add docs
      Add missing api to the docs
      3.15.2
      Bump version

Owen W. Taylor (2):
      x11: round the scaled size *up* when we get a ConfigureNotify
      x11: Keep track of the exact size in X pixels of windows

Piotr Drąg (2):
      Updated POTFILES.in
      Updated POTFILES.in

Robert Ancell (3):
      mir: Don't assert on unknown Mir events.
      mir: Handle pointer up/down events without a button mask set (i.e. touch events)
      mir: Require mirclient >= 0.9.0

Ryan Lortie (1):
      mir: rework cursors a bit

Timm Bäder (5):
      GtkMenuSectionBox: Add tooltip to iconic buttons
      popover: Add show/hide transition
      GtkDialog: Connect to activate signals only once
      Revert "popover: Add show/hide transition"
      Revert "GtkMenuSectionBox: Add tooltip to iconic buttons"

Tom Tryfonidis (1):
      Updated Greek translation

William Hua (2):
      mir: set cursor
      mir: enable csd

Yosef Or Boczko (2):
      Updated Hebrew translation
      Updated Hebrew properties translation


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]