[mutter] Created tag 3.13.2



The unsigned tag '3.13.2' was created.

Tagger: Florian Müllner <fmuellner gnome org>
Date: Tue May 27 21:41:12 2014 +0200

    Tag release 3.13.2

Changes since the last tag '3.13.1':

Adel Gadllah (3):
      wayland: Add basic hidpi support
      wayland: Scale native surfaces for hidpi
      Fix last commit

Daniel Mustieles (1):
      Updated Spanish translation

Florian Müllner (8):
      display: Don't grab transient's parent unconditionally
      window: Fix delayed mouse mode
      window: Fix delayed mouse mode on X
      Remove MetaMenuIconType
      Add support for app-menu button in window decorations
      Actually implement opening the app menu
      window: Add accessor method for gtk_theme_variant
      Bump version to 3.13.2

Giovanni Campagna (7):
      MetaMonitorConfig: don't keep a previous config with the wrong outputs
      MetaMonitorConfig: don't always restore the previous config when opening the laptop lid
      MetaIdleMonitorDBus: unref the objects after exporting them
      MetaDisplay: free the wayland windows table at close
      default: free the option context after parsing
      MetaStackTracker: make sure all stack ops are freed eventually
      xprops: free the text list content too

Jasper St. Pierre (116):
      core: Remove a few unused meta_core functions
      window: Fix typo in comment
      window: Simplify adjust_for_gravity
      window: Remove the borders parameter from adjust_for_gravity
      window: Move the session restoration and post-manage move_resize to window-x11
      window: Move adjust_for_gravity to window-x11
      window: Make the x/y position in the requested_rect more accurate
      window: Remove some ugly debug logging
      window-wayland: Fix interactive resizing from the top/left once more
      window-x11: Fix a copy/paste error
      window-x11: Clean up a bit
      window-x11: Clean up formatting a bit more
      window: Change meta_window_move_resize_internal to take a MetaRectangle
      constraints: Remove a lie
      window: Rearrange code a tiny bit
      window: Clean up old_rect handling a tiny bit
      Remove trailing whitespace
      display: Remove some more unnecessary NULL checks
      keybindings: Make sure not to call meta_change_keygrab under Wayland
      wayland-surface: Fix warnings
      xwayland: Don't crash when the window disappears from under us
      ui: Remove maybe_redirect_mouse_event
      constraints: Size increments need to be applied to the client rect
      window: Make sure not to eat any events that end grab ops
      Update to latest xdg-shell protocol
      constraints: Complete fix for size hints constrainment
      Revert "ui: Remove maybe_redirect_mouse_event"
      Revert "Update to latest xdg-shell protocol"
      keybindings: Fix <Super> key crash
      keybindings: Don't mark a replayed keypress event as handled
      display: Correct check for grab_window_buttons
      events: Don't check if we have the grab to raise / focus a window
      events: Remove an unnecessary check
      events: Move keybindings event handling out of the giant switch
      events: Move the overlay_key_only_pressed handling to keybindings.c
      events: Remove extra check for certain grab op
      events: Replace a switch statement with a simple if test
      events: Swallow all events directly on windows
      events: Clean up event replay code
      events: Move window button handling to window.c
      events: Set display->current_time when we start processing the event
      events: Make sure to reset current_time after handling events
      wayland: Use standard SINCE version definitions
      wayland: Move appears-focused changed handling to window-wayland
      wayland: Update to latest xdg-shell protocol
      wayland: Send a correct width / height for state changes
      cursor-tracker: Use a separate cursor for xfixes cursor tracking
      cursor-tracker: Remove the grab cursor
      backend-x11: Always pass None for the cursor
      display: Replace set_grab_op_cursor with update_cursor
      configure: Remove old, unused configure arg
      configure: Require a newer wayland-server
      wayland: Use meta_window_move to position xdg_popup windows
      pointer: Update the button count after repicking
      backend: Create the cursor renderer after the monitor manager
      wayland: Don't try to autostart gnome-session
      keybindings: Rename initial_selection to window
      keybindings: Don't crash if we don't have any windows to activate
      cursor-renderer: We always use a MetaStage
      cursor-renderer-native: Don't move the cursor when we don't need to
      cursor: Correct switching between fallback and backend cursors
      cursor: Add a META_CURSOR_NONE
      x11: Add simple cursor renderer
      Convert window menus to a compositor implementation
      window: Complete moving enter/leave handling here
      launcher: Remove the "VT-switched lock"
      launcher: Pause Clutter during VT switches
      launcher: Put in some markers to help diff make a readable patch
      launcher: Replace mutter-launch with logind integration
      Revert "launcher: Put in some markers to help diff make a readable patch"
      keybindings: Clean up code a tiny bit
      window: Replace the user_rect with the unconstrained_rect
      window: Make propagate_focus_appearance internal to MetaWindow
      Rework timestamp pinging
      place: Simplify control flow and fix a crash
      place: Move maximization path above first fit finding
      place: Don't require checking for changing
      core: Remove some unused meta_core_get requests
      window: Move _NET_WM_DESKTOP setting to window-x11
      window-x11: Make sure to chain up in grab_op_began / ended
      window-wayland: Change the state on grab op transitions
      window: Move meta_window_wayland_new to window-wayland.c
      window: Move constructors to the respective header files
      window: Make border_width private to X11
      frame: Make sure to XSync before grabbing keybindings
      window: Reindent slightly
      window: Remove meta_window_resize
      window-x11: Consistently include the bottom border on shaded windows
      window-x11: Don't bother calculating the actual deltas for the frame
      window-x11: Simplify leftovers from the static gravity code removal
      window-x11: Calculate size_dx / size_dy before assigning to window->rect
      window-x11: Rearrange locals a tiny bit
      window: Remove some overcomplicated uses of meta_window_move_resize
      window: Remove another comment reference to StaticGravity
      x11: Add support for a new _GTK_SHOW_WINDOW_MENU request
      Add back coordinates to the window menu
      keybindings: Correct coords for window menu for CSD windows
      wayland: Move checks for grabbing into a central location
      window-x11: Move the comment about StaticGravity resizing down
      window: Allow passing garbage window sizes for move-only actions
      window: Rename the requested_rect to the unconstrained_rect
      window-x11: Remove a use of meta_window_get_position
      keybindings: Fix code style
      keybindings: Correct move_to_corner_backend
      window-wayland: Don't use meta_window_get_position
      keybindings: Replace the incomprehensible set of flags with a gravity param
      monitor-manager-xrandr: Make sure to XFlush the XUngrabServer
      wayland: Add support for show_window_menu
      window: Move the extents storage above the rects
      constraints: Remove improper frame_rect_to_client_rect for placement
      core: Reindent
      backend: Add an XIWarpPointer wrapper
      window: Remove meta_window_get_rect
      window: Rename get_geometry to get_session_geometry
      window: Add a meta_window_get_titlebar_rect
      window: Make meta_window_unmaximize_with_gravity internal

Jonas Ådahl (1):
      wayland: Only send wl_output.scale event if supported by the client

Pau Iranzo (1):
      [l10n] Update Catalan translation

Piotr Drąg (2):
      Updated POTFILES.skip
      Updated POTFILES.in

Rico Tzschichholz (2):
      Drop leftover menu.h/metaaccellabel.h references
      build: Add org.freedesktop.login1.xml to EXTRA_DIST


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]