[mutter] Created tag 3.13.4



The unsigned tag '3.13.4' was created.

Tagger: Florian Müllner <fmuellner gnome org>
Date: Wed Jul 23 13:08:51 2014 +0200

    Tag release

Changes since the last tag '3.13.3':

Adel Gadllah (2):
      Revert "backend-x11: Take the touch grab on the stage window"
      x11: Move event filter to backend connection

Aurimas Černius (1):
      Updated Lithuanian translation

Carlos Garnacho (17):
      backend-x11: Remove pointless goto
      backend-x11: Ensure touch event coordinates are translated to the stage's
      ui: Remove unneeded code
      frame: Only select for ButtonPress/Release/Motion/Crossing
      ui: Remove XI_TouchBegin handling from window frame event handlers
      events: Update current time on CLUTTER_TOUCH_BEGIN events
      compositor: emit grab-op-begin/end signals on plugin grabs
      core: Add MetaGestureTracker
      display: Add a global MetaGestureTracker
      events: Hook MetaGestureTracker to display event processing
      display: Set an X11 passive touch grab on the root window
      backend: Use the most recent event time on replayed touch events
      frames: Keep information about the ongoing grab operation, and retry if needed.
      gesture-tracker: Implement threshold-based sequence rejection
      wayland: set the interface vfuncs when declaring the keyboard interface
      wayland: set the interface vfuncs when declaring the touch interface
      wayland: Unset keyboard/pointer focus when releasing the data for these devices

Enrico Nicoletto (1):
      Updated Brazilian Portuguese translation

Florian Müllner (5):
      gradient: Remove unused parameter
      gradient: Support alpha values in colors
      theme: Also support alpha values in blend/shade functions
      screen: Tweak workspace initialization (again)
      Bump version to 3.13.4

Fran Diéguez (1):
      Updated Galician translations

Giovanni Campagna (4):
      build: link against libinput explicitly
      main: kill custom log handler
      compositor: show the stage after we set the size
      window: expose meta_window_is_client_decorated() in the API

Jasper St. Pierre (104):
      window: Use g_object_class_install_properties
      window: Use g_object_notify_by_pspec
      window: Set custom frame extents to 0 if we don't have any
      window-wayland: Correct the buffer rect for frame extents
      window: Fix get_client_area_rect for the frame rect conversion
      window-x11: Fizzle out changes to the three different regions
      screen: Set a black background for testing purposes
      screen: Fix up last commit
      window-wayland: Make sure the size of the buffer rect is kept up to date
      monitor-manager: Remove duplicate variable definition
      monitor-manager: Rename output_id to output_index
      window: Don't treat an output_id of 0 as an invalid ID
      monitor-manager: Rename output_id to winsys_id
      window: Don't eat events on O-R windows
      wayland-surface: Make sure to apply the margin before moving the window
      theme: Remove bogus comment
      window-wayland: Check to update the buffer_rect separately
      window: Only update the unconstrained rect when we actually moved/resized
      backend-x11: Only spoof the event when we're passing it to Clutter
      frame: Don't select for core events on the frame window
      ui: Filter out touch events
      ui: Remove a superfluous set on emulated motion events
      ui: Fill in more fields on our emulated motion / crossing events
      window: Set the surface to NULL when unmanaging
      window: Remove pending pings in unmanage
      window: Reformat a comment
      ui: Fix the check for the XInput opcode
      ui: Bring back the is_input_event helper
      gesture-tracker: Don't pass an autodeny-timeout
      gesture-tracker: Update documentation format
      gesture-tracker: Rename files to include the meta- prefix
      wayland: Move DataOffer / DataSource into data-device internals
      wayland: Add a wrapper for set_input_focus
      wayland: Fix include ordering
      wayland: Remove seat->display
      data-device: Start a cleanup
      data-device: Don't look up the same client twice in two different ways
      data-device: Use a better variable name than "resource"
      data-device: Put the DataDevice implementation in its own struct
      wayland: Remove a few unused fields from MetaWaylandCompositor
      wayland: Remove an unused field from MetaWaylandFrameCallback
      Don't add in our old input event mask when we select input events
      frame: Only XSync when we're on the X11 compositor backend
      screen: Fetch the COW window up-front
      window-props: Use the standard property type system for WM_WINDOW_ROLE
      window-props: Use the standard property type system for _NET_WM_WINDOW_TYPE
      window-props: Fix assert testing
      window-props: Don't load WM_STATE
      window-props: Use a flags-based approach for our prop hooks
      window-props: Fizzle out PropertyNotifies that happen after initial map
      stack-tracker: Fix comments
      stack-tracker: Fix code style
      stack-tracker: Fix the case where the serial is too old
      stack-tracker: Clean up dumping
      stack-tracker: Add some more debug output
      stack-tracker: Remove unused variable
      stack-tracker: More small cleanups
      util: Turn STACK debugging back off
      window-props: Make sure that recalc_window_type is always called
      window: Manage after setting the OR special case properties
      Remove unused Wayland includes
      monitor: Don't use wl_output_transform in our APIs
      display: Use a local here instead of the global the_display
      display: Add an extra check inside meta_display_close
      events: Return early if we close the display
      Makefile: Disable Clutter / Cogl deprecation warnings
      frames: Don't make a round trip to the X server for every MotionNotify
      window-props: Don't make another round-trip to fetch the opaque region
      screen: Don't make a round-trip to fetch a value we know to be empty
      Take the touch grab in MetaBackendX11
      iconcache: Remove want_fallback hint
      iconcache: Remove commented out code
      iconcache: Remove dead code
      iconcache: Group declarations where they're used
      core: Remove useless meta_invalidate_default_icons implementation
      iconcache: Remove a useless icon_cache_free
      window: Move X11-specific icon code to MetaWindowX11
      window: Remove the concept of surface_mapped
      window: Force updating icons when initially loading them
      keybindings: Fix backend check in change_keygrabs
      window: Fix meta_window_move_resize_internal for the case of a sole ack
      backend-x11: Take the touch grab on the stage window
      compositor: Don't bother selecting for events on the COW
      screen: Don't select for key and motion events on the root window
      screen: Select for events on the guard window on the backend connection
      restart: Fix pointer/XID confusion
      Update .gitignore
      xdg-shell: Fix typo
      xdg-shell: Update to latest
      wayland: Don't require a new buffer to move windows with dx/dy
      wayland: Use the variables we already have
      display: Call meta_window_grab_op_ended after everything else is reset
      wayland: Don't send superfluous configures for uninteresting grab ops
      wayland: Don't fizzle out attaches
      wayland: Calculate the window geometry based on all subsurfaces
      wayland: Fix the sign for the geometry coordinates
      wayland: Treat the size in the configure event as frame rect coordinates
      wayland: Replace set_margin with set_window_geometry
      wayland: Don't emit SIZE_CHANGED on every commit
      wayland: Fix indentation
      wayland: Don't leak an extra xdg_shell resource
      wayland: Use our named #define for the wl_shell version
      wayland: Use a named #define for the xdg-shell version
      cursor-tracker: Don't require a screen

MarMav (1):
      Updated Greek translation

Marek Chalupa (2):
      wayland-pointer: fix condition for grabbing
      wayland window: update buffer_rect when moving

Owen W. Taylor (7):
      Add ::first-frame signal to MetaWindowActor
      meta_accelerator_parse(): handle keysyms without the XF86 prefix
      Switch to using ClutterStage::after-paint
      Don't grab the server when unmanaging the screen
      MetaDisplay: remove meta_display_grab()/ungrab()
      Connect to ClutterStage::after-paint with connect_after()
      Add a framework for restarting the compositor with nice visuals

Rico Tzschichholz (1):
      gradient: Fix warning/typo

Tom Beckmann (1):
      window: Add a property for on_all_workspaces

Yuri Myasoedov (1):
      Updated Russian translation


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]