[mutter] Created tag 3.13.90



The unsigned tag '3.13.90' was created.

Tagger: Florian Müllner <fmuellner gnome org>
Date: Wed Aug 20 02:19:42 2014 +0200

    Tag release 3.13.90

Changes since the last tag '3.13.4':

Adel Gadllah (2):
      background: Do not assume GLSL is available
      window-x11: The x11 backend window is our window as well

Carlos Garnacho (16):
      wayland: Notify modifiers after keymap changes
      seat: Listen for ClutterDeviceManager signals in order to update capabilities
      wayland: Fix infinite loop in touch_handle_cancel_event()
      wayland: Rename touch_handle_cancel_event() to meta_wayland_touch_cancel()
      window: Use event data getters in event handling code
      wayland: set the current serial on touch down/up notifications
      display: Implement gesture-induced touch cancellation for wayland
      display: Add forgotten meta_display_cancel_touch
      gesture-tracker: Add meta_gesture_tracker_get_n_current_touches()
      display: Add meta_display_is_pointer_emulating_sequence()
      window: Implement single-touch window dragging
      wayland: Clear hashtable pointers on meta_wayland_touch_release()
      wayland: Handle window drags for touch events
      events: Simplify gesture event management
      display: cancel wayland client touches when the compositor is grabbed
      events: Do not swallow touch events on windows

Christophe Fergeau (6):
      Add meta_key_binding_is_reversed()
      Don't automatically add bindings for -backward actions
      Add hidden -backward bindings to 50-mutter-navigation.xml
      Remove use of META_KEY_BINDING_REVERSES
      Don't list meta/meta-version.h in mutter_built_sources
      Don't remove meta/meta-version.h during make clean

Cosimo Cecchi (1):
      compositor: add support for unminimize compositor effects

Daniel Mustieles (1):
      Updated Spanish translation

Emmanuele Bassi (1):
      core: Select the X11 backend of Clutter

Florian Müllner (2):
      window-props: Add FORCE_INIT flag to force hooks for unset properties
      Bump version to 3.13.90

Giovanni Campagna (3):
      MetaWaylandTouch: fix running without touch hardware
      MetaShapedTexture: fix critical warnings with fully obscured windows
      ui: always set the frame background to None

Inaki Larranaga Murgoitio (2):
      Updated Basque language
      Updated Basque language

Jasper St. Pierre (131):
      events: Fix compilation when disabling the native backend
      wayland-keyboard: Add support for the repeat_info event in Wayland v4
      cursor-tracker: Reindent
      window: Clean up keyboard-resizing code path
      wayland-surface: Make sure to zero out the geometry
      backend-x11: Make sure to not crash during initialization
      prefs: Scale the root window cursor by the scale factor
      wayland-surface: Add some extra protection
      window-wayland: Rename saved_pos to pending_move
      wayland-surface: Don't do pending move/resizes on all commits
      window-wayland: Clean up code that pends moves
      window-wayland: Don't insist if the window gives us a bad buffer
      wayland-surface: Fix coordinates for xdg_surface.show_window_menu
      shaped-texture: Clean up slightly
      window: Don't leak the input region
      window-wayland: Update the buffer rect size immediately
      window-actor: Don't connect to allocation-changed
      window-wayland: Only fizzle out configures when we do pending moves
      shaped-texture: Remove silly ClutterPaintVolume code with slightly less silly ClutterActorBox code
      window-actor: Base the paint volume on our children, not our shape
      surface-actor: Remove unused APIs
      window-actor: Rebuild the shape and mask when the surface updates
      shadow-factory: Untabify
      shadow-factory: Fix style
      shadow-factory: Comment fixes
      wayland: Simplify slave version management
      wayland: Simplify global version management
      wayland: Fix naming scheme for request handlers
      wayland: Add a few statics we forgot before
      wayland: Use wl_display_add_socket_auto
      wayland: Use the send event wrappers
      background: Don't bother supporting alpha channels for gradients
      background: Merge the code for creating the color texture into here
      compositor: Don't use cogl_texture_new_with_data in the obvious cases
      background: Don't render with blending when we don't need to
      background-actor: Don't bother clipping to the content box
      background: Don't bother attaching a paint node if the region is empty
      texture-tower: Fix error case in meta-texture-tower
      wayland: Fix minor style issue
      wayland: Don't assert fail when dealing with popup windows
      window: Fix some minor constant type issues
      stack: Rewrite to not be based on X11 xtransient_for properties
      window: Kill off a now-unnecessary state variable
      display: Move composite version checks here
      backend: Create the stage in the backend, rather than the compositor
      Conditionalize Wayland support again
      Remove a few extra HAVE_XKBs
      keybindings: Don't bother not reloading keymaps for MappingModifier
      display: Move devirtualize_modifiers into keybindings
      display: Simplify the regrab on focus mode
      keybindings: Simplify a bit more code
      keybindings: Move the button grabs to here as well
      keybindings: Make devirtualize_modifiers a private function
      Remove support for the debugging window grabs feature
      window: Centralize the checks for the window grab modifiers
      keybindings: Add an accessor for window grab modifiers
      keybindings: Seal off the keybindings manager into its own structure
      keybindings: Add a helper for taking the standard three-button grab
      backend-x11: Don't leak the keymap
      backend: Add a keymap-changed signal
      window: Don't mark the event as handled for odd event combinations
      events: Make the ungrabbed button press handling more bullet proof
      window: Filter out buttons when checking if the event is unmodified
      meta-stage: Remove an unused variable
      window-x11: Fix stage window check when running under non-X11 backends
      display: Don't bother recording the grab timestamp
      display: Init X11 events separately
      window-x11: Simplify some grab op code
      cursor-renderer: Popups need to set cursors, too
      workspace: Simplify some more grab op code
      display: Simplify yet even more grab op code
      events: Revert a local change I accidentally made
      workspace: Fix build
      pointer: Update an old function reference
      window: Be better at filtering window grab mods
      window: Fix build
      display: Establish a separate state variable for routing events
      common: Create a better encoding for MetaGrabOp
      keybindings: Hardcode Mod2Mask for Num Lock
      events: Fix get_window_for_event for the new route logic
      display: Fix meta_grab_op_is_moving
      display: Remove meta_grab_op_is_moving_or_resizing
      display: Use a named mask constant inside is_moving / is_resizing
      display: Fix the base type check inside is_keyboard
      display: Replace the inline logic with a static inline
      window: Don't use GTK+ to fetch the drag threshold
      screen: Remove blank and unused function
      screen: Simplify meta_screen_get_workspace_by_index
      screen: Remove a bunch of screen checks
      screen: Use the standard for-loop iteration for iterating over lists
      screen: Make meta_screen_foreach_window scan Wayland windows
      screen: Drop the MetaScreen parameter from the foreach function
      screen: Add the list window flags to meta_screen_foreach_window
      prefs: Actually insert the SCHEMA_MOUSE settings
      screen: Fix workspace removal
      workspace: Replace a boolean ^ with !=
      workspace: Make the code for removing windows easier to read
      workspace: Use for loops instead of whiles to iterate through lists
      workspace: Use g_object_class_install_properties
      workspace: Use G_PARAM_STATIC_STRINGS
      workspace: Add a "workspace-index" property to MetaWorkspace
      workspace: Rewrite workspace management code
      display: Fix inversion for meta_grab_op_is_*
      wayland-pointer: Insert missing break;s
      wayland-pointer: Squash warning
      common: Don't define _WGO_BASE inside the enum
      prefs: Completely remove references to REVERSES
      keybindings: Remove unused includes
      util: Move the text direction stuff out of MetaUI
      prefs: Fix indentation
      Remove a few extra "ui.h" includes
      keybindings: Rewrite the modmap code so that it uses libxkbcommon
      keybindings: Rewrite the keymap code so that it uses libxkbcommon
      window-x11: Fix the coordinates we use in the synthetic ConfigureNotify
      keybindings: Use a less hacky method of getting the proper modifier mask
      main: Clutter does not have to be initialized after the UI
      main: Clean up the initialization sequence
      xrandr: Don't use RRQueryOutputProperty to fetch hotplug_mode_update
      xrandr: Fix build
      bell: Clean up the bell code
      xrandr: Port some checks to XCB so we don't have to deal with BadName
      window: Fix cursor anchoring issues when drag-unmaximizing windows
      window: Increase the height of CSD titlebars
      window: Add a hack to correct dragging from the top panel in gnome-shell
      stack: Reindent
      prefs: Don't crash when we get a preference changed we don't know about
      keybindings: Make sure to filter out the virtualized mod itself
      window: Fix the north/south cursor position when keyboard resizing
      common: Make UNKNOWN a flag, not a combination of all directions
      window: Don't try to map / unmap OR windows by ourselves
      wayland: Initialize SHM again

Kjartan Maraas (1):
      Updated Norwegian bokmål translation.

Lasse Liehu (1):
      Finnish translation update

Olav Vitters (1):
      doap category core

Owen W. Taylor (1):
      MetaTextureTower: actually mark revalidated levels as valid

Piotr Drąg (1):
      doap: add <programming-language>

Rico Tzschichholz (1):
      configure: Require wayland-server >= 1.5.90

Rui Matos (8):
      compositor: Sync X drawing only once per frame
      wayland-keyboard: Make update_pressed_keys() more generic
      wayland-keyboard: Send keymap events also to focused resources
      wayland-keyboard: Send modifiers after the keymap
      Use libX11's Xkb* API unconditionally
      backends: Add methods to handle keymaps
      wayland-keyboard: Use the backend's keymap
      backends: Make MetaBackend available to introspection

ngoswami (1):
      Updated Assamese translation


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]