[mutter] wayland: Rename set_transient_for to set_parent
- From: Jasper St. Pierre <jstpierre src gnome org>
- To: commits-list gnome org
- Cc:
- Subject: [mutter] wayland: Rename set_transient_for to set_parent
- Date: Sat, 12 Apr 2014 06:56:22 +0000 (UTC)
commit 7c4f4c6f36cfa01df891bae322e233f8ae2f6deb
Author: Jasper St. Pierre <jstpierre mecheye net>
Date: Fri Apr 11 22:33:38 2014 -0700
wayland: Rename set_transient_for to set_parent
This is also something that we did upstream. Since we want to
introduce an explicit "xdg_transient" window type for tooltips
and popovers, and since "transient_for" is a confusing dumb
80s term lifted from the ICCCM spec, just rename it.
src/wayland/meta-wayland-surface.c | 8 ++++----
src/wayland/protocol/xdg-shell.xml | 5 +----
2 files changed, 5 insertions(+), 8 deletions(-)
---
diff --git a/src/wayland/meta-wayland-surface.c b/src/wayland/meta-wayland-surface.c
index 2a2830f..3a2018f 100644
--- a/src/wayland/meta-wayland-surface.c
+++ b/src/wayland/meta-wayland-surface.c
@@ -707,9 +707,9 @@ xdg_surface_destroy (struct wl_client *client,
}
static void
-xdg_surface_set_transient_for (struct wl_client *client,
- struct wl_resource *resource,
- struct wl_resource *parent_resource)
+xdg_surface_set_parent (struct wl_client *client,
+ struct wl_resource *resource,
+ struct wl_resource *parent_resource)
{
MetaWaylandSurface *surface = wl_resource_get_user_data (resource);
MetaWindow *transient_for = NULL;
@@ -905,7 +905,7 @@ xdg_surface_set_minimized (struct wl_client *client,
static const struct xdg_surface_interface meta_wayland_xdg_surface_interface = {
xdg_surface_destroy,
- xdg_surface_set_transient_for,
+ xdg_surface_set_parent,
xdg_surface_set_margin,
xdg_surface_set_title,
xdg_surface_set_app_id,
diff --git a/src/wayland/protocol/xdg-shell.xml b/src/wayland/protocol/xdg-shell.xml
index 79a2831..7882693 100644
--- a/src/wayland/protocol/xdg-shell.xml
+++ b/src/wayland/protocol/xdg-shell.xml
@@ -137,11 +137,8 @@
</description>
</request>
- <request name="set_transient_for">
+ <request name="set_parent">
<description summary="surface is a child of another surface">
- Setting a surface as transient of another means that it is child
- of another surface.
-
Child surfaces are stacked above their parents, and will be
unmapped if the parent is unmapped too. They should not appear
on task bars and alt+tab.
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]