[gstreamermm] (167 commits) ...removed code, which might be generated (patch published here: https://bugzilla.gnome.org/show_bug.cg



Summary of changes:

  cd5dded... fixed BufferFormatType - renamed to AudioRingBufferFormatTy
  bb6c31c... removed BufferFormat enum type, format member from AudioRin
  a6044d1... fixed audiofilter class, still AudioInfo missing
  3a069b7... minor
  3091a29... added a part-implementation of AudioFormatInfo class
  be17c25... fixed audiofilter class
  c4069d9... audioringbufferspec class improved
  9aa60e2... removed unnecessary functions, fixed commit-callback method
  1f007e5... renamed old-style name gst_ring_buffer to gst_audio_ring_bu
  e0a2198... renamed baseaudio to audiobase
  c6fac72... renamed GstRingBufferSpec to GstAudioRingBufferSpec
  4856a14... renamed Gst::RingBufferSpec to Gst::AudioRingBufferSpec
  f1d3b98... some minor fixes in build (includes, types)
  2abaa2a... fixed audiosrc
  50b7417... fixed bufferlist
  36740d7... fixed basesink, basesrc, glib::wrap instead of gst::wrap
  5ae9297... temporary(?) removed lock/unlock methods
  3134087... fixed basetransform class
  0f1ba92... fixed buffer, bin, iterator
  53856f0... minors in bufferlist
  84053dd... fixed bus
  380fc55... fixed caps
  ee21d3a... we are using GStreamer 1.0.8, not 1.1.1
  1beed47... Don't wrap plugins for now, focus on gstreamer core and lib
  5ee32db... update types and includes in generator's hardcoded lists
  8635001... enums patch fixed to match GStreamer 1.0 (not 1.1)
  06d01a0... query and event enums fixed
  61a4fbb... audiobase{sink,src} compiles
  fe8fd44... generate_methods.sh script should work even if "h2def" is n
  af4db06... gst_methods fixed (1.0.8 vs 1.1.1)
  461b5b7... cddabasesrc disabled for now (it is in plugins-bad)
  d594a63... removed old method wrappers from buffer
  56aa4bf... include convert_glibmm.m4 since we'll need conversion of GO
  0b5761e... signals and methods regenerated (signals patch still fails)
  0088062... childproxy renewed
  efa2dbf... some fixes in clock
  a7c1445... colorbanace[channel].hg was moved to another directory. Inc
  2de7a14... disabled colorbalance[channel].hg
  42eb4dc... solved problems with discovererinfo
  6cf8b4f... minor
  a1f57f7... removed some functions from element
  e6f27dd... removed some bad-building methods from event, probably it s
  23544ab... removed deprecated files
  9e166fe...  removed deprecated interface files
  2ab9f5b... temporary fixed messaeg
  5837512... mixer[track] fixed
  7925d22... fixed problems with Message - previous commit didn't solve 
  40cfffe... fixed miniobject class
  99e5071... temporary disabled mixer
  8a44774... improved include statements
  c76c334... fixed object class
  1951b83... removed deprecated methods from pad
  02831b9... removed propertyprobe - not implemented in gstreamer1.0 yet
  518421a... fixed query class
  6137810... minor fixes, temporary disabled streamvolume class
  6491e2c... structure class repaired
  2a90cfe... fixes in tags
  f491a59... split GstTaskThreadCallbacks struct to independend variable
  4df71d5... disabled tuner
  0338f7e... minor change in typefind
  aee4a0f... minor changes in urihandler, removed some functions from va
  b7e041f... xoverlay to videooverlay renamed, minor improvements
  db84e7c... includes fixed
  b6cde1c... enabled plugins
  dd2520b... made project build-able
  296d3d5... added simple example
  6276641... appsink disabled
  e7aa548... gitignore updated
  a7a074c... [cleaning] audioringbuffer
  4628a9f... modified names audiobase* and audioringbuffer in comments
  0bb13c1... restored event methods (ported to 1.0)
  006cdbd... replaced C-type arguments to c++ types
  da62211... removed some entries in enum patch(patch for glibmm enum.pl
  5aca013... resolved wrong include dependencies in buffer
  7a43791... wrapped GstMemory
  622904f... wrapped (I think) useful methods in buffer
  85946c9... [peper0] Registration of C++ type as GType
  0505065... [peper0]added missing file
  e1a207e... [peper0]Pad::set_chain_function support prototype.
  de7ed05... [peper0] Pad::chain and Pad::push functions corrected
  b9f5150... [peper0] set_clock vfunc fixed
  f9e5e73... [peper0] plugin registering test
  1e117dd... [peper0]  gst_element_class_get_pad_template wrapped, which
  e093624... [peper0] Corrected default retval of BaseSrc::start & stop 
  be60431... [peper0] Don't copy buffer if RefPtr is empty.
  d36d878... [peper0] added some unit examples
  ea34c89... ignore list updated
  1c946ed... added wait method to basesink
  57c9224... wrapped GstSample struct
  21c1a42... added appsink plugin. appsink.{hg|ccg} as handcrafted files
  ba5ed26... enabled audioformat
  87b5822... removed "test-base-src" test - mixer removed without replac
  8a5955f... fixed test-init test
  a66ba8a... removed Interface class declaration
  5581d69... removed deprecated class ElementInterfaced
  c94cf80... fixed some tests
  9f04fe7... wrapped GstMapInfo, added simple test, implemented some met
  c083211... replaced c-style pointers with RefPtr objects
  8d2a334... fixed peper0's tests, minor changes in test-buffer-mapinfo 
  4a90ee6... moved tests to old-tests directory
  14cf449... added simple gtest unit tests
  1c6e3f5... added first gstreamermm tests
  55758b0... added Bin tests
  2fdc0e6... added taglist tests, and first fails;)
  69e763d... fixed unit test - adding/getting date from taglist. Yep... 
  1b7aa88... added tests for Structure, additional test in TagList
  c08691c... added Pad tests, temporary disabled one test in TagList tes
  0675e3f... added Caps tests
  e146b30... added tests for Bus
  eaeb3d0... added tests for pushsrc, unfortunatelly one test must be di
  4eefafb... added tests for registering plugins
  436b095... added tests for AppSrc plugin
  9fb2e12... implemented {add|remove}_probe methods in pad
  5732d65... enabled some examples (c-style of some functions for now)
  3b15234... improved {add|remove}_probe methods in pads, improved ogg_p
  548723c... minor
  a302c32... wrapped gstpadprobeinfo
  68788d8... fixed plugin hg generator - different access operator for a
  b7dca89... fixed and enabled playbin, repaired hello_world example
  85533ba... appsink as generated plugin - again. It might be done becau
  9bb313c... fixed and restor examples, minor changes in caps, pad
  332f3f4... created Makefile.am for tests (run make check to compile an
  764d7fd... plugin process already done, added some tests, connected it
  3325020... start wrapping test framework - unfortunatelly, i don't kno
  2bbdeb8... minor update in gitignore
  47ee79d... "gstcheck" module cannot be generated because of gstcheck f
  b3a2a0b... added some functions for testing
  2f70274... wrapped some query "create" methods as static methods of Qu
  244f8f8... added another test for caps
  8ddd170... added appsink test, enableda all test-plugin-* tests (yes, 
  ee96ccb... fixed test-plugin-app{sink|src} tests (stupid bug in tests)
  b295f55... added ghostpad's tests
  f593f80... added first regression test
  fb9afe1... added VideoDuration test
  828c5e0... replaced some C-functions with C++ wrappers
  dadf8a4... allowed to build chain of parameters
  1e6d99e... message's wrapper should copy object
  9e5ce60... added tests - check seeking
  80378a8... minor improvements
  e89b312... added test - create custom bin, and check how does it works
  903c551... fixed setting property method
  68202f8... minor fixes, noted by Mr Cumming
  6025cd5... replaced bad method names
  4d4e929... implemented Mr Cumming's advices - part 2
  6a4173a... fixed Buffer::create_writeable method
  2f30714... refactoring
  a3aa65c... gst_sample_get_buffer wrapped automatically
  852f7fc... added test to test-plugin-register suite - checking propert
  c008f0c... minor - removed deprecated comment. Property is installed i
  8a70061... added test - checking plugin based on a Gst::Bin
  bf8359e... Merge branch 'gst-check-wrapping'
  353d4fc... added memcmp method to buffer
  67afcc3... minor
  156fafe... added setters for timestamps
  3560ea9... build fix
  8348961... creating extra reference in gst_sample_get_buffer
  87b6860... added example with matroska, minor fix in Pad class
  d6a0a3b... wrapped necessary field in PadProbeInfo struct, fixed get_e
  ecb086a... added sample with dynamic changing pipeline
  eabc442... updated .gitignore
  5a145d3... added example
  75b969d... added missing enum value
  a933092... added new event type
  a633a4d... added is_ghost_pad method to a pad class
  6f44c14... added is_proxy_pad method to a pad class
  ee5bfdc... implemented "request_new_pad" vfunc
  53cf954... removed code, which might be generated (patch published her


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]