[libgit2-glib] Created tag 0.0.8



The unsigned tag '0.0.8' was created.

Tagger: Paolo Borelli <pborelli gnome org>
Date: Sun Nov 24 19:06:43 2013 +0100

    Tag 0.0.8

Changes since the last tag 'v0.0.6':

Ignacio Casal Quinteiro (19):
      Post release version bump
      Bind git_diff_similarity_metric
      Pass GgitDiffSimilarityMetric to GgitMergeTreeOptions
      Rename GgitDiffPatch to GgitPatch
      Rename GgitDiffList to GgitDiff
      Add GgitRemoteCbs
      Fix GgitCloneOptions to compile
      Fix include
      Rename GgitDiffRange to GgitDiffLine
      Fix Diff because of the split of Range into Hunk/Line
      Add GgitDiffHunk
      Use Hunk and Line in callbacks
      diff: remove print_compact
      diff: rename print_patch to print
      patch: free git2 allocated data with free
      diff: diff_get_patch is replaced now by patch_new_from_diff
      Bind ggit_patch_new_from_blobs
      Move GgitRemoteCallbacks type to types.h
      Minor update of the docs

Jasper Lievisse Adriaanse (1):
      Unbreak pkg-config file; some "variables" were mangled and not substituted.

Jesse van den Kieboom (58):
      Mark pathspec as null terminated array
      Properly initialize git2 diff options struct
      Add missing diff options
      Added ggit_repository_create_commit_from_oids
      Bind git_reference_has_log
      Fix getting native oid in ggit_ref_create_reflog
      Reorganize reflog
      Improved documentation for getting head
      Use time zone included in GDateTime
      Fix check for UTF-8 encoding in convert
      Fix indentation
      Bind git_diff_num_deltas
      Annotate patch and delta to be out
      Bind more GgitDiffPatch API
      Correct type for line cb
      Cast GgitDiffFormatType to underlying type
      Added missing include for strncpy
      Added force parameter to ggit_index_read
      Fix g_return with return value
      Added missing ggit-diff include in patch
      Fix ggit_patch_to_string for new name
      Fix patch_to_stream for new signature using git_diff_line
      Fix changes to reflog API no longer being based on git_reference
      Added GgitRemoteHead
      Make ggit_remote_list return an array of GgitRemoteHead
      Added missing NULL termination in array
      Implemented branch enumerator
      Do not use local includes in headers
      Rename _head_orphan to _head_unborn
      Added type conversions for enumerations
      Update enums
      Added missing includes in ggit.h
      Use same parameter names in declaration and definition
      Fix typo in header comment
      Added coverage tool
      Added ignores for cache files
      [coverage] Sort on covered
      Fix total coverage percentage
      Implement GgitRemoteCallbacks as a class
      Update walk example for new API
      Add _ggit_native_release
      Release native object for credentials
      Add API to set remote callbacks in clone options
      Explicitly cast enum values
      Use GError instead of raw git2 error codes
      Annotate @cred as out
      Move out argument to last argument
      Do not try to set workdir when repository was not created
      Correctly initialize git_remote_callbacks
      Fix clone example
      Better detection of libclang
      Chomp of newline from output for libdir
      Do not expose header length
      Make get_origin return a GgitDiffLineType
      Make get_content return a byte array
      Added ggit_patch_get_delta
      Add ggit_patch_get_hunk
      Fix walk example for new line_get_content API

Paolo Borelli (3):
      Fix const warnings
      Fix annotation syntax
      Release 0.0.8

Sindhu S (1):
      Fix patch-to-string in ggit-diff-patch.c


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]