[aisleriot] cover: Use hint-move instead of get-name.



commit d8a86f1ec90c95bd16e7391a2a6869b6111dac4e
Author: Vincent Povirk <madewokherd gmail com>
Date:   Sun May 5 14:36:47 2013 -0500

    cover: Use hint-move instead of get-name.
    
    For bug 551859.

 games/cover.scm |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)
---
diff --git a/games/cover.scm b/games/cover.scm
index 7e1b235..b8090db 100644
--- a/games/cover.scm
+++ b/games/cover.scm
@@ -83,7 +83,7 @@
         (check-suits (+ 1 slot1) (+ 2 slot1)))
        ((= (get-suit (get-top-card slot1))
            (get-suit (get-top-card slot2)))
-        (list 1 (get-name (get-top-card slot1)) (get-name (get-top-card slot2))))
+        (hint-move slot1 1 slot2))
        (#t (check-suits slot1 (+ 1 slot2)))))
 
 (define (get-hint)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]