[gimp] app: rename gimp_histogram_get_channel() to get_component()



commit 8d1cbd95d25ba2752d2d6fb38caa620bf86f531c
Author: Michael Natterer <mitch gimp org>
Date:   Tue Jun 11 21:32:08 2013 +0200

    app: rename gimp_histogram_get_channel() to get_component()
    
    Because that's what it is. It also takes a "gint component"
    (0..4) and not a "GimpHistogramChannel channel".

 app/core/gimphistogram.c               |   10 +++++-----
 app/core/gimphistogram.h               |    4 ++--
 app/operations/gimpoperationequalize.c |    2 +-
 3 files changed, 8 insertions(+), 8 deletions(-)
---
diff --git a/app/core/gimphistogram.c b/app/core/gimphistogram.c
index 37fc7d4..a403c82 100644
--- a/app/core/gimphistogram.c
+++ b/app/core/gimphistogram.c
@@ -558,16 +558,16 @@ gimp_histogram_get_value (GimpHistogram        *histogram,
 }
 
 gdouble
-gimp_histogram_get_channel (GimpHistogram        *histogram,
-                            GimpHistogramChannel  channel,
-                            gint                  bin)
+gimp_histogram_get_component (GimpHistogram *histogram,
+                              gint           component,
+                              gint           bin)
 {
   g_return_val_if_fail (GIMP_IS_HISTOGRAM (histogram), 0.0);
 
   if (histogram->priv->n_channels > 3)
-    channel++;
+    component++;
 
-  return gimp_histogram_get_value (histogram, channel, bin);
+  return gimp_histogram_get_value (histogram, component, bin);
 }
 
 gint
diff --git a/app/core/gimphistogram.h b/app/core/gimphistogram.h
index 0deb200..7f8173c 100644
--- a/app/core/gimphistogram.h
+++ b/app/core/gimphistogram.h
@@ -87,8 +87,8 @@ gdouble         gimp_histogram_get_threshold (GimpHistogram        *histogram,
 gdouble         gimp_histogram_get_value     (GimpHistogram        *histogram,
                                               GimpHistogramChannel  channel,
                                               gint                  bin);
-gdouble         gimp_histogram_get_channel   (GimpHistogram        *histogram,
-                                              GimpHistogramChannel  channel,
+gdouble         gimp_histogram_get_component (GimpHistogram        *histogram,
+                                              gint                  component,
                                               gint                  bin);
 gint            gimp_histogram_n_channels    (GimpHistogram        *histogram);
 gint            gimp_histogram_n_bins        (GimpHistogram        *histogram);
diff --git a/app/operations/gimpoperationequalize.c b/app/operations/gimpoperationequalize.c
index d0d56cf..5e4a3da 100644
--- a/app/operations/gimpoperationequalize.c
+++ b/app/operations/gimpoperationequalize.c
@@ -168,7 +168,7 @@ gimp_operation_equalize_set_property (GObject      *object,
                 {
                   gdouble histi;
 
-                  histi = gimp_histogram_get_channel (self->histogram, k, i);
+                  histi = gimp_histogram_get_component (self->histogram, k, i);
 
                   sum += histi;
 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]