[geocode-glib] Created tag 0.99.1
- From: Zeeshan Ali Khattak <zeeshanak src gnome org>
- To: commits-list gnome org
- Cc:
- Subject: [geocode-glib] Created tag 0.99.1
- Date: Tue, 30 Jul 2013 16:34:40 +0000 (UTC)
The signed tag '0.99.1' was created.
Tagger: Zeeshan Ali (Khattak) <zeeshanak gnome org>
Date: Tue Jul 30 19:34:04 2013 +0300
Release 0.99.1
Changes since the last tag '0.99.0':
Andreas Henriksson (3):
Make include directory API versioned
Unify include paths to be the same everywhere
Symlink geocode-glib.h into subdir to avoid breakage
Bastien Nocera (124):
lib: Add geocode_object_new_for_location() helper
test: Use geocode_object_new_for_location()
lib: Remove geocode_object_new() from the public API
lib: Mention the one result or nothing behaviour of the API
lib: Move application ID to be a constant
lib: geocode_object_add() is for bindings
lib: Make lookup type an enum
lib: Don't modify the user given parameters
lib: Add locale aware search results
test: Add locale based test
lib: Rename the enumeration
build: Require the stable version of json-glib
lib: Add forward geocoding search
lib: Fix memory leak in PlaceFinder JSON parser
lib: Only cache if we don't have a parsing error
test: Add search test
test: Add ability to do a search from the command-line
test: Add empty json search parser test
README: Update
TODO: Update TODO
lib: Add a way to differentiate search from resolve
lib: Tag search objects as such
lib: Fix retval of _search_finish()
lib: Implement _search_async()
TODO: Remove done item
lib: Add introspection annotation for GHashTable
lib: Add geocode_object_new_for_params_str() function
lib: Handle the "language" key from Telepathy
lib: Don't ever have a failing _new() call
lib: Add "invalid arguments" error
lib: Report invalid arguments when searching/resolving
lib: Add a way to change the lookup type
test: Add a --reverse option for reverse geocoding
lib: Fix possible use of uninitialised variable
lib: Include geocode-error.h in the main header
lib: Add simple GeocodeLocation object
lib: Remove _set_lookup_type() from private API
lib: Export the caching functions internally
lib: Add GeocodeForward
lib: Add GeocodeReverse object
lib: Small indent fix in private header
lib: Move json parsers to the objects
lib: Export function to create query
lib: Special-case the single answer query
lib: Add helper to free GeocodeLocation objects
test: First pass at using GeocodeForward
test: Use GeocodeReverse object
test: Use GeocodeForward in XEP test
test: Port pub test to GeocodeForward
test: Port interactive tests to new objects
lib: Fix long/lat parsing in some locales
lib: Add description to the result
test: Fix long/lat parsing in some locales
test: Add --count argument for forward geocoding
lib: Fix search long/lat in some locales
test: Россия means Russia, not Moscow :)
lib: Fix some results not being in the right language
test: Clean test search
test: Port locale test to GeocodeForward
test: Add test for the radix difference
lib: Remove duplicated _get_lang() functions
lib: Remove GeocodeObject
lib: Fix the coords parsing from searches
TODO: Update
docs: Add missing docs to the index
lib: Update API docs
lib: Do validation of lat/long when creating the location
docs: Link to the Unix time Wikipedia article
lib: Make the rev geocoding results use XEP attributes
lib: Add function to calculate distance between 2 locations
lib: Simplify _new_for_params() internally
lib: Print warning for unknown XEP attributes
lib: Fix GeocodeForward XEP test
README: Add mention of other web service used
tests: Load tests from external files
lib: Add debug for where cache files are saved/loaded
tests: Add GeoPlanet parsing test case
lib: Handle 0 answer count as unlimited results
lib: Use DEFAULT_ANSWER_COUNT in test
test: Add test for unlimited results in paris test case
build: Require a new enough glib
build: Bump requirements again for g_clear_pointer()
test: Fix search (aka Paris) and locale tests
TODO: Update for recent developments
lib: Use a dynamic array instead of a static one
lib: Simplify while loop for a for loop
lib: Add geocode_location_set_description() helper
lib: Use new _set_description() helper
lib: Simplify returning the value
lib: Fix memory leak looking for a single item
lib: Add woeid to the PlaceFinder results
TODO: Update for libgweather requirements
lib: Simplify while loop into a for loop
lib: Remove dead code
server: Fix pkg-config usage
server: Fix error when QUERY_STRING is not passed
server: Better error message for missing database
server: Use path from geoip.pc to locate the database
server: Coding style fixes
tests: Check for httpd on Fedora
tests: Use relative module paths by default
tests: Add some necessary modules
tests: Correct run-time directory
tests: Add the Full Monty of annoying auth modules
ipclient: Validate the server property
ipclient: Add guards for invalid server property
ip-server: Rename argument to needs_update
ip-server: Rename if_db_updated() function
lib: Simplify geocode_reverse_resolve_finish()
ip-server: geocode-update isn't a test program
build: Add test data to the dist
ip-server: Fix make check
build: Check for libm in configure
ip-server: Factor out query string for our server
lib: Fix introspection warnings
geoip-update: Remove linefeed in attribution text
lib: Fix compile-time warning
ip-server: Use enum instead of int in parameters
ip-server: Use switch statement to print error messages
ip-server: Better error message for Invalid IP addresses
lib: Use g_simple_async_result_take_error()
lib: Simplify a few exit paths
lib: Simplify geocode_forward_search_finish()
Revert "Symlink geocode-glib.h into subdir to avoid breakage"
Javier Jardón (5):
Update autotools configuration
Use upstream gettext instead the glib one
configure.ac: Fix typo
Remove unneded dependency on gnome-doc-utils
Do not call g_type_init() if GLib >= 2.36
Matthew Barnes (1):
Bump version to 0.99.1.
Ryan Lortie (1):
geocode-glib: fix installation of headers
Satabdi Das (23):
lib: Create a better description for search results
server: Add GeoIP server
server: Handle requests coming from proxies better
server: Remove unnecessary error messages
server: Move print_error_in_json()
server: Add support for the country-only database
server: Add a stop/start script
ipclient: Add IP Geocoding client
server: Coding style fixes
server: Add status key to the JSON output
tests: Check the status of the request in the JSON output
server: Error out if IP address in query is invalid
script: Make a soft link of the server in cgi-bin/
server script: Set a server side proxy variable
ipclient: Add gtk-doc annotations
server: change GEOIP_DATABASE_PATH env variable
ipclient: Add server URI as a property
ip-server: Add country and city DB updater
test-geoip: Fix test function for IP based search
ipclient: Coding style fix
ipclient: Fix memory leak
ip-server: Add support for Wi-Fi based search
geoip-update: Handle blank option
Zeeshan Ali (Khattak) (45):
lib: Correct docs/annotation for geocode_forward_search*
build: Specify main header in gir file
pkg-config: Version the pkg-config file
lib: Add missing header to main header
geoip-update: Honor DB path variables
lib: Add error code for internal server errors
server: Put server errors into a separate header
lib: Return a location from geocode_ipclient_search()
lib: Use glib-mkenums to register enums with glib
Add a missing '\'
Add testcases for _geocode_ip_json_to_location()
Add testcases for _geocode_ip_json_to_location()
geoip-lookup: Use same JSON format as other free services
geoip-lookup: Update error JSON format
Add testcase for our & freegeoip JSON formats
Revert "Add testcases for _geocode_ip_json_to_location()"
lib: Minor coding-style fixes
lib: Report accuracy of location result(s)
lib: Turn GeocodeLocation into a proper GObject
lib: Add GeocodeIpclient:compatibility-mode property
lib: Slightly improved accuracy estimates
lib: Add myself to authors list
lib: Add missing EOL
lib: Introducing GeocodePlace class
lib: geocode_forward_search*() returns places
lib: Make use of g_clear_pointer()
lib: Use libsoup directly for HTTP GET requests
lib: Port reverse geocoding API to Nominatim
place: Add more properties
lib: Make GeocodePlace:name writable
lib: Fix a typo in a doc comment
lib: Compare against the correct values
lib: Adapt GeocodePlace for Nominatim
lib: Port forward geocoding API to Nominatim
lib: Remove remaining references to Yahoo Places API
lib: Separate function to determine place type
lib: One dedicated function to create GeocodePlace object
lib: Export create_place_from_attributes library-wide
lib: Add new place getter/setters to symbols file
lib: geocode_reverse_resolve*() now returns GeocodePlace
lib: Remove now redundant code
lib: Remove now redundant macros
lib: Update list of test data files
Disable client-side geoip test for now
Release 0.99.1
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]