[mutter] window-actor: Rename variable in scanning function



commit 95f3bb3b818e6db78fb10f787b13bc30f2ef6a9c
Author: Jasper St. Pierre <jstpierre mecheye net>
Date:   Wed Jan 16 10:14:40 2013 -0500

    window-actor: Rename variable in scanning function
    
    "w" usually stands for "width", but here it stands for the end X bound,
    so we'll rename it to the more traditional "x2".
    
    https://bugzilla.gnome.org/show_bug.cgi?id=691874

 src/compositor/meta-window-actor.c |   12 ++++++------
 1 files changed, 6 insertions(+), 6 deletions(-)
---
diff --git a/src/compositor/meta-window-actor.c b/src/compositor/meta-window-actor.c
index 2c33b2e..05acb53 100644
--- a/src/compositor/meta-window-actor.c
+++ b/src/compositor/meta-window-actor.c
@@ -2113,14 +2113,14 @@ scan_visible_region (guchar         *mask_data,
         {
           for (x = rect.x; x < (rect.x + rect.width); x++)
             {
-              int w = x;
-              while (mask_data[y * stride + w] == 255 && w < (rect.x + rect.width))
-                w++;
+              int x2 = x;
+              while (mask_data[y * stride + x2] == 255 && x2 < (rect.x + rect.width))
+                x2++;
 
-              if (w > 0)
+              if (x2 > 0)
                 {
-                  meta_region_builder_add_rectangle (&builder, x, y, w - x, 1);
-                  x = w;
+                  meta_region_builder_add_rectangle (&builder, x, y, x2 - x, 1);
+                  x = x2;
                 }
             }
         }



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]