[gtk+] Created tag 3.7.6

The unsigned tag '3.7.6' was created.

Tagger: Matthias Clasen <mclasen redhat com>
Date: Tue Jan 15 00:37:01 2013 -0500


Changes since the last tag '3.7.4':

Alexander Larsson (39):
      broadway: Separate out the server parts
      broadway: Remove separate browser windows hack
      broadway: Fix possible access-after-free
      broadway: Allow reconnecting to a broadway page
      broadway: Use SOURCE operator when scrolling
      broadway: Break out broadway protocol in its own header
      broadway: Add enum for even types
      broadway: Add OPs top protocol
      broadway: Initial version of separate broadway server
      broadway: disconnect in idle when needed
      broadway: rename broadway.[ch] to broadway-output.[ch]
      broadway: Drop libbroadway.la
      broadway: rename broadway-server to broadwayd
      broadway: Rename gdkbroadway-server.c to broadway-server.c
      broadway: Track windows for client and kill on client exit
      broadway: Collect and document some TODOs
      broadway: Proper handling of http port and display nr
      broadway: Make daemon side server "gdk independent".
      broadway: During pointer grabs, send pointer events only to one client
      broadway: Move broadwayd to bin
      broadway: Add TODO.broadway
      broadway: Stop default mouse button handling
      broadway: Make resize grip work again
      broadway: Rename gdkbroadway-server-client.c to gdkbroadway-server.c
      broadway: Handle NULL surface in update
      broadway: Remove last_serial from BroadwayReplyBase
      broadway: Rewrite serials for clients
      broadway: Clean up broadwayd event sending code
      broadway: Fix gdk_broadway_server_wait_for_reply
      broadway: Make the InputMessage type a uint32
      broadway: Move window position ownership to browser
      broadway: Don't allow dragging windows above top of window
      broadway: Send window size to new clients
      broadway: Update TODO
      broadway: We need gio-unix for the unix domain sockets
      broadway: Remove leftover typedef
      broadway: Allow binding http server to an ip
      broadway: Make Sec-WebSocket-Origin optional
      broadway: Make /dev/shm names nicer

Alexander Shopov (2):
      Updated Bulgarian translation
      Updated Bulgarian translation

Andrew Potter (1):
      GtkApplication: properly unexport x11 menus

Arash Mousavi (1):
      l10n: Updated Persian translation

Aurimas Äernius (1):
      Updated Lithuanian translation

BalÃzs Ãr (1):
      Updated Hungarian translation

Baurzhan Muftakhidinov (2):
      Updated Kazakh translation
      Updated Kazakh translation

Benjamin Otte (27):
      API: Add state flags for RTL and LTR
      css: Parse and print the new state flags
      widget: Set state flags for direction
      stylecontext: Use state flags for direction
      stylecontext: Deprecate direction property
      box: Don't special-case RTL hbox child positions anymore
      toolbar: Don't special-case RTL toolbar child positions anymore
      combobox: Don't special-case RTL child positions anymore
      testgtk: Remove GtkAlignment usage from progressbar test
      roundedbox: Fix copy-paste error
      progressbar: Remove activity_step from private struct
      progressbar: Store activity position as percentage
      widget: Remove underscore prefix from static function
      menu: Huh?
      widget: Fix state propagation code
      widget: Fix initial state flags for RTL
      stylecontext: Make font hack not crash
      tests: return 0; from main()
      tests: Don't use unicode escapes
      sizerequest: Make invisible widgets return a 0x0 size.
      treeviewcolumn: Show button if we're visible
      widget: Give some meaning to "visible"
      widget: Remove leftover debug statement
      x11: unconst-cast result of g_get_prgname()
      a11y: Implement get_name() instead of setting variables
      window: Don't use set_allocation() to store cached values
      scrolledwindow: Use child-visible instead of visible for scrollbars

Cosimo Cecchi (2):
      aboutdialog: ensure the credits page uses the "view" style class
      range: don't trim the trough rectange by the trough margin

Duarte Loreto (2):
      Updated Portuguese translation and converted to New Spelling (Novo AO)
      Updated Portuguese translation and converted to New Spelling (Novo AO)

Fabian Henze (1):
      Fix the annotations of gtk_color_chooser_get_rgba()

Fran DiÃguez (2):
      Updated Galician translations
      Updated Galician translations

Gabor Kelemen (1):
      Updated Hungarian translation

Geoff Reedy (1):
      x11: add missing checks that a hint is supported

Gheyret Kenji (1):
      Updated Uyghur translation

Javier JardÃn (1):
      docs: Use gtk-doc-check in make check

Khaled Hosny (1):

Kjartan Maraas (5):
      Updated Norwegian bokmÃl translation
      Updated Norwegian bokmÃl translation
      Updated Norwegian bokmÃl translation
      Updated Norwegian bokmÃl translation
      Updated Norwegian bokmÃl translation

Matej UrbanÄiÄ (2):
      Updated Slovenian translation
      Updated Slovenian translation

Matthias Clasen (25):
      bump version
      Trivial sorting fix
      Make accessible implementations public
      Some renaming
      Rename and clean up gailutil
      More gail removal
      Fix inter-header includes
      Add single-include guards to a11y headers
      Install a11y headers
      Install gtk-a11y.h
      Add a test for deriving accessible implementations
      Drop separate scrollbar accessible implementation
      Rename gtkcolorswatchaccessible.h
      Another trivial sorting fix
      docs: Restart a Deprecated section
      Move single-include guards inside include guards
      Typo fix
      Documentation fixes
      Remove some non-warranted checks from builder tests
      Update expected output of a11y tests
      Remove a no-longer existing symbol
      Don't run gtkdoc-check in make check
      Ignore more private headers when generating docs

Mattias PÃldaru (1):
      [l10n] Updated Estonian translation

Murray Cumming (1):
      iconhelper: treat the empty string as a NULL stock-id

Nicola Fontana (1):
      configure.ac: fix autoreconf with automake-1.13

Nilamdyuti Goswami (1):
      Assamese translation updated

Paolo Borelli (2):
      Paint GtkFrame background
      Paint GtkFrame background correctly when there is a label

Ross Burton (1):
      build: support cross-compilation by natively building gtk-update-icon-cache

RÅdolfs Mazurs (1):
      Updated Latvian translation

Shantha kumar (2):
      Tamil translation updated
      Tamil translation updated

Theppitak Karoonboonyanan (1):
      Updated Thai translation

Tristan Brindle (1):
      Add missing annotation for gtk_combo_box_text_get_active_text()

Volker Sobek (1):
      docs: fix typo in gtkbuildable

William Jon McCann (1):
      Use Website instead of Homepage

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]